Bug 6562 - Reserve request generates unnecessary runtime errors
Summary: Reserve request generates unnecessary runtime errors
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Architecture, internals, and plumbing (show other bugs)
Version: master
Hardware: All All
: PATCH-Sent (DO NOT USE) minor (vote)
Assignee: Colin Campbell
QA Contact: Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-07-07 11:32 UTC by Colin Campbell
Modified: 2012-10-25 23:10 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Text to go in the release notes:
Version(s) released in:


Attachments
Proposed Patch (768 bytes, patch)
2011-07-07 11:36 UTC, Colin Campbell
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Colin Campbell 2011-07-07 11:32:29 UTC
Because the script action is directed by 'action' but is initially called with action undefined it fills the log with noise.
Assign a suitable falsy value to action if undefined so that we can use the error logs more efficiently.
script is a prime candidate for refactoring if anyone has the time as its over complex and slow
Comment 1 Colin Campbell 2011-07-07 11:36:26 UTC
Created attachment 4575 [details] [review]
Proposed Patch
Comment 2 Christophe Croullebois 2011-08-05 10:30:14 UTC
ok
Comment 3 Ian Walls 2011-08-25 02:03:21 UTC
One-liner patch that provides a default value to a potentially undefined variable.  No chance of regression here.  Marking as Passed QA.
Comment 4 Chris Cormack 2011-08-25 23:26:05 UTC
Pushed please test
Comment 5 Chris Nighswonger 2011-10-26 18:02:23 UTC
The fix for this bug was published in the 3.4.5 release. If you were the reporter of this bug, please take time to verify the fix and update the status of this bug report accordingly. If the bug is fixed to your satisfaction, please close this report.