Bug 6574 - js error in en-GB template breaks circulation toolbar
Summary: js error in en-GB template breaks circulation toolbar
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: I18N/L10N (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Liz Rea
QA Contact: Jonathan Druart
URL:
Keywords:
: 7109 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-07-11 15:35 UTC by Emrys Minnig
Modified: 2014-05-26 21:04 UTC (History)
6 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 6574 - js error in en-GB template breaks circulation toolbar (2.60 KB, patch)
2012-12-03 01:32 UTC, Liz Rea
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 6574 - js error in en-GB template breaks circulation toolbar (2.70 KB, patch)
2012-12-10 20:44 UTC, Katrin Fischer
Details | Diff | Splinter Review
Bug 6574 - js error in en-GB template breaks circulation toolbar (2.77 KB, patch)
2012-12-26 14:51 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 6574 - js error in en-GB and en-NZ translations due to improper quoting (1.79 KB, patch)
2012-12-28 00:27 UTC, Liz Rea
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 6574 - js error in en-GB and en-NZ translations due to improper quoting (1.90 KB, patch)
2012-12-28 16:36 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 6574 - js error in en-GB and en-NZ translations due to improper quoting (1.91 KB, patch)
2013-01-14 11:32 UTC, Jonathan Druart
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Emrys Minnig 2011-07-11 15:35:18 UTC
Line 20 of internet-tmpl/prog/en-GB/circ-toolbar.inc AND
line 20 of internet-tmpl/prog/en-GB/members-toolbar.inc read:

var is_confirmed = window.confirm(_('Are you sure you want to renew this user\\'s registration?'));

It should read:

var is_confirmed = window.confirm(_('Are you sure you want to renew this user\'s registration?'));


This bug causes the buttons on the patron's 'circ' and 'details' pages to not display properly.  Further, as a result, the 'Delete' button will not work.

I'm not sure if this error appears in the templates for other languages.
Comment 1 Owen Leonard 2011-07-11 16:20:16 UTC
Confirmed in a freshly-processed installation of en-GB and en-NZ translations.
Comment 2 Owen Leonard 2011-12-07 17:02:10 UTC
*** Bug 7109 has been marked as a duplicate of this bug. ***
Comment 3 Liz Rea 2012-11-30 01:42:52 UTC
I also confirm this bug ib en-NZ
Comment 4 Liz Rea 2012-11-30 02:19:20 UTC
The same issue is found in moremember.tt.
Comment 5 Katrin Fischer 2012-11-30 07:18:17 UTC
Using double quites instead of single quotes is currently the most used fix for this. It prevents translators from using double quotes in translations, but single quotes are more often used in a lot of languages. 

In the past I had problems with escaping in Pootle - \n was changed to \\n (double escaped) automatically. So I think not using escaping is safer.
Comment 6 Liz Rea 2012-12-03 01:32:21 UTC Comment hidden (obsolete)
Comment 7 Liz Rea 2012-12-03 03:55:12 UTC
I'm not really clear on how translations get from template -> pootle -> misc/translator/po -- there may be a step in testing necessary for that (like, grabbing the new .po from translate.koha-community.org or somesuch).
Comment 8 Katrin Fischer 2012-12-10 20:44:09 UTC Comment hidden (obsolete)
Comment 9 Jonathan Druart 2012-12-26 14:50:46 UTC
QA Comments:

I did not test this patch, but it does not break anything and is in agreement with the result of the discussion of Bug 6574.

Marked as Passed QA.

Jared, this patch will be in conflict with Bug 6261. So I advice you to apply the patch of Bug 6261 before this one.
Comment 10 Jonathan Druart 2012-12-26 14:51:40 UTC Comment hidden (obsolete)
Comment 11 Jared Camins-Esakov 2012-12-27 23:57:00 UTC
I believe this patch is unnecessary now that bug 6261 has been pushed. Could you please confirm that?
Comment 12 Liz Rea 2012-12-28 00:27:16 UTC Comment hidden (obsolete)
Comment 13 Liz Rea 2012-12-28 00:28:32 UTC
This last patch is based on the work of 6261, which was just pushed. It'll need a new signoff.
Comment 14 Owen Leonard 2012-12-28 16:36:15 UTC Comment hidden (obsolete)
Comment 15 Jonathan Druart 2013-01-14 11:31:44 UTC
QA Comment:

Same as comment 9

Marked as Passed QA.
Comment 16 Jonathan Druart 2013-01-14 11:32:14 UTC
Created attachment 14560 [details] [review]
Bug 6574 - js error in en-GB and en-NZ translations due to improper quoting

To replicate:

* install en-NZ translation (or en-GB)
* activate the new language, and select it for use
* pretend you are going to issue a book to a member (search for a member from "check out" in header)
* without the patch, the toolbar will be incorrect. The toolbar will also be incorrect on moremember.pl.

To test:
* apply the patch
* re-generate the en-NZ or en-GB translation
* activate the new language, or select it for use
* pretend you are going to issue a book to a member (search for a member from "check out" in header)
* with the patch, the toolbar will appear to be correct. It will also be correct on moremember.pl.

Signed-off-by: Owen Leonard <oleonard@myacpl.org>
Signed-off-by: Jonathan Druart <jonathan.druart@biblibre.com>
Comment 17 Jared Camins-Esakov 2013-01-15 04:17:05 UTC
This patch has been pushed to master.
Comment 18 Chris Cormack 2013-01-15 05:02:25 UTC
Pushed to 3.10.x and 3.8.x will be in 3.10.2 and 3.8.9