Bug 6645 - attaching items loses hold
Summary: attaching items loses hold
Status: RESOLVED DUPLICATE of bug 8723
Alias: None
Product: Koha
Classification: Unclassified
Component: Cataloging (show other bugs)
Version: master
Hardware: All All
: P5 - low major (vote)
Assignee: Galen Charlton
QA Contact: Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-07-28 22:24 UTC by Nicole C. Engard
Modified: 2013-08-13 20:00 UTC (History)
2 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nicole C. Engard 2011-07-28 22:24:21 UTC
If you have an item with an item specific hold on it on one bib record and you use the 'attach item' function to move it to another bib record the hold does not transfer to the new bib record, but if the item was waiting the waiting note remains on the item.  It sounds like the bibnumber isn't changing in the reserves table, and so the hold is listed on the wrong bib but the right item.
Comment 1 Liz Rea 2012-02-08 18:24:46 UTC
a derivative of this is when you move an item from one bib to another, and the item has a hold waiting, filling/completing the hold doesn't remove the reserve, because the reserve is still attached to the old biblionumber.
Comment 2 Liz Rea 2012-02-08 18:25:27 UTC
That is to say, I confirm this bug.
Comment 3 Owen Leonard 2013-08-13 20:00:23 UTC

*** This bug has been marked as a duplicate of bug 8723 ***