Bug 6649 - Error when editing the help screens.
Summary: Error when editing the help screens.
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Architecture, internals, and plumbing (show other bugs)
Version: 3.4
Hardware: All All
: PATCH-Sent (DO NOT USE) minor (vote)
Assignee: Frédéric Demians
QA Contact: Bugs List
URL:
Keywords:
Depends on:
Blocks: 5917 6884
  Show dependency treegraph
 
Reported: 2011-07-29 21:15 UTC by Joy Nelson
Modified: 2012-10-25 23:09 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Proposed patch (3.60 KB, patch)
2011-09-17 07:22 UTC, Frédéric Demians
Details | Diff | Splinter Review
Proposed patch (3.55 KB, patch)
2011-09-17 07:25 UTC, Frédéric Demians
Details | Diff | Splinter Review
Proposed patch (6.03 KB, patch)
2011-09-17 07:35 UTC, Frédéric Demians
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 6649 Allow help screens editing (6.22 KB, patch)
2011-09-20 06:40 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Joy Nelson 2011-07-29 21:15:25 UTC
Clicking on Edit Help results in an error message:

Cannot read file: '/home/koha/kohaclone/koha-tmpl/intranet-tmpl/prog/en/modules/help/.tmpl'.

Replication:
Staff Interface, click on ? in upper right
Scroll to bottom of the screen in the popup
Click on Edit Help
Error appears at the top.
Comment 1 Owen Leonard 2011-08-08 18:26:12 UTC
I can reproduce this bug, but it's not a template error. edithelp.pl looks like it hasn't been updated to work with Template:Toolkit. Still lots of references to TMPL.
Comment 2 Frédéric Demians 2011-09-17 07:22:44 UTC Comment hidden (obsolete)
Comment 3 Frédéric Demians 2011-09-17 07:25:46 UTC Comment hidden (obsolete)
Comment 4 Frédéric Demians 2011-09-17 07:35:43 UTC Comment hidden (obsolete)
Comment 5 Katrin Fischer 2011-09-20 06:40:58 UTC
Created attachment 5472 [details] [review]
[SIGNED-OFF] Bug 6649 Allow help screens editing

edithelp.pl hadn't been updated to allow help screen editing.

Signed-off-by: Katrin Fischer <Katrin.Fischer.83@web.de>

Only a note: Apparently you need to be 'superlibrarian' permission
to edit help pages.
Comment 6 Chris Cormack 2011-09-25 22:27:50 UTC
Fix works well, pushed
Comment 7 Katrin Fischer 2011-10-07 06:02:04 UTC
Successfully tested on current master.