Bug 6697 - Empty Organisation(s) field for organisational patrons
Summary: Empty Organisation(s) field for organisational patrons
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Templates (show other bugs)
Version: master
Hardware: All All
: P5 - low minor (vote)
Assignee: Owen Leonard
QA Contact: Bugs List
URL: /cgi-bin/koha/members/memberentry.pl?...
Keywords:
: 5664 (view as bug list)
Depends on: 6712
Blocks: 7207
  Show dependency treegraph
 
Reported: 2011-08-10 12:03 UTC by Katrin Fischer
Modified: 2014-05-26 21:04 UTC (History)
2 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Documentation contact:
Documentation submission:
Text to go in the release notes:
Version(s) released in:


Attachments
screenshot (5.57 KB, image/png)
2011-08-10 12:03 UTC, Katrin Fischer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Katrin Fischer 2011-08-10 12:03:49 UTC
Created attachment 4930 [details]
screenshot

When adding or modifying a patron with a patron category that is type 'organisation' an additioanl fieldset 'Organisation' with an empty field 'Organisation(s)' is displayed in the patron record.

I see no way to make use of this.

I linked a professional patron to my organisation, but the field stayed empty.
I tried adding a second organisation, but the field still stayed empty.

There is currently no way to link orgaisational patrons together in hierarchies - so why should we display a list of organisations there?

Perhaps this is a leftover from an earlier feature. As it seems not to be working it should be removed. And if there is a trick to make it work it should be documented.
Comment 1 Owen Leonard 2011-08-10 18:49:22 UTC
*** Bug 5664 has been marked as a duplicate of this bug. ***
Comment 2 Katrin Fischer 2011-08-14 13:33:01 UTC
Display problem fixed by patch for bug 6712 - underlying feature is currently broken and waits for reimplementation.
Comment 3 MJ Ray (software.coop) 2012-04-03 17:06:04 UTC
How should it work?

Is this about having patrons grouped into organisations grouped into institutions, or is it about having patrons grouped into institutions grouped into a hierarchy of organisations?

How was it broken? Just by not feeding the organisations to the template? As bug 6712 hid the feature, I'm not sure that I can test it easily.
Comment 4 Owen Leonard 2013-08-12 16:53:17 UTC
If the display problem is fixed, isn't this bug fixed? If there is functionality which hasn't been implemented that belongs in another bug.