Bug 6857 - Show a warning if placing a reserve will incur a cost
Summary: Show a warning if placing a reserve will incur a cost
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: OPAC (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Robin Sheat
QA Contact: Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-09-08 06:33 UTC by Robin Sheat
Modified: 2013-12-05 20:01 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 6857: display a charge warning alert for reserves (3.42 KB, patch)
2011-09-08 06:35 UTC, Robin Sheat
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 6857: display a charge warning alert for reserves (3.50 KB, patch)
2011-09-09 19:01 UTC, Nicole C. Engard
Details | Diff | Splinter Review
Follow up to Bug 6857: Change language from 'reserve' to 'hold' (1.11 KB, patch)
2011-09-09 19:05 UTC, Nicole C. Engard
Details | Diff | Splinter Review
Follow up to Bug 6857: Change language from 'reserve' to 'hold' (1.26 KB, patch)
2011-09-09 19:11 UTC, Nicole C. Engard
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Robin Sheat 2011-09-08 06:33:08 UTC
When placing a reserve via the OPAC, we should tell the user if this is going to cost them.
Comment 1 Robin Sheat 2011-09-08 06:35:07 UTC Comment hidden (obsolete)
Comment 2 Nicole C. Engard 2011-09-08 14:15:39 UTC
How do I test this?  I have an item type with a rental charge and I placed a hold on that item type and no warning appeared telling me that I was going to be charged the rental fee. So I'm wondering what cost we're talking about.

Nicole
Comment 3 Robin Sheat 2011-09-08 23:59:51 UTC
Oh, I forgot to squash two patches. The former being the syspref that turns this on. Let me try that again...
Comment 4 Robin Sheat 2011-09-09 02:51:04 UTC
Oh, I was wrong about the syspref thing, was looking at the wrong branch. 

The issue is that it applies to reserves, not rental charges.
Comment 5 Nicole C. Engard 2011-09-09 15:28:10 UTC
What reserve has a fee associated with it? Where do I set a fee associated with a hold?  The only fee I know of is if the item is overdue or if the item has a rental charge.
Comment 6 Katrin Fischer 2011-09-09 16:14:19 UTC
Hi Nicole, 
hold fees can be set for borrower category types. 
Something else that would be nice to have in circ matrix :)
Comment 7 Nicole C. Engard 2011-09-09 18:58:41 UTC
a sign that i'm just way way way too braindead!  Off to retest.
Comment 8 Nicole C. Engard 2011-09-09 19:01:21 UTC
Created attachment 5390 [details] [review]
[SIGNED-OFF] Bug 6857: display a charge warning alert for reserves

If a user is placing a reserve on the OPAC, this'll let them know that
it's going to cost them.

Author: Chris Cormack <chrisc@catalyst.net.nz>
Signed-off-by: Nicole C. Engard <nengard@bywatersolutions.com>
Comment 9 Nicole C. Engard 2011-09-09 19:05:56 UTC Comment hidden (obsolete)
Comment 10 Nicole C. Engard 2011-09-09 19:06:27 UTC
Original patch signed off, follow up needs a sign off though.
Comment 11 Ian Walls 2011-09-09 19:07:24 UTC
Sorry to be a pain, but the <div> in the template for this message needs to have an ID so that it's content can be altered easily with JQuery (for any libraries who may not want this exact message to be displayed).

Marking as Failed QA until 'id=reserve_fee' is added.
Comment 12 Nicole C. Engard 2011-09-09 19:09:39 UTC
i'll add that to my follow up.
Comment 13 Nicole C. Engard 2011-09-09 19:11:41 UTC
Created attachment 5392 [details] [review]
Follow up to Bug 6857: Change language from 'reserve' to 'hold'

Reserves are called holds all throughout the OPAC so this follow up
updates the language in this patch to match the standard.

Also adds an id tag to the message for altering with JQuery.

Signed-off-by: Nicole C. Engard <nengard@bywatersolutions.com>
Comment 14 Nicole C. Engard 2011-09-09 19:12:27 UTC
follow up includes the ID tag, so first patch is still signed off and follow up needs sign off.
Comment 15 Ian Walls 2011-09-09 19:36:20 UTC
Thank you, Nicole.  Signing off on your followup, and marking both patches as Passed QA.
Comment 16 Chris Cormack 2011-09-11 09:37:47 UTC
Pushed, please test