Bug 6933 - Add a view of titles with a particular tag to the staff client
Summary: Add a view of titles with a particular tag to the staff client
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Staff Client (show other bugs)
Version: 3.8
Hardware: All All
: P3 enhancement (vote)
Assignee: Owen Leonard
QA Contact: Bugs List
URL:
Keywords:
: 8118 (view as bug list)
Depends on:
Blocks: 4134
  Show dependency treegraph
 
Reported: 2011-09-28 20:21 UTC by Owen Leonard
Modified: 2014-05-26 21:04 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Proposed fix (11.96 KB, patch)
2011-10-20 15:58 UTC, Owen Leonard
Details | Diff | Splinter Review
Approved tags on staff client detail (28.09 KB, image/png)
2011-10-20 16:08 UTC, Owen Leonard
Details
Tags summary links to titles by tag view (26.16 KB, image/png)
2011-10-20 16:09 UTC, Owen Leonard
Details
Titles by tag view (28.73 KB, image/png)
2011-10-20 16:10 UTC, Owen Leonard
Details
Having trouble seeing tags. (37.48 KB, image/png)
2011-12-15 03:08 UTC, Duncan
Details
Follow-up fix adds output to XSLT view (13.06 KB, patch)
2011-12-15 18:35 UTC, Owen Leonard
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 6933 [REVISED] Add a view of titles with a particular tag to the staff client (13.09 KB, patch)
2011-12-15 19:25 UTC, Nicole C. Engard
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Owen Leonard 2011-09-28 20:21:29 UTC
When looking at tags in the tag review interface (/cgi-bin/koha/tags/review.pl) it should be possible to click on any tag and see a list of titles which have been tagged with that term. From this list it should also be possible to remove a tag from a particular title.
Comment 1 Owen Leonard 2011-10-20 15:58:41 UTC Comment hidden (obsolete)
Comment 2 Owen Leonard 2011-10-20 16:08:45 UTC
Created attachment 6009 [details]
Approved tags on staff client detail
Comment 3 Owen Leonard 2011-10-20 16:09:39 UTC
Created attachment 6010 [details]
Tags summary links to titles by tag view
Comment 4 Owen Leonard 2011-10-20 16:10:02 UTC
Created attachment 6011 [details]
Titles by tag view
Comment 5 Paul Poulain 2011-10-24 11:38:11 UTC
Updating Version : This ENH will be for Koha 3.8
Comment 6 Paul Poulain 2011-10-25 15:05:45 UTC
Bug versionned for master. entries will be made against rel_3_8 once the patch has been applied (see thread about that on koha-devel yesterday)
Comment 7 Duncan 2011-12-15 03:08:37 UTC
Created attachment 6798 [details]
Having trouble seeing tags.

I have made a few tags in the OPAC view attached to a few different items but am unable to see them attached in the view like the example picture in my staff client. Is there some option to enable somewhere? I have currently enabled pretty much everything that is related to tags in the system preferences that I could find.
Comment 8 Owen Leonard 2011-12-15 18:35:41 UTC Comment hidden (obsolete)
Comment 9 Nicole C. Engard 2011-12-15 19:25:16 UTC
Created attachment 6818 [details] [review]
[SIGNED-OFF] Bug 6933 [REVISED] Add a view of titles with a particular tag to the staff client

- Adds a new page to the tags moderation section for viewing all the
  titles tagged with a particular term.
- Adds display of approved tags to the catalog detail page matching the opac
  view. Adding tags from the detail view not implemented.

Follow-up adds tags display to XSLT detail view

Areas for improvement:

- I think it would be better to show "Also tagged with:" and exclude
  the current tag from the list of titles tagged with a particular tag.
- It would be nice to be able to show unapproved tags (and some idication of
  their status) along with approved tags on the detail page if the user had
  TagsModeration permission.

Signed-off-by: Nicole C. Engard <nengard@bywatersolutions.com>
Comment 10 Nicole C. Engard 2011-12-15 19:25:44 UTC
Love it - great addition. I've signed off. I tested with XSLT on and off in the staff client.
Comment 11 Paul Poulain 2012-02-02 09:19:16 UTC
QA comment:
I was about to say "perfect, nothing to say", when I realised list.pl was a new script so we could apply PERL1 coding guideline (perltidy).
list.pl was not perfectly perltidied, i've added a follow-up

other than that, passed QA
Comment 12 Owen Leonard 2013-08-09 16:01:03 UTC
*** Bug 8118 has been marked as a duplicate of this bug. ***