Bug 6935 - SYStem preference XISBNDailyLimit preference text error
Summary: SYStem preference XISBNDailyLimit preference text error
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: System Administration (show other bugs)
Version: 3.6
Hardware: All All
: PATCH-Sent (DO NOT USE) minor (vote)
Assignee: Paul Poulain
QA Contact: Bugs List
URL:
Keywords:
: 5774 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-09-28 22:13 UTC by cmeech
Modified: 2013-12-05 19:59 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 6935: Correct XISBNDailyLimit for new installations (2.62 KB, patch)
2011-11-30 07:16 UTC, Katrin Fischer
Details | Diff | Splinter Review
Bug 6935: Correct XISBNDailyLimit for new installations (2.67 KB, patch)
2011-12-13 08:14 UTC, Chris Cormack
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description cmeech 2011-09-28 22:13:43 UTC
XISBNDailyLimit	 Only use the xISBN service   times a day. Unless you are paying for the xISBN service, you should leave this at the default of 999 (as detailed above)

default should be 499 rather than 999

eg
XISBNDailyLimit	 Only use the xISBN service   times a day. Unless you are paying for the xISBN service, you should leave this at the default of 499 (as detailed above)
Comment 1 Katrin Fischer 2011-09-29 05:02:01 UTC
The limit was changed to 999 a while ago:
http://koha-community.org/oclc-raises-daily-noncommercial-usage-limits-for-xisbn-and-xissn/

But it seems 499 is correct?
http://www.worldcat.org/affiliate/webservices/xisbn/app.jsp
'The xISBN Web service is free for non-commercial use when usage does not exceed 500 requests per day. Free usage is governed by the WorldCat Affiliate Terms and Conditions. See the xISBN API for instructions.'
Comment 2 Katrin Fischer 2011-10-13 05:44:35 UTC
*** Bug 5774 has been marked as a duplicate of this bug. ***
Comment 3 Katrin Fischer 2011-10-13 05:45:19 UTC
I can make a patch to correct it, but which value do we want?
Comment 4 Nicole C. Engard 2011-10-14 14:15:21 UTC
999 (because the max is 1000)
Comment 5 Katrin Fischer 2011-10-18 06:19:32 UTC
I have checked the pref file, the text there is correct:

OCLC:
        -
            - pref: XISBN
              choices:
                  yes: Use
                  no: "Don't use"
            - the OCLC xISBN service to show other editions of a title (when either FRBRizeEditions or OPACFRBRizeEditions is on).
        -
            - Use the <a href="http://www.worldcat.org/affiliate/webservices/xisbn/app.jsp">OCLC affiliate ID</a>
            - pref: OCLCAffiliateID
            - to access the xISBN service. Note that unless you have signed up for an ID, you are limited to 1000 requests per day.
        -
            - Only use the xISBN service
            - pref: XISBNDailyLimit
              class: integer
            - times a day. Unless you are paying for the xISBN service, you should leave this at the default of 999 (as detailed above).

Perhaps this is a problem in the po files of the installed language?
Comment 6 Katrin Fischer 2011-11-30 07:01:16 UTC
In my newly created database the value is set to 499 instead of 999 - investigating.
Comment 7 Katrin Fischer 2011-11-30 07:16:48 UTC Comment hidden (obsolete)
Comment 8 Chris Cormack 2011-12-13 08:14:34 UTC
Created attachment 6736 [details] [review]
Bug 6935: Correct XISBNDailyLimit for new installations

This corrects the value of XISBNDailyLimit in the system preferences
installation file to 999 instead of 499.

The file was missed in an earlier update, so new installations
have different values than older installations that were updated.

Another patch with a database update is needed. Sending this patch first,
until it's clear how database updates will work for 3.8.

To test:
1) Recreate your database from scratch
2) Check your system preference XISBNDailyLimit shows 999 instead of 499,
matching the description of the system preference.

Signed-off-by: Chris Cormack <chrisc@catalyst.net.nz>
Comment 9 Paul Poulain 2011-12-13 15:47:56 UTC
QA comment: trivial patch, passed QA

patch pushed, please test
Comment 10 Jared Camins-Esakov 2012-05-23 12:39:34 UTC
This was included in the 3.6 branch prior to 3.6.4.