Bug 6955 - Toolbar on reading history broken
Summary: Toolbar on reading history broken
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Templates (show other bugs)
Version: master
Hardware: All All
: PATCH-Sent (DO NOT USE) minor (vote)
Target Milestone: ---
Assignee: Owen Leonard
QA Contact: Bugs List
URL: /cgi-bin/koha/members/readingrec.pl?b...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-10-02 20:25 UTC by Katrin Fischer
Modified: 2013-12-05 20:04 UTC (History)
2 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
screenshot (45.90 KB, image/png)
2011-10-02 20:25 UTC, Katrin Fischer
Details
Proposed fix (1.41 KB, patch)
2011-10-03 13:33 UTC, Owen Leonard
Details | Diff | Splinter Review
[SIGNED-OFF] Fix for Bug 6955, Toolbar on reading history broken (1.68 KB, patch)
2011-10-07 04:35 UTC, Katrin Fischer
Details | Diff | Splinter Review
Fix for Bug 6955, Toolbar on reading history broken (1.67 KB, patch)
2011-10-12 12:08 UTC, Paul Poulain
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Katrin Fischer 2011-10-02 20:25:15 UTC
Created attachment 5673 [details]
screenshot

The toolbar on the reading history page in patron account is broken.
Comment 1 Owen Leonard 2011-10-03 13:33:34 UTC Comment hidden (obsolete)
Comment 2 Katrin Fischer 2011-10-07 04:35:26 UTC Comment hidden (obsolete)
Comment 3 Paul Poulain 2011-10-12 12:08:50 UTC
Created attachment 5849 [details] [review]
Fix for Bug 6955, Toolbar on reading history broken

Table sorter script causes error if there is no <tbody> to sort.
JS errors cause the YUI toolbar js to abort, causing the problem
observed. When there are no results the whole table should be
omitted and a message displayed in its place.

Signed-off-by: Katrin Fischer <Katrin.Fischer.83@web.de>
To test:
- check toolbar on top of patron reading history with no entries
- check toolbar on top of patron reading history after a few checkouts

Signed-off-by: Katrin Fischer <Katrin.Fischer.83@web.de>
Signed-off-by: Paul Poulain <paul.poulain@biblibre.com>
Comment 4 Paul Poulain 2011-10-12 12:10:32 UTC
QA comment
  * Minor problem, not major
  * works as expected, good description, small patch
passed QA

Note for 3.6 RM : this patch adds a string. We've string freezed, it's up to you to decide wether to apply the patch or not : the problem is minor, but it's a bug, definetly
Comment 5 Ian Walls 2011-10-12 21:09:58 UTC
Template only change, wrapping a conditional around dependent code.  Introduces new strings, so it may need to wait until 3.6.1, but as for now, it's Passed QA.
Comment 6 Paul Poulain 2011-11-04 09:33:46 UTC
patch pushed, please test

(made a small mistake when pushing : don't search for a new/bug_6955 branch, it was one of my 1st push)
Comment 7 Jared Camins-Esakov 2012-12-31 00:16:40 UTC
There have been no further reports of problems so I am marking this bug resolved.