Bug 7106 - analytics links broken
Summary: analytics links broken
Status: CLOSED INVALID
Alias: None
Product: Koha
Classification: Unclassified
Component: Templates (show other bugs)
Version: 3.6
Hardware: All All
: P5 - low major (vote)
Assignee: Owen Leonard
QA Contact: Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-10-27 15:37 UTC by Nicole C. Engard
Modified: 2012-10-26 00:41 UTC (History)
2 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nicole C. Engard 2011-10-27 15:37:30 UTC
When in the staff client and the opac, if I click on the link to find the host record for an analytic it finds no results because it's searching for 

'kw,wrdl: Control-number:15804854'

The link though says: 

http://localhost-staff:8000/cgi-bin/koha/catalogue/search.pl?q=Control-number:15804854

See this video for more info: http://screencast.com/t/D8MGCr3xLkF
Comment 1 lculber 2011-10-27 16:04:31 UTC
I think may be because the Control-number is using the 001 and the analytics feature is using the 773 subfield w (or is is 0?).  Koha doesn't automatically add an 001, so unless the record has an 001 from a previous system, there is anything for it to use. In our catalog, the ones we migrated work, because we use the old system ids.
Comment 2 Jared Camins-Esakov 2011-10-27 16:50:27 UTC
Nicole,

I think the problem is that you have UseControlNumber is enabled. UseControlNumber offers an alternative, for those libraries which have rigorously established bibliographic relationships without using the analytics code from OSS Labs[1]. That takes precedent over the the 773$0 and 773$9 because if it didn't, Koha wouldn't be able to handle analytics in a union catalog environment. Basically, unless you are going in and manually changing 773$w to match your rigorously-defined bibliographic relationships, you should turn UseControlNumber off if you want EasyAnalytics (or whatever it's called) turned on.

You should probably note in the manual that anyone who is using analytics and isn't sure about whether they want UseControlNumber based on the description should turn it off if they want to use the Easy Analytics from OSS Labs. If disabling UseControlNumber solves the problem, could you please close this bug?

[1] To clarify, when I say "without using the analytics code from OSS Labs," I mean that their rigorously-defined bibliographic relationships are not intrinsic to the Easy Analytics workflow, but rather stem from an external source.

Regards,
Jared
Comment 3 Nicole C. Engard 2011-11-05 19:08:07 UTC
Thanks Jared, that worked and I will update the manual right now so others know the same thing.

Nicole