Bug 7127 - Templates must be valid XHTML
Summary: Templates must be valid XHTML
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Templates (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Owen Leonard
QA Contact: Marcel de Rooy
URL:
Keywords:
: 7452 (view as bug list)
Depends on:
Blocks: 7452
  Show dependency treegraph
 
Reported: 2011-11-01 16:42 UTC by Owen Leonard
Modified: 2013-12-05 20:06 UTC (History)
6 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Proposed fix (26.62 KB, patch)
2011-11-18 19:11 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 7127 - Templates must be valid XHTML (26.63 KB, patch)
2011-12-11 00:26 UTC, Chris Cormack
Details | Diff | Splinter Review
Revised for current master (25.44 KB, patch)
2012-01-13 16:04 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 7127 - Follow-up - Templates must be valid XHTML (14.18 KB, patch)
2012-01-26 20:12 UTC, Owen Leonard
Details | Diff | Splinter Review
Signed off Patch (24.16 KB, patch)
2012-02-03 12:59 UTC, Ian Walls
Details | Diff | Splinter Review
Bug 7127 - Follow-up - Templates must be valid XHTML (14.13 KB, patch)
2012-02-03 13:39 UTC, Owen Leonard
Details | Diff | Splinter Review
[SIGNED OFF] Bug 7127 - Follow-up - Templates must be valid XHTML (14.16 KB, patch)
2012-02-03 23:39 UTC, Ian Walls
Details | Diff | Splinter Review
Bug 7127 - Templates must be valid XHTML (5.13 KB, patch)
2012-05-24 14:20 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 7127 - Templates must be valid XHTML (5.20 KB, patch)
2012-05-26 10:47 UTC, Jared Camins-Esakov
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Owen Leonard 2011-11-01 16:42:38 UTC
All templates should be valid XHTML. I'm finding many new instances of unescaped ampersands which need to be corrected.
Comment 1 Owen Leonard 2011-11-18 19:11:55 UTC Comment hidden (obsolete)
Comment 2 Chris Cormack 2011-12-11 00:26:43 UTC Comment hidden (obsolete)
Comment 3 Paul Poulain 2011-12-13 16:53:16 UTC
QA comment:
* how to prove the validity of XHTML ? Is there a jenkin test for that ?
Comment 4 Marcel de Rooy 2012-01-10 15:21:34 UTC
QA: Looks good. Updating status..
Comment 5 Paul Poulain 2012-01-13 10:49:47 UTC
QA comment

Chris = is there a unit test for XHTML validity ?

+ merge problem:
Applying: Bug 7127 - Templates must be valid XHTML
/home/paul/koha.dev/koha-community/.git/rebase-apply/patch:64: space before tab in indent.
                      		<a href="/cgi-bin/koha/catalogue/search.pl?idx=hi&amp;q=[% itemloo.itemnumber %]">[% itemloo.countanalytics %] analytics</a>
warning: 1 line adds whitespace errors.
Using index info to reconstruct a base tree...
<stdin>:64: space before tab in indent.
                      		<a href="/cgi-bin/koha/catalogue/search.pl?idx=hi&amp;q=[% itemloo.itemnumber %]">[% itemloo.countanalytics %] analytics</a>
warning: 1 line applied after fixing whitespace errors.
Falling back to patching base and 3-way merge...
Auto-merging koha-tmpl/intranet-tmpl/prog/en/modules/catalogue/detail.tt
Auto-merging koha-tmpl/intranet-tmpl/prog/en/modules/catalogue/moredetail.tt
CONFLICT (content): Merge conflict in koha-tmpl/intranet-tmpl/prog/en/modules/catalogue/moredetail.tt
Failed to merge in the changes.
Patch failed at 0001 Bug 7127 - Templates must be valid XHTML
Comment 6 Owen Leonard 2012-01-13 16:04:55 UTC Comment hidden (obsolete)
Comment 7 Owen Leonard 2012-01-26 20:12:26 UTC Comment hidden (obsolete)
Comment 8 Owen Leonard 2012-01-26 20:14:06 UTC
Attachment 7339 [details] can be applied and tested independently of attachment 7140 [details] [review].
Comment 9 Owen Leonard 2012-01-26 20:27:46 UTC
Attachment 7339 [details] should also fix Bug 7452.
Comment 10 Ian Walls 2012-02-03 12:59:15 UTC Comment hidden (obsolete)
Comment 11 Ian Walls 2012-02-03 13:00:17 UTC
Second patch double |html filters on page-numbers.inc; while this may be benign, it won't pass QA.
Comment 12 Ian Walls 2012-02-03 13:01:09 UTC
Marking Passed QA for signed off patch only, since it's a safe template-only change.
Comment 13 Owen Leonard 2012-02-03 13:39:08 UTC Comment hidden (obsolete)
Comment 14 Paul Poulain 2012-02-03 13:54:56 UTC
i'm not sure what to do with those patches. Should I push the 1st and reset status to need signoff?
Comment 15 Ian Walls 2012-02-03 23:39:56 UTC Comment hidden (obsolete)
Comment 16 Ian Walls 2012-02-03 23:40:59 UTC
Signed off and Passed QA on followup: both attached patches can now be committed.
Comment 17 Owen Leonard 2012-02-17 15:08:24 UTC
*** Bug 7452 has been marked as a duplicate of this bug. ***
Comment 18 Owen Leonard 2012-05-24 14:20:20 UTC Comment hidden (obsolete)
Comment 19 Jared Camins-Esakov 2012-05-26 10:47:53 UTC Comment hidden (obsolete)
Comment 20 Paul Poulain 2012-05-28 15:50:20 UTC
QA comment:
 * this patch does not apply on new/bug_7127 branch, that is too old
 * template only change, for better XHTML compliance

passed QA, will push them on master branch directly
Comment 21 Paul Poulain 2012-05-28 15:50:40 UTC
Comment on attachment 9788 [details] [review]
Bug 7127 - Templates must be valid XHTML

this patch has been pushed
Comment 22 Katrin Fischer 2013-04-14 10:43:45 UTC
Should we leave this open or better have individual new bugs for new problems?
That templates should be valid XHTML is part of the coding guidelines.
Comment 23 Owen Leonard 2013-05-15 14:38:40 UTC
(In reply to comment #22)
> Should we leave this open or better have individual new bugs for new
> problems?

I think in general individual bugs work better, and since we're using an HTML5 doctype now this bug should be closed.