Bug 7136 - Correct description of Grace period for subscriptions
Summary: Correct description of Grace period for subscriptions
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Serials (show other bugs)
Version: master
Hardware: All All
: P5 - low minor (vote)
Assignee: Katrin Fischer
QA Contact: Marcel de Rooy
URL: /cgi-bin/koha/opac-serial-issues.pl?s...
Keywords:
Depends on:
Blocks:
 
Reported: 2011-11-01 20:55 UTC by Nicole C. Engard
Modified: 2019-10-14 19:57 UTC (History)
7 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Documentation contact:
Documentation submission:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 7136: Correct description of Grace period for subscriptions (1.58 KB, patch)
2018-05-16 02:27 UTC, Katrin Fischer
Details | Diff | Splinter Review
Bug 7136: Correct description of Grace period for subscriptions (1.64 KB, patch)
2018-06-08 19:44 UTC, Maryse Simard
Details | Diff | Splinter Review
Bug 7136: Correct description of Grace period for subscriptions (1.74 KB, patch)
2018-07-06 06:10 UTC, Marcel de Rooy
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Nicole C. Engard 2011-11-01 20:55:04 UTC
When looking at a serial in the opac it says 'Waiting' if the issue is 'Expected' - this is confusing and should be consistent and say 'Expected' instead.
Comment 1 Owen Leonard 2011-11-02 14:01:39 UTC
I see this in one of the help files:

"The 'Grace Period' is the number of days before an issue is automatically moved from 'expected' status to 'waiting' and how many days before an issue is automatically moved from 'waiting' status to 'late'"

If the OPAC should show "expected" when it says "waiting," should it show "waiting" instead of "arrived?" In the template:

    <td>    [% IF ( serial.status1 ) %]Waiting[% END %]
	[% IF ( serial.status2 ) %]Arrived[% END %]
	[% IF ( serial.status3 ) %]Late[% END %]
	[% IF ( serial.status4 ) %]Missing[% END %]
	[% IF ( serial.status5 ) %]Not Available[% END %]
	[% IF ( serial.status7 ) %]Claimed[% END %]
	[% IF ( serial.notes ) %]([% serial.notes %])[% END %]
    </td>
Comment 2 Nicole C. Engard 2011-11-05 19:29:34 UTC
Owen,

I know I put that in the help file, but I've never actually seen that automatic status change happen - has anyone else?

Regarding the template change I mentioned an issue is saying Waiting in the OPAC and Expected in the staff client - I just ask that it says the same thing in both places because "Waiting" is confusing patrons when in fact the issue is not late but just expected to arrive next month.

Nicole
Comment 3 Katrin Fischer 2011-11-06 08:46:14 UTC
I think there might be a cronjob doing this automatic change. 
There is a cronjob related to serials, but I have not tried it out yet:
/ misc / cronjobs / serialsUpdate.pl
Comment 4 Owen Leonard 2013-08-12 16:40:08 UTC
I still don't know what to do with this. If an issue goes from "expected" to "waiting" to "late" like the help file says, how can we replace "waiting" with "expected?" Or are they really the same, and the help file is inaccurate?
Comment 5 Katrin Fischer 2018-05-16 02:24:48 UTC
I think it never worked the way it's described on the help page and the manual. The grace period is used with the serialsUpdate.pl cronjob. It will generate the next issue and set the one before to 'Late' with an optional note.

Submitting a patch for the help file and the manual, OPAC appears to be fixed already.
Comment 6 Katrin Fischer 2018-05-16 02:27:39 UTC
Created attachment 75352 [details] [review]
Bug 7136: Correct description of Grace period for subscriptions

The grace period is used with the serialsUpdate.pl cronjob. It will
generate the next issue and set the one before to 'Late' with
an optional note.

There is on trace of a 'waiting' status for serials.

To test:
- check help file on the subscription edit form for
  the description of the 'Grace period'.
Comment 7 Maryse Simard 2018-06-08 19:44:45 UTC
Created attachment 75934 [details] [review]
Bug 7136: Correct description of Grace period for subscriptions

The grace period is used with the serialsUpdate.pl cronjob. It will
generate the next issue and set the one before to 'Late' with
an optional note.

There is on trace of a 'waiting' status for serials.

To test:
- check help file on the subscription edit form for
  the description of the 'Grace period'.

Signed-off-by: Maryse Simard <maryse.simard@inlibro.com>
Comment 8 Marcel de Rooy 2018-07-06 06:10:18 UTC
Created attachment 76715 [details] [review]
Bug 7136: Correct description of Grace period for subscriptions

The grace period is used with the serialsUpdate.pl cronjob. It will
generate the next issue and set the one before to 'Late' with
an optional note.

There is on trace of a 'waiting' status for serials.

To test:
- check help file on the subscription edit form for
  the description of the 'Grace period'.

Signed-off-by: Maryse Simard <maryse.simard@inlibro.com>

Signed-off-by: Marcel de Rooy <m.de.rooy@rijksmuseum.nl>
Comment 9 Nick Clemens 2018-07-06 14:43:08 UTC
Awesome work all!

Pushed to master for 18.11
Comment 10 Martin Renvoize 2018-07-10 06:57:28 UTC
Pushed to 18.05.x for 18.05.02
Comment 11 Fridolin Somers 2018-07-12 07:01:59 UTC
Pushed to 17.11.x for 17.11.08