Bug 7224 - Allow patrons to pick their own preferred language
Summary: Allow patrons to pick their own preferred language
Status: RESOLVED DUPLICATE of bug 17762
Alias: None
Product: Koha
Classification: Unclassified
Component: I18N/L10N (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Frédéric Demians
QA Contact:
URL:
Keywords:
Depends on: 6481
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-15 12:50 UTC by Ian Walls
Modified: 2017-07-08 18:59 UTC (History)
2 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ian Walls 2011-11-15 12:50:21 UTC
Allow patrons to select their own preferred language, individually.  This can provide an extra level of personalization in multi-lingual environments, and could later be applied to more than just the OPAC or staff client templates (translated notices).

The choice should be configurable in the OPAC, under Preferences, without the need to confirm with the librarian (like for contact info changes)

The structural changes to Koha required for this development would pave the way for a whole bunch of other individual preference values (beyond just messaging and OPAC privacy preferences), making for more customizable ILS
Comment 1 Katrin Fischer 2016-02-28 21:57:05 UTC
This could also be a first step to allow sending out notices in the preferred language to the user.
Comment 2 Katrin Fischer 2017-07-08 18:59:23 UTC
This has been made possible with bug 17762.

- preferred language setting in the patron account
- translatable notices

I will open a new bug report for making it possible for the user to select their preferred language in the OPAC themselves.

*** This bug has been marked as a duplicate of bug 17762 ***