Bug 7247 - rebuild_zebra.pl -v should show all Zebra log output
Summary: rebuild_zebra.pl -v should show all Zebra log output
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Searching (show other bugs)
Version: 3.6
Hardware: All All
: P3 enhancement (vote)
Target Milestone: ---
Assignee: Dobrica Pavlinusic
QA Contact: Ian Walls
URL:
Whiteboard:
Keywords:
: 8493 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-11-19 11:06 UTC by Dobrica Pavlinusic
Modified: 2014-03-11 11:47 UTC (History)
6 users (show)

See Also:
Change sponsored?: Sponsored
Patch complexity: ---
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Bug 7247 - rebuild_zebra.pl -v should show all Zebra log output (1.80 KB, patch)
2011-11-19 11:24 UTC, Dobrica Pavlinusic
Details | Diff | Splinter Review
Bug 7247 - rebuild_zebra.pl -v should show all Zebra log output (1.85 KB, patch)
2011-12-02 08:50 UTC, Chris Cormack
Details | Diff | Splinter Review
re-submit patch with --help output changes for -vv (2.17 KB, patch)
2011-12-14 17:59 UTC, Dobrica Pavlinusic
Details | Diff | Splinter Review
Fixed usage instructions to mention -v -v option (2.17 KB, patch)
2011-12-16 10:40 UTC, Dobrica Pavlinusic
Details | Diff | Splinter Review
Bug 7247 - rebuild_zebra.pl -v -v should show all Zebra log output (2.17 KB, patch)
2011-12-20 12:04 UTC, Dobrica Pavlinusic
Details | Diff | Splinter Review
[Signed Off] Bug 7247 - rebuild_zebra.pl -v should show all Zebra log output (2.36 KB, patch)
2011-12-31 22:23 UTC, Liz Rea
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Dobrica Pavlinusic 2011-11-19 11:06:10 UTC

    
Comment 1 Dobrica Pavlinusic 2011-11-19 11:24:47 UTC Comment hidden (obsolete)
Comment 2 Chris Cormack 2011-12-02 08:50:29 UTC Comment hidden (obsolete)
Comment 3 Paul Poulain 2011-12-14 16:47:47 UTC
QA comment : Sorry Dobrika, failed QA

misc/migration_tools/rebuild_zebra.pl --help don't show the new option for -v
Please add documentation on print_usage & resubmit, should be OK with doc
Comment 4 Dobrica Pavlinusic 2011-12-14 17:59:30 UTC Comment hidden (obsolete)
Comment 5 Katrin Fischer 2011-12-16 07:08:47 UTC
Hi Dobrica, 
I tested the option and the new help. It states to use -vv for more output. Perhaps I am missing some common syntax here, but you have to type -v -v to make it work, while -vv doesn't. Perhaps we can make the help more clear?
Comment 6 Dobrica Pavlinusic 2011-12-16 10:40:19 UTC Comment hidden (obsolete)
Comment 7 Chris Cormack 2011-12-18 07:51:59 UTC
Hi Dobrica

It looks like you might have accidentally submitted the same patch again? It still says -vv in the help
Comment 8 Dobrica Pavlinusic 2011-12-20 12:04:21 UTC Comment hidden (obsolete)
Comment 9 Liz Rea 2011-12-31 22:23:09 UTC
Created attachment 6993 [details] [review]
[Signed Off] Bug 7247 - rebuild_zebra.pl -v should show all Zebra log output

Currently, -v option resets Zebra log output to default system values.

This produce amount of log specified in system defaults which is usually
too low for debugging.

This change explicitly forces all Zebra log output which create much more
chatter so it triggers with verbosity level 2

Test scenario:
1. pick koha site to reindex
2. use -v -v options to rebuild_zebra.pl to see additional output

Signed-off-by: Liz Rea <wizzyrea@gmail.com>
Verified help corrections and  loglevel 2 output vs. loglevel 1 output. No issues found.
Comment 10 Paul Poulain 2012-01-17 16:33:26 UTC
QA comment: none, this time everything seems OK!
Comment 11 Martin Renvoize 2014-03-11 11:47:49 UTC
*** Bug 8493 has been marked as a duplicate of this bug. ***