Bug 7381 - wrong isbn showing on the staff search results
Summary: wrong isbn showing on the staff search results
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Templates (show other bugs)
Version: 3.6
Hardware: All All
: P4 normal (vote)
Assignee: Owen Leonard
QA Contact: Ian Walls
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-12-27 17:57 UTC by Nicole C. Engard
Modified: 2013-12-05 19:57 UTC (History)
2 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Text to go in the release notes:
Version(s) released in:


Attachments
Proposed fix (2.39 KB, patch)
2011-12-27 20:00 UTC, Owen Leonard
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 7381 - wrong isbn showing on the staff search results (2.54 KB, patch)
2011-12-27 20:26 UTC, Nicole C. Engard
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Nicole C. Engard 2011-12-27 17:57:33 UTC
I cataloged this book originally - no importing done here
http://screencast.com/t/kNAVuxLKMk3

This shows the right isbn (the one I cataloged):  http://screencast.com/t/Pah0bgDVE

This shows an isbn that I did not put in the record at all: http://screencast.com/t/QEcM4zxBEJo 

What's happening is that the normalization script is running to change the isbn to 10 digit for amazon to work, and then displaying the 10 digit isbn on the results. This should not happen.  The isbn on the results should be the one in the marc record - like in the opac - and the isbn sent to amazon can be the one it needs.  

This happens with xslt on and off in the staff client and should be fixed on both displays to avoid confusion.  It also shows in the results found in the reservoir.
Comment 1 Owen Leonard 2011-12-27 20:00:59 UTC Comment hidden (obsolete)
Comment 2 Owen Leonard 2011-12-27 20:06:16 UTC
As far as I can tell the results in the reservoir are not doing any processing of the ISBN. Looks like ISBNs are being displayed exactly as they are stored.
Comment 3 Nicole C. Engard 2011-12-27 20:26:27 UTC
Created attachment 6934 [details] [review]
[SIGNED-OFF] Bug 7381 - wrong isbn showing on the staff search results

Outputting the "raw" ISBN. In the case of multiples, ISBNs
are concatenated with " | " Using a T:T filter to make these
a comma-separated list.

Signed-off-by: Nicole C. Engard <nengard@bywatersolutions.com>

Added a record and confirmed that the right ISBN shows on the
search results and that the amazon cover image still works.
Comment 4 Ian Walls 2012-01-11 02:41:49 UTC
Template only change to use raw ISBN and a simple replacement.  Marking Passed QA
Comment 5 Paul Poulain 2012-01-13 11:15:37 UTC
patch pushed please test

(lowered the severity, this is not major)