Bug 7409 - Missing dependencies for Debian package
Summary: Missing dependencies for Debian package
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Packaging (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Robin Sheat
QA Contact: Ian Walls
URL:
Keywords:
: 7389 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-01-05 23:26 UTC by Jared Camins-Esakov
Modified: 2014-05-26 21:04 UTC (History)
5 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 7409 - add unzip and perl-doc dependencies to package (1.21 KB, patch)
2012-02-12 02:07 UTC, Robin Sheat
Details | Diff | Splinter Review
Bug 7409 - add unzip and perl-doc dependencies to package (1.31 KB, patch)
2012-02-13 01:05 UTC, Jared Camins-Esakov
Details | Diff | Splinter Review
Bug 7409 : Missing dependency on libtest-mockmodule-perl (665 bytes, patch)
2012-09-16 07:52 UTC, Chris Cormack
Details | Diff | Splinter Review
Bug 7409 : Adding missing dependency (649 bytes, patch)
2012-09-16 09:55 UTC, Chris Cormack
Details | Diff | Splinter Review
Bug 7409 : Missing dependency on DBD::Mock (637 bytes, patch)
2012-09-17 07:35 UTC, Chris Cormack
Details | Diff | Splinter Review
Bug 7409 : Adding missing dependency (764 bytes, patch)
2012-09-21 13:03 UTC, Kyle M Hall
Details | Diff | Splinter Review
Bug 7409 : Missing dependency on DBD::Mock (752 bytes, patch)
2012-09-21 13:03 UTC, Kyle M Hall
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Jared Camins-Esakov 2012-01-05 23:26:14 UTC
In order for all the functionality in Koha to work properly, unzip is required (for patron images), and perl-doc is required (for --help switches on the command line scripts).
Comment 1 Magnus Enger 2012-01-06 08:08:24 UTC
*** Bug 7389 has been marked as a duplicate of this bug. ***
Comment 2 Robin Sheat 2012-02-12 02:07:10 UTC Comment hidden (obsolete)
Comment 3 Robin Sheat 2012-02-12 02:22:46 UTC
Note that the Koha dependency on Date::ICal will cause build errors if you have an up-to-date with testing build environment. It's unrelated to this, but may cause problems testing it. See bug 7532 for details.
Comment 4 Jared Camins-Esakov 2012-02-13 01:05:01 UTC Comment hidden (obsolete)
Comment 5 Ian Walls 2012-02-16 16:59:57 UTC
Simple patch to add two important dependencies for the debian packages.  Marking as Passed QA.
Comment 6 Paul Poulain 2012-02-17 10:21:46 UTC
QA comment:
also REMOVE 
- libhtml-template-pro-perl,
that we don't use anymore, it's OK, just to be full disclaiming what' in the patch !

does not look like an ENH to me, so switching to severity "normal" and version rel_3_6
Comment 7 Robin Sheat 2012-02-17 10:24:09 UTC
The removal of that was completely automatic, it presumably was removed from the main Koha dependencies file some time in the past (which is what the control file is built from.)

But yes, worth noting still.
Comment 8 Jared Camins-Esakov 2012-05-23 13:03:04 UTC
This fix was included in the 3.6.x branch prior to 3.6.4.
Comment 9 Chris Cormack 2012-09-16 07:52:55 UTC Comment hidden (obsolete)
Comment 10 Chris Cormack 2012-09-16 09:55:36 UTC Comment hidden (obsolete)
Comment 11 Chris Cormack 2012-09-17 07:35:50 UTC Comment hidden (obsolete)
Comment 12 Robin Sheat 2012-09-17 09:29:41 UTC
Assuming that these deps are recorded in the standard dependencies file, they'll get picked up on their own, and I tend to roll them into a bigger patch, along with changelog updates and such. If not, then this patch will be needed for them.
Comment 13 Chris Cormack 2012-09-17 09:31:02 UTC
They aren't currently, which means that the 3.8.x daily builds are failing
Comment 14 Kyle M Hall 2012-09-21 13:03:26 UTC
Created attachment 12423 [details] [review]
Bug 7409 : Adding missing dependency

Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>
Comment 15 Kyle M Hall 2012-09-21 13:03:38 UTC
Created attachment 12424 [details] [review]
Bug 7409 : Missing dependency on DBD::Mock

Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>
Comment 16 Robin Sheat 2012-09-24 06:33:14 UTC
There's something wrong here.

In particular, C4::Installer::PerlDependencies doesn't contain the required modules, and so they will not be included in the debian build. The debian control file is automatically generated, and shouldn't be edited by hand.

I will add it to the dependencies file as part of 8806. I'll chance the status on this, as this patch really shouldn't go in in this form.
Comment 17 Robin Sheat 2012-09-24 07:15:02 UTC
These changes have been included in bug 8806, things are best done there.
Comment 18 Galen Charlton 2013-07-03 20:25:52 UTC
Does this bug need to remain open?  libdbd-mock-perl was added a while back, and I'm not sure that we need a standing bug for adding new package dependencies.
Comment 19 Robin Sheat 2013-07-04 09:37:33 UTC
Nah, it should be closed.