Bug 7783 - Show private shelves in opac when deleting non-empty private list from shelf view
Summary: Show private shelves in opac when deleting non-empty private list from shelf ...
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Lists (show other bugs)
Version: 3.8
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Marcel de Rooy
QA Contact: Ian Walls
URL:
Keywords:
Depends on: 7310
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-21 15:41 UTC by Marcel de Rooy
Modified: 2013-12-05 19:53 UTC (History)
2 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Text to go in the release notes:
Version(s) released in:


Attachments
Patch (1.40 KB, patch)
2012-03-21 15:46 UTC, Marcel de Rooy
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Marcel de Rooy 2012-03-21 15:41:22 UTC
This patch builds on top of 7310, but the problem is in master already.
If you delete a non-empty list from shelf view (looking at the biblio records of the list), the confirm message is shown but listing public lists instead of private lists.

Report 7310 resolved this for staff. This patch adds it for OPAC.
Comment 1 Marcel de Rooy 2012-03-21 15:46:39 UTC
Created attachment 8440 [details] [review]
Patch

One-line-fix: easy to test (after 7310 is through)
Comment 2 MathildeF 2012-03-23 10:00:34 UTC
Tested on sandbox.
it works correct.
Comment 3 Ian Walls 2012-03-25 20:20:56 UTC
Template only change, adding a new template parameter to the submit to opac-shelves.pl if showprivateshelves is set.  Marking Passed QA.
Comment 4 Paul Poulain 2012-03-26 14:00:13 UTC
tiny comment: it would have been more clear to write the patch on 2 lines:
+ [% IF ( showprivateshelves ) %]<input type="hidden" name="display" value="privateshelves"/>[% END %]
alone, but will push the patch as it is ;-)