Bug 7899 - Remove C4::Dates from C4::Circulation
Summary: Remove C4::Dates from C4::Circulation
Status: RESOLVED DUPLICATE of bug 14903
Alias: None
Product: Koha
Classification: Unclassified
Component: Architecture, internals, and plumbing (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Galen Charlton
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-04-04 20:35 UTC by Ian Walls
Modified: 2015-10-09 19:25 UTC (History)
2 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ian Walls 2012-04-04 20:35:26 UTC
Now that we have Koha::Calendar and DateTime, we no longer need C4::Dates in C4::Circulation

There are currently 6 usages of the module left:

2 'use' calls to this... both will be removed.

2 calls to format_date in CanBookBeIssued (needsconfirmation message).  Will need to replace with KohaDates plugin on all template pages using this subroutine

"if (C4::Context->preference('globalDueDate') && (C4::Context->preference('globalDueDate') =~ C4::Dates->regexp('syspref')" is never true since that syspref was removed, so it can be removed entirely

sub TransferSlip creates a new $pulldate variable, but never uses it before the subroutine exits.  Can be removed

The rest of the usage here is in the POD, which needs to be updated to reflect the new type of objects we're using now with Hourly Loans.
Comment 1 Marc Véron 2015-10-09 19:25:38 UTC
Bug 14903 removes deprectated C4::Dates from
- circ/circulation.pl
- C4/Circulation.pm
- koha-tmpl/intranet-tmpl/prog/en/modules/circ/circulation.tt

*** This bug has been marked as a duplicate of bug 14903 ***