Bug 7953 - opacuserjs to the sco template
Summary: opacuserjs to the sco template
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Self checkout (show other bugs)
Version: 3.8
Hardware: All All
: P5 - low trivial (vote)
Assignee: Liz Rea
QA Contact: Ian Walls
URL:
Whiteboard:
Keywords:
: 6310 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-04-12 21:51 UTC by Ed Veal
Modified: 2013-12-05 19:59 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Bug 7953 - add opacuserjs to the sco template (1.39 KB, patch)
2012-04-12 22:00 UTC, Liz Rea
Details | Diff | Splinter Review
Bug 7953 - add opacuserjs to the sco template (1.40 KB, patch)
2012-04-27 21:44 UTC, Liz Rea
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 7953 - add opacuserjs to the sco template (1.51 KB, patch)
2012-04-30 13:32 UTC, Owen Leonard
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Ed Veal 2012-04-12 21:51:19 UTC
Basicly we need a patch to add a bit for opacuserjs to the sco template.

Ed
Comment 1 Liz Rea 2012-04-12 22:00:31 UTC Comment hidden (obsolete)
Comment 2 Ian Walls 2012-04-16 18:39:43 UTC
Conditional check for IF opacuserjs should exist outside <script> tags, lest empty tags be created when no content is present.

Marking Failed QA for the above reason.
Comment 3 Liz Rea 2012-04-27 21:44:42 UTC Comment hidden (obsolete)
Comment 4 Owen Leonard 2012-04-30 13:32:16 UTC
Created attachment 9370 [details] [review]
[SIGNED-OFF] Bug 7953 - add opacuserjs to the sco template

To test:
add some jquery to opacuserjs that would change the screen
a la: $(".checkout label[for='patronid']").css("border","3px solid red");
verify you see a red box on the sco-main page.

Also adds the ability to use opacusercss to style sco-main.tt

to test:
Add some css to opacusercss that would change the screen:
.checkout { background: grey; }
verify you see a grey box around the checkout div.

Signed-off-by: Owen Leonard <oleonard@myacpl.org>

http://bugs.koha-community.org/show_bug.cgi?id=7959
Comment 5 Ian Walls 2012-04-30 14:14:53 UTC
Conditional statement fixed (thank you!).  Marking Passed QA.
Comment 6 Magnus Enger 2012-08-13 12:12:39 UTC
*** Bug 6310 has been marked as a duplicate of this bug. ***