Bug 8075 - Add XSLT script to remove NSB and NSE characters from Z39.50 downloads
Summary: Add XSLT script to remove NSB and NSE characters from Z39.50 downloads
Status: RESOLVED DUPLICATE of bug 6536
Alias: None
Product: Koha
Classification: Unclassified
Component: Searching (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement with 10 votes (vote)
Assignee: Galen Charlton
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-05-11 14:19 UTC by Gaetan Boisson
Modified: 2022-08-22 03:27 UTC (History)
2 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Documentation contact:
Documentation submission:
Text to go in the release notes:
Version(s) released in:


Attachments
NSB NSE characters showing under windows (309.94 KB, image/png)
2012-05-11 14:19 UTC, Gaetan Boisson
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gaetan Boisson 2012-05-11 14:19:37 UTC
Created attachment 9515 [details]
NSB NSE characters showing under windows

NSB and NSE characters in a biblio downloaded via z39.50 are left in the title and mess up with the indexation : in the title "NSBlaNSEnuit des contrebandiers" "nuit" was indexed as NSEnuit and is therefore not searchable.

Also in windows the NSB NSE characters are showing in boxes with their codes, 0088 and 0089. (Which might be a local configuration problem or not, i saw this on several different computers.)
Comment 1 Katrin Fischer 2012-05-11 15:56:09 UTC
Hi Gaetan,
I think the work Marcel has done to allow for modification of records using XSLT would make it possible to this and other problems easily and in a generic way. 
Perhaps it's worth taking a look (and the patch got stuck because of a UNIMARC problem, that is hard to test for MARC21 users :) ). It's bug 6536 - note there is a link to a more detailed page in the wiki.
Comment 2 David Cook 2022-08-22 03:27:36 UTC
I think that bug 6536 really is the solution to this one

*** This bug has been marked as a duplicate of bug 6536 ***