Bug 8276 - circ history not sorting right
Summary: circ history not sorting right
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Circulation (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Jonathan Druart
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-06-20 15:06 UTC by Nicole C. Engard
Modified: 2015-12-03 22:11 UTC (History)
5 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
sort error (278.97 KB, image/png)
2012-06-20 15:06 UTC, Nicole C. Engard
Details
Bug 8276: circ history - checked out items are later (1.45 KB, patch)
2015-03-31 14:12 UTC, Jonathan Druart
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 8276: circ history - checked out items are later (1.53 KB, patch)
2015-04-15 06:29 UTC, Josef Moravec
Details | Diff | Splinter Review
[PASSED QA] Bug 8276: circ history - checked out items are later (1.58 KB, patch)
2015-04-19 20:29 UTC, Katrin Fischer
Details | Diff | Splinter Review
Follow-up: Remove stry </td> (1.15 KB, patch)
2015-04-19 20:29 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Nicole C. Engard 2012-06-20 15:06:01 UTC
Created attachment 10390 [details]
sort error

When you're on the patron's circulation history in the staff client the far right column is sorting by month/day in descending order, but year is ascending.
Comment 1 Colin Campbell 2013-06-19 10:07:42 UTC
Can you retest this? I think the patch associated with bug 8017 has fixed by removing some of the sorting layers that were over-complicating. It seems ok in my test.
Comment 2 Colin Campbell 2013-06-19 11:56:38 UTC
Actually I can reproduce it... When there are items checked out it ceases sorting by date and searches by string to accomodate the text 'Checked out'. If borrower has no current issues its correct.
Comment 3 Owen Leonard 2014-07-16 16:12:48 UTC
Can you retest this? The handling of date sorting has changed since the last comment was added so I'm not sure if this bug is still valid.
Comment 4 Colin Campbell 2014-07-18 13:51:38 UTC
On an admittedly small sample dates look ok. Strange behaviour with checked out items .... they always sort as being the earliest if you sort on that column (the sorting value is set to '00-00-0000' The patron's history is more intuitive, these appear as 'checked out' and characters being > numbers always sort as newer. If folk agree that making the two screens consustent is a good idea, I'll submit the patch
Comment 5 Jonathan Druart 2015-03-31 14:12:06 UTC Comment hidden (obsolete)
Comment 6 Josef Moravec 2015-04-15 06:29:17 UTC Comment hidden (obsolete)
Comment 7 Katrin Fischer 2015-04-19 20:29:38 UTC
Created attachment 38141 [details] [review]
[PASSED QA] Bug 8276: circ history - checked out items are later

If the sort is done on "checkin on", the items currently checked out
should be list after all others.

Test plan:
1/ Go on the checkout history page for a record with checked out items
2/ Sort on the "checkin on" column and confirm that the checked out
items are sorted after/before others depending on the sort order
(asc/desc).

Signed-off-by: Josef Moravec <josef.moravec@gmail.com>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 8 Katrin Fischer 2015-04-19 20:29:54 UTC
Created attachment 38142 [details] [review]
Follow-up: Remove stry </td>

Removes an additional </td> tag that isn't needed.
Comment 9 Tomás Cohen Arazi 2015-04-22 18:26:41 UTC
Patches pushed to master.

Thanks Jonathan!