Bug 8315 - fix 'C4::Output 3.02' errors in Koha
Summary: fix 'C4::Output 3.02' errors in Koha
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Architecture, internals, and plumbing (show other bugs)
Version: 3.8
Hardware: All All
: P5 - low major (vote)
Assignee: Dobrica Pavlinusic
QA Contact: Jonathan Druart
URL:
Keywords:
: 8344 8354 8625 (view as bug list)
Depends on: 7941
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-26 03:46 UTC by Mason James
Modified: 2013-12-05 19:59 UTC (History)
9 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 8315 - fix 'C4::Output 3.02' errors in Koha (1.98 KB, patch)
2012-06-26 04:00 UTC, Mason James
Details | Diff | Splinter Review
Bug 8315 - fix 'C4::Output 3.02' errors in Koha (1.96 KB, patch)
2012-06-26 13:03 UTC, Robin Sheat
Details | Diff | Splinter Review
Bug 8315 - remove use C4::* version (14.84 KB, patch)
2012-07-12 16:05 UTC, Dobrica Pavlinusic
Details | Diff | Splinter Review
Bug 8315 - remove use C4::* version (14.89 KB, patch)
2012-07-12 21:56 UTC, Chris Cormack
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Mason James 2012-06-26 03:46:18 UTC
some lines in Koha have a hardcode version, like this...

use C4::Output 3.02

which cause a version-mismatch error, like this...

C4::Output version 3.02 required--this is only version 3.07.00.049 at review.pl line 33
Comment 1 Mason James 2012-06-26 04:00:12 UTC Comment hidden (obsolete)
Comment 2 Mason James 2012-06-26 04:03:50 UTC
(In reply to comment #1)
> Created attachment 10483 [details] [review]
> Bug 8315 - fix 'C4::Output 3.02' errors in Koha


i've sent a patch that removes the unneeded '3.02' part

only 3 lines are changed
Comment 3 Robin Sheat 2012-06-26 13:03:10 UTC Comment hidden (obsolete)
Comment 4 Jonathan Druart 2012-06-27 10:28:39 UTC
    Bug 7941 introduces issues in some pages.

    3 are list in this bug, but others exist.

    At least:
    tags/list.pl:use C4::Tags 0.03 qw(get_tags remove_tag get_tag_rows);
    tags/review.pl:use C4::Tags 0.03 qw(get_tags get_approval_rows approval_counts whitelist blacklist is_approved);


    Marking as Passed QA.
Comment 5 Chris Cormack 2012-06-27 10:32:15 UTC
Interesting those use lines have been there since 2008, it's only now we actually have accurate version numbers on our modules that they are causing a breakage. 

Still they definitely shouldn't be there.
Comment 6 Robin Sheat 2012-06-27 13:11:29 UTC
On 3.8.2, I see the following things that use versioning:

$ grep -rPe '^\s*use\s+[^\s]+\s+\d' *
C4/Creators/Template.pm:use C4::Creators::Profile 1.000000;
C4/Creators/Template.pm:use C4::Creators::Lib 1.000000 qw(get_unit_values);
C4/Creators/Profile.pm:use C4::Creators::Lib 1.000000 qw(get_unit_values);
C4/Patroncards.pm:    use C4::Patroncards::Batch 1.000000;
C4/Patroncards.pm:    use C4::Patroncards::Layout 1.000000;
C4/Patroncards.pm:    use C4::Patroncards::Lib 1.000000;
C4/Patroncards.pm:    use C4::Patroncards::Patroncard 1.000000;
C4/Patroncards.pm:    use C4::Patroncards::Profile 1.000000;
C4/Patroncards.pm:    use C4::Patroncards::Template 1.000000;
C4/Labels.pm:    use C4::Labels::Batch 1.000000;
C4/Labels.pm:    use C4::Labels::Label 1.000000;
C4/Labels.pm:    use C4::Labels::Layout 1.000000;
C4/Labels.pm:    use C4::Labels::Profile 1.000000;
C4/Labels.pm:    use C4::Labels::Template 1.000000;
C4/Creators.pm:    use C4::Creators::Lib 1.000000;
C4/Creators.pm:    use C4::Creators::PDF 1.000000;
C4/Installer.pm:use C4::Installer::PerlModules 1.000000;
C4/Patroncards/Patroncard.pm:use C4::Creators::Lib 1.000000 qw(get_font_types);
C4/Patroncards/Patroncard.pm:use C4::Creators::PDF 1.000000 qw(StrWidth);
C4/Patroncards/Patroncard.pm:use C4::Patroncards::Lib 1.000000 qw(unpack_UTF8 text_alignment leading box get_borrower_attributes);
labels/label-manage.pl:use C4::Creators 1.000000;
labels/label-manage.pl:use C4::Labels 1.000000;
labels/label-create-csv.pl:use C4::Creators 1.000000;
labels/label-create-csv.pl:use C4::Labels 1.000000;
labels/label-create-xml.pl:use C4::Creators 1.000000;
labels/label-create-xml.pl:use C4::Labels 1.000000;
labels/label-print.pl:use C4::Creators::Lib 1.000000 qw(get_all_templates get_all_layouts get_output_formats);
labels/label-print.pl:use C4::Labels::Batch 1.000000;
labels/label-create-pdf.pl:use C4::Creators 1.000000;
labels/label-create-pdf.pl:use C4::Labels 1.000000;
labels/label-edit-batch.pl:use C4::Creators 1.000000;
labels/label-edit-batch.pl:use C4::Labels 1.000000;
labels/label-edit-profile.pl:use C4::Creators 1.000000;
labels/label-edit-profile.pl:use C4::Labels 1.000000;
labels/label-edit-layout.pl:use C4::Creators 1.000000;
labels/label-edit-layout.pl:use C4::Labels 1.000000;
labels/label-edit-template.pl:use C4::Creators 1.000000;
labels/label-edit-template.pl:use C4::Labels 1.000000;
misc/cronjobs/overdue_notices.pl:use Locale::Currency::Format 1.28;
opac/opac-ratings-ajax.pl:use C4::Output 3.02 qw(:html :ajax pagination_bar);
opac/opac-tags.pl:use C4::Output 3.02 qw(:html :ajax pagination_bar);
patroncards/image-manage.pl:use C4::Creators 1.000000;
patroncards/image-manage.pl:use C4::Patroncards 1.000000;
patroncards/create-pdf.pl:use C4::Creators 1.000000;
patroncards/create-pdf.pl:use C4::Patroncards 1.000000;
patroncards/manage.pl:use C4::Creators 1.000000;
patroncards/manage.pl:use C4::Patroncards 1.000000;
patroncards/manage.pl:use C4::Labels 1.000000;
patroncards/edit-template.pl:use C4::Creators 1.000000;
patroncards/edit-template.pl:use C4::Patroncards 1.000000;
patroncards/edit-layout.pl:use C4::Creators 1.000000;
patroncards/edit-layout.pl:use C4::Patroncards 1.000000;
patroncards/card-print.pl:use C4::Creators 1.000000;
patroncards/card-print.pl:use C4::Labels 1.000000;
patroncards/edit-batch.pl:use C4::Creators 1.000000;
patroncards/edit-batch.pl:use C4::Patroncards 1.000000;
patroncards/print.pl:use C4::Creators 1.000000;
patroncards/print.pl:use C4::Patroncards 1.000000;
patroncards/edit-profile.pl:use C4::Creators::Lib 1.000000 qw(get_all_templates get_unit_values);
patroncards/edit-profile.pl:use C4::Patroncards::Profile 1.000000;
tags/list.pl:use C4::Tags 0.03 qw(get_tags remove_tag get_tag_rows);
tags/review.pl:use C4::Output 3.02 qw(:html :ajax pagination_bar);
tags/review.pl:use C4::Tags 0.03 qw(get_tags get_approval_rows approval_counts whitelist blacklist is_approved);
tools/manage-marc-import.pl:use C4::Labels::Batch 1.000000;
Comment 7 Dobrica Pavlinusic 2012-06-27 14:22:54 UTC
I would love for this to land in master ASAP because it breaks our production, but I would be also happy with patch with removes all versions as Robin pointed out in comment #6... Should I submit one?
Comment 8 Paul Poulain 2012-06-29 09:39:06 UTC
Comment on attachment 10483 [details] [review]
Bug 8315 - fix 'C4::Output 3.02' errors in Koha

Robin, seems you forgot to obsolete the original patch when you uploaded the signed-off one
Comment 9 Chris Cormack 2012-06-29 09:42:26 UTC
This still needs a follow up for all the other version numbers Robin listed
Comment 10 Paul Poulain 2012-06-29 10:00:15 UTC
Comment on attachment 10490 [details] [review]
Bug 8315 - fix 'C4::Output 3.02' errors in Koha

This patch has been pushed
Comment 11 Paul Poulain 2012-06-29 10:01:22 UTC
Switching back to "assigned", the patch provided has been pushed, other patches welcomed !

Assigning to Dobrica, as you seem to be motivated by this topic ;-)
Comment 12 Chris Cormack 2012-06-29 21:30:33 UTC
First patch pushed to 3.8.x
Comment 13 Christophe Croullebois 2012-07-02 13:04:47 UTC
*** Bug 8344 has been marked as a duplicate of this bug. ***
Comment 14 Nicole C. Engard 2012-07-03 19:06:58 UTC
*** Bug 8354 has been marked as a duplicate of this bug. ***
Comment 15 Dobrica Pavlinusic 2012-07-12 16:05:51 UTC Comment hidden (obsolete)
Comment 16 Chris Cormack 2012-07-12 21:56:09 UTC Comment hidden (obsolete)
Comment 17 Jonathan Druart 2012-07-13 08:33:08 UTC
QA Comment:

Remove the version informations when we use a module.

C4::Labels[::*], use C4::Creators::*, C4::Installer::PerlModules, C4::Patroncards[::*], Locale::Currency::Format and C4::Tags

Marking as Passed QA
Comment 18 Chris Cormack 2012-07-13 22:28:28 UTC
Pushed to 3.8.x will be in 3.8.3
Comment 19 Chris Cormack 2012-08-13 02:38:13 UTC
*** Bug 8625 has been marked as a duplicate of this bug. ***