Bug 8489 - Revised ubuntu-pkg-check.sh, renamed ubuntu package files, tweaked 12.04 package file, copied 12.04 package file to ubuntu.packages
Summary: Revised ubuntu-pkg-check.sh, renamed ubuntu package files, tweaked 12.04 pack...
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Installation and upgrade (command-line installer) (show other bugs)
Version: 3.6
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Galen Charlton
QA Contact:
URL:
Keywords:
: 8488 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-07-21 13:35 UTC by M. Tompsett
Modified: 2013-12-05 19:59 UTC (History)
0 users

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Restructured ubuntu .packages files to include versioning and to have the ubuntu-pkg-check.sh script use the versioning (20.14 KB, patch)
2012-07-21 14:29 UTC, M. Tompsett
Details | Diff | Splinter Review
Restructured ubuntu .packages files to include versioning and to have the ubuntu-pkg-check.sh script use the versioning (20.17 KB, patch)
2012-07-21 14:46 UTC, M. Tompsett
Details | Diff | Splinter Review
Restructured ubuntu .packages files to include versioning and to have the ubuntu-pkg-check.sh script use the versioning (v3) (20.59 KB, patch)
2012-07-21 16:15 UTC, M. Tompsett
Details | Diff | Splinter Review
Bug 8489: Revise Ubuntu install files (11.73 KB, patch)
2012-07-21 17:37 UTC, Jared Camins-Esakov
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description M. Tompsett 2012-07-21 13:35:37 UTC
This may overlap with bug 8478.

The ubuntu-pkg-chk.sh script hardcoded the use of ubuntu.packages. By using an `lsb_release -r | cut -f2 -d'{tab}'` we can determine the version number of the ubuntu (tested on 10.04 and 12.04). If the user is running on a non-LTS, the script will inform the user and use the latest one, because
NOTE: ubuntu.packages SHOULD ALWAYS BE A COPY OF THE LATEST VERSION!!!

ubuntu.packages became ubuntu.10.04.packages
ubuntu_maverick.packages became ubuntu.10.10.packages
ubuntu.precise.packages became ubuntu.12.04.package (was created from 8488)

This supersedes bug 8488, by renaming ubuntu.precise.packages to ubuntu.12.04.packages and updating the libmysqlclient16 to mylibsqlclient18 and removing the libmysqlclient16-dev. There were no known dependencies in the perl libraries. Feel free to confirm otherwise.

I then copied ubuntu.12.04.packages back to ubuntu.packages after modifications, as the INSTALL.ubuntu install instructions say:
$ sudo dpkg --set-selections < install_misc/ubuntu.packages

The goal of this script is that:
   ./ubuntu-pkg-check.sh | grep none
should produce no output if all dependencies are installed (optional or otherwise).

However, it should be noted that the wiki instructions do not reference the file ubuntu-pkg-check.sh and it is currently only mentioned in the INSTALL.ubuntu.lucid instructions.

The figures generated by:
   # A = 
   $ ./install_misc/ubuntu-pkg-check | wc
   $ ./koha_perl_deps.pl -a
   # and B = the total modules reported number
should have A>=B. And, if the ubuntu packages were installed with dselect, there should be 0 modules listed for:
   $ ./koha_perl_deps.pl -m -u

To the cleanest 3.6.X version install yet! :)
Comment 1 M. Tompsett 2012-07-21 14:29:22 UTC Comment hidden (obsolete)
Comment 2 M. Tompsett 2012-07-21 14:46:49 UTC Comment hidden (obsolete)
Comment 3 M. Tompsett 2012-07-21 14:59:24 UTC
*** Bug 8488 has been marked as a duplicate of this bug. ***
Comment 4 Jared Camins-Esakov 2012-07-21 15:02:54 UTC
A version of this will also be needed for Master and 3.6.x.
Comment 5 M. Tompsett 2012-07-21 15:15:09 UTC
Once 3.6.7 is out the door with this, I'll work on a patch for master, but as a separate bug report.
Comment 6 M. Tompsett 2012-07-21 16:15:35 UTC Comment hidden (obsolete)
Comment 7 Jared Camins-Esakov 2012-07-21 17:37:21 UTC
Created attachment 11066 [details] [review]
Bug 8489: Revise Ubuntu install files

1) Changed ubuntu-pkg-check.sh to use lsb_release to determine version
   of ubuntu.{version}.packages file. If a versioned file does not
   exist, the user is warned, and ubuntu.packages is used. Told the
   user which file is being used. Caught apt-cache policy errors nicely.
   NOTE: ubuntu.packages MUST BE A COPY OF THE
   LATEST ubuntu.{version}.packages FILE!
2) Moved: ubuntu.packages -> ubuntu.10.04.packages
          ubuntu_maverick.packages -> ubuntu.10.10.packages
          ubuntu.precise.packages -> ubuntu.12.04 packages
             (last file created new, but effectively supersedes bug 8488)
3) Tweaked ubuntu.12.04.packages:
   * changed yaz3 references to yaz4
   * dropped libmysqlclient16-dev
   * changed libmysqlclient16 to libmysqlclient18
4) Copied the ubuntu.12.04.packages file to ubuntu.packages

Signed-off-by: Jared Camins-Esakov <jcamins@cpbibliography.com>
Comment 8 Jared Camins-Esakov 2012-07-21 17:39:23 UTC
This patch has been included in 3.6.7 to enable the installation of 3.6.7 under Ubuntu per the instructions.
Comment 9 M. Tompsett 2012-07-24 01:38:46 UTC
The patch for master will be done on bug 8478.