Bug 8575 - Number of items expected is wrong
Summary: Number of items expected is wrong
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Acquisitions (show other bugs)
Version: 3.8
Hardware: All All
: P5 - low normal (vote)
Assignee: Julian Maurice
QA Contact: Jonathan Druart
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-08-06 12:08 UTC by Julian Maurice
Modified: 2013-12-05 19:57 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 8575: Expected items count should not include cancelled orders (1.34 KB, patch)
2012-08-06 12:25 UTC, Julian Maurice
Details | Diff | Splinter Review
Bug 8575: Expected items count should not include cancelled orders (1.42 KB, patch)
2012-08-07 08:28 UTC, Chris Cormack
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Julian Maurice 2012-08-06 12:08:08 UTC
In acqui/booksellers.pl, the number below "Items expected" column is wrong, because it also takes into account cancelled orders.

Steps to reproduce:
1/ create a new basket with 2 orders, one with 1 item, another with 2 items
2/ look at booksellers.pl page, you should see that 3 items are expected
3/ cancel one order
4/ refresh booksellers.pl page, there are still 3 items expected
Comment 1 Julian Maurice 2012-08-06 12:25:15 UTC Comment hidden (obsolete)
Comment 2 Chris Cormack 2012-08-07 08:28:11 UTC
Created attachment 11406 [details] [review]
Bug 8575: Expected items count should not include cancelled orders

To test:
  1/ create a new basket with 2 orders, one with 1 item, another with 2
     items
  2/ look at booksellers.pl page, you should see that 3 items are
     expected
  3/ cancel the order with 1 item
  4/ refresh booksellers.pl page, it should remains 2 expected items

Signed-off-by: Chris Cormack <chris@bigballofwax.co.nz>

Works exactly as designed
Comment 3 Jonathan Druart 2012-08-09 11:52:27 UTC
Seems logical.
Marked as Passed QA
Comment 4 Chris Cormack 2012-08-10 07:26:02 UTC
Pushed to 3.8.x, will be in 3.8.4
Comment 5 Paul Poulain 2012-08-31 15:59:14 UTC
Pushed to master. Already pushed to stable, so setting status accordingly
Comment 6 Julian Maurice 2012-09-14 14:00:43 UTC
Ok in master and 3.8.x. Marked as RESOLVED.