Bug 8614 - Icon for scores on OPAC detail page broken
Summary: Icon for scores on OPAC detail page broken
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: OPAC (show other bugs)
Version: 3.8
Hardware: All All
: P5 - low minor (vote)
Assignee: Owen Leonard
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-08-10 05:23 UTC by Katrin Fischer
Modified: 2013-05-23 06:23 UTC (History)
1 user (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Text to go in the release notes:
Version(s) released in:


Attachments
screenshot (48.76 KB, image/png)
2012-08-10 05:23 UTC, Katrin Fischer
Details
Bug 8614 [3.8.x] Icon for scores on OPAC detail page broken (499.39 KB, patch)
2012-11-14 18:09 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 8614 [3.8.x] Icon for scores on OPAC detail page broken (499.42 KB, patch)
2012-11-29 17:48 UTC, Owen Leonard
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Katrin Fischer 2012-08-10 05:23:28 UTC
Created attachment 11520 [details]
screenshot

The icon for scores on the OPAC detail page is not displaying correctly, instead following text is shown:

Type: materialTypeLabelScore

In other cases the score icon shows up on the result list, but on the detail page the article icon or the book is shown. It seems that different conditions are used to determine which icon to display on both pages.
Comment 1 Owen Leonard 2012-11-02 16:24:09 UTC
I can't reproduce this bug in current master.
Comment 2 Katrin Fischer 2012-11-12 20:05:05 UTC
Hi Owen, I retested, I see it in 3.6.3 and 3.8.x - not on master.
Comment 3 Owen Leonard 2012-11-14 18:09:26 UTC Comment hidden (obsolete)
Comment 4 Chris Cormack 2012-11-28 06:55:03 UTC
I tried applying this on 3.8.x

Using index info to reconstruct a base tree...
error: patch failed: koha-tmpl/opac-tmpl/prog/famfamfam/mini/readme.txt:1
error: koha-tmpl/opac-tmpl/prog/famfamfam/mini/readme.txt: patch does not apply
error: patch failed: koha-tmpl/opac-tmpl/prog/famfamfam/readme.txt:1
error: koha-tmpl/opac-tmpl/prog/famfamfam/readme.txt: patch does not apply
Did you hand edit your patch?
It does not apply to blobs recorded in its index.
Cannot fall back to three-way merge.
Comment 5 Owen Leonard 2012-11-29 17:48:36 UTC
Created attachment 13784 [details] [review]
Bug 8614 [3.8.x] Icon for scores on OPAC detail page broken

At some point some famfamfam icons were moved out of the
theme director into the lib directory in opac-tmpl. When
this was done the path to the directory was changed accordingly
in most cases. However, not all famfamfam icons were moved,
and some image paths were not corrected.

This patch completes the move of the famfamfam icon set
to opac-tmpl/lib and corrects the path to the icons on
the OPAC XSL detail page and the OPAC holds page.

To test, view those pages and confirm that the images work.
View records with a variety of material types.

Edit: Rebased on origin/3.8.x
Comment 6 Chris Cormack 2012-11-29 21:36:01 UTC
Pushed to 3.8.x, thank you Owen