Bug 8630 - Add covers from AdLibris to the OPAC and Intranet
Summary: Add covers from AdLibris to the OPAC and Intranet
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: OPAC (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Martin Persson
QA Contact: Katrin Fischer
URL:
Keywords:
: 14953 (view as bug list)
Depends on:
Blocks: 8628
  Show dependency treegraph
 
Reported: 2012-08-13 12:59 UTC by Magnus Enger
Modified: 2019-10-14 19:57 UTC (History)
11 users (show)

See Also:
Change sponsored?: Sponsored
Patch complexity: Medium patch
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 8630 - Adlibris covers (syspref files) (5.69 KB, patch)
2015-10-07 09:37 UTC, Martin Persson
Details | Diff | Splinter Review
Bug 8630 - Adlibris covers (intranet templates) (6.61 KB, patch)
2015-10-08 14:26 UTC, Martin Persson
Details | Diff | Splinter Review
Bug 8630 - Adlibris covers (intranet CSS) (981 bytes, patch)
2015-10-08 14:26 UTC, Martin Persson
Details | Diff | Splinter Review
Bug 8630 - Adlibris covers (OPAC templates) (25.26 KB, patch)
2015-10-08 14:26 UTC, Martin Persson
Details | Diff | Splinter Review
Bug 8630 - Adlibris covers (OPAC less changes) (858 bytes, patch)
2015-10-08 14:27 UTC, Martin Persson
Details | Diff | Splinter Review
Bug 8630 - Adlibris covers (OPAC minified CSS) (83.10 KB, patch)
2015-10-08 14:27 UTC, Martin Persson
Details | Diff | Splinter Review
Bug 8630 - Adlibris covers (syspref files) (5.69 KB, patch)
2016-12-21 04:08 UTC, Aleisha Amohia
Details | Diff | Splinter Review
Bug 8630 - Adlibris covers (intranet templates) (6.37 KB, patch)
2016-12-21 04:08 UTC, Aleisha Amohia
Details | Diff | Splinter Review
Bug 8630 - Adlibris covers (intranet CSS) (953 bytes, patch)
2016-12-21 04:08 UTC, Aleisha Amohia
Details | Diff | Splinter Review
Bug 8630 - Adlibris covers (OPAC templates) (25.95 KB, patch)
2016-12-21 04:08 UTC, Aleisha Amohia
Details | Diff | Splinter Review
Bug 8630 - Adlibris covers (OPAC less changes) (858 bytes, patch)
2016-12-21 04:09 UTC, Aleisha Amohia
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 8630 - Adlibris covers (syspref files) (5.76 KB, patch)
2016-12-21 15:05 UTC, Owen Leonard
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 8630 - Adlibris covers (intranet templates) (6.43 KB, patch)
2016-12-21 15:05 UTC, Owen Leonard
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 8630 - Adlibris covers (intranet CSS) (1017 bytes, patch)
2016-12-21 15:05 UTC, Owen Leonard
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 8630 - Adlibris covers (OPAC templates) (26.01 KB, patch)
2016-12-21 15:05 UTC, Owen Leonard
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 8630 - Adlibris covers (OPAC less changes) (922 bytes, patch)
2016-12-21 15:06 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 8630 - Adlibris covers (syspref files) (5.75 KB, patch)
2017-06-13 02:00 UTC, Aleisha Amohia
Details | Diff | Splinter Review
Bug 8630 - Adlibris covers (intranet templates) (6.48 KB, patch)
2017-06-13 02:00 UTC, Aleisha Amohia
Details | Diff | Splinter Review
Bug 8630 - Adlibris covers (intranet CSS) (1015 bytes, patch)
2017-06-13 02:00 UTC, Aleisha Amohia
Details | Diff | Splinter Review
Bug 8630 - Adlibris covers (OPAC templates) (25.78 KB, patch)
2017-06-13 02:01 UTC, Aleisha Amohia
Details | Diff | Splinter Review
Bug 8630 - Adlibris covers (OPAC less changes) (909 bytes, patch)
2017-06-13 02:01 UTC, Aleisha Amohia
Details | Diff | Splinter Review
Bug 8630 - Regenerated CSS - Not minified, do NOT PUSH! (99.63 KB, patch)
2017-10-22 09:49 UTC, Katrin Fischer
Details | Diff | Splinter Review
Bug 8630 - Adlibris covers (intranet templates) (6.58 KB, patch)
2018-03-21 00:47 UTC, Aleisha Amohia
Details | Diff | Splinter Review
Bug 8630 - Adlibris covers (intranet CSS) (995 bytes, patch)
2018-03-21 00:47 UTC, Aleisha Amohia
Details | Diff | Splinter Review
Bug 8630 - Adlibris covers (OPAC templates) (25.78 KB, patch)
2018-03-21 00:47 UTC, Aleisha Amohia
Details | Diff | Splinter Review
Bug 8630 - Adlibris covers (OPAC less changes) (909 bytes, patch)
2018-03-21 00:47 UTC, Aleisha Amohia
Details | Diff | Splinter Review
Bug 8630 - Regenerated CSS - Not minified, do NOT PUSH! (143.17 KB, patch)
2018-03-21 00:47 UTC, Aleisha Amohia
Details | Diff | Splinter Review
Bug 8630 - Adlibris covers (syspref files) (5.75 KB, patch)
2018-07-11 01:27 UTC, Aleisha Amohia
Details | Diff | Splinter Review
Bug 8630 - Adlibris covers (intranet templates) (6.24 KB, patch)
2018-07-11 01:27 UTC, Aleisha Amohia
Details | Diff | Splinter Review
Bug 8630 - Adlibris covers (intranet CSS) (990 bytes, patch)
2018-07-11 01:27 UTC, Aleisha Amohia
Details | Diff | Splinter Review
Bug 8630 - Adlibris covers (OPAC templates) (25.48 KB, patch)
2018-07-11 01:27 UTC, Aleisha Amohia
Details | Diff | Splinter Review
Bug 8630 - Adlibris covers (OPAC less changes) (909 bytes, patch)
2018-07-11 01:27 UTC, Aleisha Amohia
Details | Diff | Splinter Review
Bug 8630: [FOLLOW-UP] Make Adlibris cover show on OPAC overdues tab (2.57 KB, patch)
2018-07-11 01:28 UTC, Aleisha Amohia
Details | Diff | Splinter Review
Bug 8630: Regenerated minified OPAC CSS (86.58 KB, patch)
2018-07-11 02:05 UTC, Aleisha Amohia
Details | Diff | Splinter Review
Bug 8630 - Adlibris covers (syspref files) (5.75 KB, patch)
2018-08-29 12:11 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 8630 - Adlibris covers (intranet templates) (6.30 KB, patch)
2018-08-29 12:11 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 8630 - Adlibris covers (intranet CSS) (43.85 KB, patch)
2018-08-29 12:11 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 8630 - Adlibris covers (OPAC templates) (26.19 KB, patch)
2018-08-29 12:11 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 8630 - Adlibris covers (OPAC less changes) (1.35 KB, patch)
2018-08-29 12:11 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 8630: [FOLLOW-UP] Make Adlibris cover show on OPAC overdues tab (2.60 KB, patch)
2018-08-29 12:11 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 8630 - Adlibris covers (syspref files) (5.78 KB, patch)
2018-10-05 02:54 UTC, Aleisha Amohia
Details | Diff | Splinter Review
Bug 8630 - Adlibris covers (intranet templates) (6.30 KB, patch)
2018-10-05 02:54 UTC, Aleisha Amohia
Details | Diff | Splinter Review
Bug 8630 - Adlibris covers (intranet CSS) (44.92 KB, patch)
2018-10-05 02:54 UTC, Aleisha Amohia
Details | Diff | Splinter Review
Bug 8630 - Adlibris covers (OPAC templates) (26.19 KB, patch)
2018-10-05 02:55 UTC, Aleisha Amohia
Details | Diff | Splinter Review
Bug 8630 - Adlibris covers (OPAC less changes) (1.74 KB, patch)
2018-10-05 02:55 UTC, Aleisha Amohia
Details | Diff | Splinter Review
Bug 8630: (follow-up) Make Adlibris cover show on OPAC overdues tab (2.60 KB, patch)
2018-10-05 02:55 UTC, Aleisha Amohia
Details | Diff | Splinter Review
Bug 8630: Adlibris covers (syspref files) (5.78 KB, patch)
2018-10-05 14:24 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 8630: Adlibris covers (intranet templates) (6.35 KB, patch)
2018-10-05 14:24 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 8630: Adlibris covers (intranet CSS) (1.28 KB, patch)
2018-10-05 14:24 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 8630: Adlibris covers (OPAC templates) (26.36 KB, patch)
2018-10-05 14:24 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 8630: Adlibris covers (OPAC SCSS changes) (1.74 KB, patch)
2018-10-05 14:24 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 8630: (follow-up) Make Adlibris cover show on OPAC overdues tab (2.62 KB, patch)
2018-10-05 14:24 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 8630: (follow-up) Template corrections (3.50 KB, patch)
2018-10-05 14:35 UTC, Owen Leonard
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 8630: (follow-up) Make Adlibris cover show on OPAC overdues tab (2.69 KB, patch)
2018-10-09 00:23 UTC, Aleisha Amohia
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 8630: (follow-up) Template corrections (3.57 KB, patch)
2018-10-09 00:24 UTC, Aleisha Amohia
Details | Diff | Splinter Review
Bug 8630: Adlibris covers (syspref files) (5.83 KB, patch)
2018-10-11 05:56 UTC, Katrin Fischer
Details | Diff | Splinter Review
Bug 8630: Adlibris covers (intranet templates) (6.41 KB, patch)
2018-10-11 05:56 UTC, Katrin Fischer
Details | Diff | Splinter Review
Bug 8630: Adlibris covers (intranet CSS) (1.34 KB, patch)
2018-10-11 05:56 UTC, Katrin Fischer
Details | Diff | Splinter Review
Bug 8630: Adlibris covers (OPAC templates) (26.42 KB, patch)
2018-10-11 05:56 UTC, Katrin Fischer
Details | Diff | Splinter Review
Bug 8630: Adlibris covers (OPAC SCSS changes) (1.79 KB, patch)
2018-10-11 05:56 UTC, Katrin Fischer
Details | Diff | Splinter Review
Bug 8630: (follow-up) Make Adlibris cover show on OPAC overdues tab (2.74 KB, patch)
2018-10-11 05:56 UTC, Katrin Fischer
Details | Diff | Splinter Review
Bug 8630: (follow-up) Template corrections (3.61 KB, patch)
2018-10-11 05:57 UTC, Katrin Fischer
Details | Diff | Splinter Review
Bug 8630: (RM follow-up) Remove loop.odd reference and fix filters (6.78 KB, patch)
2018-11-05 13:22 UTC, Nick Clemens
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Magnus Enger 2012-08-13 12:59:05 UTC
The "API" is really simple: 
http://www.adlibris.com/se/showimagesafe.aspx?isbn=9188876659
Comment 1 Martin Persson 2015-10-07 09:37:40 UTC Comment hidden (obsolete)
Comment 2 Martin Persson 2015-10-08 14:26:22 UTC Comment hidden (obsolete)
Comment 3 Martin Persson 2015-10-08 14:26:42 UTC Comment hidden (obsolete)
Comment 4 Martin Persson 2015-10-08 14:26:54 UTC Comment hidden (obsolete)
Comment 5 Martin Persson 2015-10-08 14:27:11 UTC Comment hidden (obsolete)
Comment 6 Martin Persson 2015-10-08 14:27:23 UTC Comment hidden (obsolete)
Comment 7 Martin Persson 2015-10-08 14:30:20 UTC
Added a system preference to the "Enhanced content" tab and changed all templates in Intranet and OPAC to include this new cover source. The images needed some new CSS classes for scaling purposes, these were added to both OPAC and intranet CSS files. Separated into a bunch of patchsets in case someone deems there is a better way to handle parts of this.
Comment 8 Aleisha Amohia 2015-12-28 22:15:17 UTC
Is this ready to test?
Comment 9 Mark Tompsett 2016-02-05 22:27:48 UTC
Please rebase.
Also, opac minified CSS is going to conflict regularly.
Comment 10 Aleisha Amohia 2016-12-21 04:08:42 UTC Comment hidden (obsolete)
Comment 11 Aleisha Amohia 2016-12-21 04:08:47 UTC Comment hidden (obsolete)
Comment 12 Aleisha Amohia 2016-12-21 04:08:53 UTC Comment hidden (obsolete)
Comment 13 Aleisha Amohia 2016-12-21 04:08:57 UTC Comment hidden (obsolete)
Comment 14 Aleisha Amohia 2016-12-21 04:09:03 UTC Comment hidden (obsolete)
Comment 15 Aleisha Amohia 2016-12-21 04:10:05 UTC
Patches have been rebased and are ready for testing.
Test WITHOUT the opac minified css patch - this will only cause painful conflicts.
Comment 16 Owen Leonard 2016-12-21 15:05:25 UTC Comment hidden (obsolete)
Comment 17 Owen Leonard 2016-12-21 15:05:34 UTC Comment hidden (obsolete)
Comment 18 Owen Leonard 2016-12-21 15:05:41 UTC Comment hidden (obsolete)
Comment 19 Owen Leonard 2016-12-21 15:05:50 UTC Comment hidden (obsolete)
Comment 20 Owen Leonard 2016-12-21 15:06:00 UTC Comment hidden (obsolete)
Comment 21 Aleisha Amohia 2017-06-13 02:00:33 UTC Comment hidden (obsolete)
Comment 22 Aleisha Amohia 2017-06-13 02:00:51 UTC Comment hidden (obsolete)
Comment 23 Aleisha Amohia 2017-06-13 02:00:57 UTC Comment hidden (obsolete)
Comment 24 Aleisha Amohia 2017-06-13 02:01:02 UTC Comment hidden (obsolete)
Comment 25 Aleisha Amohia 2017-06-13 02:01:08 UTC Comment hidden (obsolete)
Comment 26 Aleisha Amohia 2017-06-13 02:02:31 UTC
Patches have been rebased. Ready to test.
Comment 27 Katrin Fischer 2017-08-08 15:03:52 UTC
There is a conflict in the OPAC minified CSS:

Apply? [(y)es, (n)o, (i)nteractive] y
Applying: Bug 8630 - Adlibris covers (OPAC minified CSS)
Using index info to reconstruct a base tree...
M	koha-tmpl/opac-tmpl/bootstrap/css/opac.css
Falling back to patching base and 3-way merge...
Auto-merging koha-tmpl/opac-tmpl/bootstrap/css/opac.css
CONFLICT (content): Merge conflict in koha-tmpl/opac-tmpl/bootstrap/css/opac.css
error: Failed to merge in the changes.
Patch failed at 0001 Bug 8630 - Adlibris covers (OPAC minified CSS)

Leaving this Needs Signoff, someone familiar with the process could recompile before testing.
Comment 28 Magnus Enger 2017-08-29 06:54:40 UTC
*** Bug 14953 has been marked as a duplicate of this bug. ***
Comment 29 Katrin Fischer 2017-10-07 20:06:52 UTC
There is a conflict with the CSS files, Aleisha, could you fix please?
Would it be safe to leave the first patch off and then regenereate opac.css from the lst one?
Comment 30 Katrin Fischer 2017-10-07 20:07:17 UTC
pply? [(y)es, (n)o, (i)nteractive] y
Applying: Bug 8630 - Adlibris covers (OPAC minified CSS)
Using index info to reconstruct a base tree...
M	koha-tmpl/opac-tmpl/bootstrap/css/opac.css
Falling back to patching base and 3-way merge...
Auto-merging koha-tmpl/opac-tmpl/bootstrap/css/opac.css
CONFLICT (content): Merge conflict in koha-tmpl/opac-tmpl/bootstrap/css/opac.css
error: Failed to merge in the changes.
Patch failed at 0001 Bug 8630 - Adlibris covers (OPAC minified CSS)
The copy of the patch that failed is found in: .git/rebase-apply/patch
When you have resolved this problem run "git bz apply --continue".
If you would prefer to skip this patch, instead run "git bz apply --skip".
To restore the original branch and stop patching run "git bz apply --abort".
Patch left in /tmp/Bug-8630---Adlibris-covers-OPAC-minified-CSS-2gtmVc.patch
Comment 31 Mark Tompsett 2017-10-08 14:18:31 UTC
(In reply to Katrin Fischer from comment #30)
> pply? [(y)es, (n)o, (i)nteractive] y
> Applying: Bug 8630 - Adlibris covers (OPAC minified CSS)
> Using index info to reconstruct a base tree...
> M	koha-tmpl/opac-tmpl/bootstrap/css/opac.css

See my comment #9. This is why I asked Tomas to get lessc into the kohadevbox. I believe it is there now.
https://wiki.koha-community.org/wiki/Working_with_Bootstrap_OPAC_LESS_files
I'd recommend skipping the first patch, and then rebuilding the minified OPAC CSS.
I'll try to remember to check back in 12+ hours, and rebase if needed.
Comment 32 Aleisha Amohia 2017-10-20 00:31:09 UTC
(In reply to M. Tompsett from comment #31)
> (In reply to Katrin Fischer from comment #30)
> > pply? [(y)es, (n)o, (i)nteractive] y
> > Applying: Bug 8630 - Adlibris covers (OPAC minified CSS)
> > Using index info to reconstruct a base tree...
> > M	koha-tmpl/opac-tmpl/bootstrap/css/opac.css
> 
> See my comment #9. This is why I asked Tomas to get lessc into the
> kohadevbox. I believe it is there now.
> https://wiki.koha-community.org/wiki/Working_with_Bootstrap_OPAC_LESS_files
> I'd recommend skipping the first patch, and then rebuilding the minified
> OPAC CSS.
> I'll try to remember to check back in 12+ hours, and rebase if needed.

I didn't make the minified CSS file so I'm not 100% sure what to do with it! Martin can you check in here please? I think it was your patch.
Comment 33 Katrin Fischer 2017-10-22 09:01:18 UTC
Instructions on recreating the less changes are here:
https://wiki.koha-community.org/wiki/Working_with_Bootstrap_OPAC_LESS_files
Comment 34 Katrin Fischer 2017-10-22 09:48:02 UTC
Instructions on recreating the less changes are here:
https://wiki.koha-community.org/wiki/Working_with_Bootstrap_OPAC_LESS_files

I am super impressed with how fast and well the cover service works!

I am having trouble to generate the minified version in kohadevbox, I will upload my non-minified file for further testing, but we need to fix this correctly in the patches to be pushed.

1) Staff result list - OK
2) Staff detail page - Cover is in the wrong spot, please check!
3) OPAC result list - OK
4) OPAC detail page - OK
5) Recent reviews - OK
6) Recent reviews - RSS - OK
7) OPAC - patron account - reading history - OK
8) OPAC - patron account - checkouts - OK
9) OPAC - patron account - overdues - Not ok, I think some code here is missing, but if condition was changed in the template.

Read the code for opac-results-grouped.tt, but couldn't test. I am not sure if the feature this template is used is still usable even. Should not be a blocker.

Aleisha, could you try to generate the minified CSS and take a look at the two problem cases?
Comment 35 Katrin Fischer 2017-10-22 09:49:38 UTC Comment hidden (obsolete)
Comment 36 Aleisha Amohia 2018-03-21 00:47:03 UTC Comment hidden (obsolete)
Comment 37 Aleisha Amohia 2018-03-21 00:47:09 UTC Comment hidden (obsolete)
Comment 38 Aleisha Amohia 2018-03-21 00:47:15 UTC Comment hidden (obsolete)
Comment 39 Aleisha Amohia 2018-03-21 00:47:21 UTC Comment hidden (obsolete)
Comment 40 Aleisha Amohia 2018-03-21 00:47:27 UTC Comment hidden (obsolete)
Comment 41 Aleisha Amohia 2018-07-11 01:27:32 UTC Comment hidden (obsolete)
Comment 42 Aleisha Amohia 2018-07-11 01:27:38 UTC Comment hidden (obsolete)
Comment 43 Aleisha Amohia 2018-07-11 01:27:43 UTC Comment hidden (obsolete)
Comment 44 Aleisha Amohia 2018-07-11 01:27:49 UTC Comment hidden (obsolete)
Comment 45 Aleisha Amohia 2018-07-11 01:27:55 UTC Comment hidden (obsolete)
Comment 46 Aleisha Amohia 2018-07-11 01:28:01 UTC Comment hidden (obsolete)
Comment 47 Aleisha Amohia 2018-07-11 02:05:59 UTC Comment hidden (obsolete)
Comment 48 Aleisha Amohia 2018-07-11 02:07:13 UTC
Ready for testing. Use Test Plan in Comment 44
Comment 49 Cab Vinton 2018-08-28 23:38:20 UTC
Patch failed in PTFS Sandbox 0:

The sandbox you've requested is not ready.
Some problems occurred applying patches from bug 8630:
<h1>Something went wrong !</h1>Applying: Bug 8630 - Adlibris covers (syspref files)
Applying: Bug 8630 - Adlibris covers (intranet templates)
Using index info to reconstruct a base tree...
M       koha-tmpl/intranet-tmpl/prog/en/modules/catalogue/detail.tt
M       koha-tmpl/intranet-tmpl/prog/en/modules/catalogue/results.tt
Falling back to patching base and 3-way merge...
Auto-merging koha-tmpl/intranet-tmpl/prog/en/modules/catalogue/results.tt
Auto-merging koha-tmpl/intranet-tmpl/prog/en/modules/catalogue/detail.tt
Applying: Bug 8630 - Adlibris covers (intranet CSS)
error: Failed to merge in the changes.
Using index info to reconstruct a base tree...
M       koha-tmpl/intranet-tmpl/prog/css/staff-global.css
Falling back to patching base and 3-way merge...
Auto-merging koha-tmpl/intranet-tmpl/prog/css/staff-global.css
CONFLICT (content): Merge conflict in koha-tmpl/intranet-tmpl/prog/css/staff-global.css
Patch failed at 0001 Bug 8630 - Adlibris covers (intranet CSS)
The copy of the patch that failed is found in: .git/rebase-apply/patch
When you have resolved this problem run git bz apply --continue.
If you would prefer to skip this patch, instead run git bz apply --skip.
To restore the original branch and stop patching run git bz apply --abort.
Bug 8630 - Add covers from AdLibris to the OPAC and Intranet

76848 - Bug 8630 - Adlibris covers (syspref files)
76849 - Bug 8630 - Adlibris covers (intranet templates)
76850 - Bug 8630 - Adlibris covers (intranet CSS)
76851 - Bug 8630 - Adlibris covers (OPAC templates)
76852 - Bug 8630 - Adlibris covers (OPAC less changes)
76853 - Bug 8630: [FOLLOW-UP] Make Adlibris cover show on OPAC overdues tab
76859 - Bug 8630: Regenerated minified OPAC CSS

Apply? [(y)es, (n)o, (i)nteractive] Patch left in /tmp/Bug-8630---Adlibris-covers-intranet-CSS-11sz87.patch
Comment 50 Katrin Fischer 2018-08-29 05:38:58 UTC
Patch doesn't apply, please rebase!

Problem is probably this one:
Bug 19474 - Convert staff client CSS to SCSS
Comment 51 Owen Leonard 2018-08-29 12:11:08 UTC Comment hidden (obsolete)
Comment 52 Owen Leonard 2018-08-29 12:11:13 UTC Comment hidden (obsolete)
Comment 53 Owen Leonard 2018-08-29 12:11:17 UTC Comment hidden (obsolete)
Comment 54 Owen Leonard 2018-08-29 12:11:21 UTC Comment hidden (obsolete)
Comment 55 Owen Leonard 2018-08-29 12:11:26 UTC Comment hidden (obsolete)
Comment 56 Owen Leonard 2018-08-29 12:11:29 UTC Comment hidden (obsolete)
Comment 57 Aleisha Amohia 2018-10-05 02:54:39 UTC Comment hidden (obsolete)
Comment 58 Aleisha Amohia 2018-10-05 02:54:47 UTC Comment hidden (obsolete)
Comment 59 Aleisha Amohia 2018-10-05 02:54:54 UTC Comment hidden (obsolete)
Comment 60 Aleisha Amohia 2018-10-05 02:55:02 UTC Comment hidden (obsolete)
Comment 61 Aleisha Amohia 2018-10-05 02:55:11 UTC Comment hidden (obsolete)
Comment 62 Aleisha Amohia 2018-10-05 02:55:20 UTC Comment hidden (obsolete)
Comment 63 Owen Leonard 2018-10-05 14:24:06 UTC
Created attachment 80106 [details] [review]
Bug 8630: Adlibris covers (syspref files)

This patch adds a system preference for cover images from Swedish
book retailer Adlibris. Images are retrieved via http or https
from an external web server. This might leak OPAC and Staff
interface data to third parties and should thus be used with
caution.

Sponsored-By: Halland County Library

Test plan:

Test 1: Test upgrade procedure for clean installation.

  Start by removing existing sysprefs, if present:

  $ mysql -u kohaadmin -p -D koha
  > DELETE FROM `systempreferences` WHERE `variable` LIKE 'Adlibris%';

* Apply this patch which will add a pref file, update the 'syspref'
  structure and add an atomic upgrade file.

* Install the update:
  Koha$ perl installer/data/mysql/updatedatabase.pl

* Once upgraded and logged in, Select 'More', 'Administration',
  'Global Preferences' and finally 'Enhanced content'.
  There should be a new option called 'Adlibris'.

  The first option should default to "Don't show", if not the
  patch is broken.

  The second options should show the default URL:
  http://www.adlibris.com/se/organisationer/showimagesafe.aspx

  If not, the patch is broken.

Test 2: Changing sysprefs

* In the control panel, change the first value from "Don't show"
  to "Show" and save the changes. Use MySQL client to inspect changes:

  $ mysql -u kohaadmin -p -D koha
  > SELECT * FROM `systempreferences` WHERE `variable` LIKE 'Adlibris%';

  The column 'value' should now have the value '1', if not the patch
  is broken.

Test 3: Apply update to existing data

* Re-execute the installer now that the database has the data already:
  Koha$ perl installer/data/mysql/updatedatabase.pl

  If any errors occur the patch is broken.

  Examine the database contents:

  $ mysql -u kohaadmin -p -D koha
  > SELECT * FROM `systempreferences` WHERE `variable` LIKE 'Adlibris%';

  If the values were overwritten by the installer the patch is broken.

Signed-off-by: Owen Leonard <oleonard@myacpl.org>
Comment 64 Owen Leonard 2018-10-05 14:24:11 UTC
Created attachment 80107 [details] [review]
Bug 8630: Adlibris covers (intranet templates)

Changes to staff interface (intranet) templates.
Depends on new CSS clases defined in separate patch.

Test plan:

To test this particular patch (intranet templates) you need:
* The syspref patch applied
* The intranet CSS patch applied

To test:
* Apply this patch

* Enable covers (if not done already)
  * Go to staff interface, log in as a priviliged user.
  * Select "More" -> "Administration" ->
    "Global system preferences" -> "Enhanced content".
  * Set ""AdlibrisCoversEnabled" to "Show" under "Adlibris".
  * Save changes

* Add a book with a known cover/ISBN (if none exists)
  * Set MARC field 020 a,
    "INTERNATIONAL STANDARD BOOK NUMBER" to: 9780451524935
  * Set MARC field 245 a, "Title" to: 1984
  * Save changes

* Test results.tt
  * From the main intranet page, select "Search the catalog" and
    enter the title we added, "1984" and press "Search".
  * You should end up with the url:
    http://127.0.1.1:8080/cgi-bin/koha/catalogue/search.pl?q=1984
  * The cover image should be shown in the leftmost column.
  * If cover is clicked, the full cover image should be shown.

* Test detail.tt
  (continue from the search results used in prev. test)
  * Click on the title text, you should be sent to:
    http://127.0.1.1:8080/cgi-bin/koha/catalogue/detail.pl?biblionumber=2
  * The cover image should be shown on the right.
  * If clicked, the full cover should be shown.

Sponsored-By: Halland County Library

Signed-off-by: Owen Leonard <oleonard@myacpl.org>
Comment 65 Owen Leonard 2018-10-05 14:24:16 UTC
Created attachment 80108 [details] [review]
Bug 8630: Adlibris covers (intranet CSS)

This defined two new CSS classes for use by the intranet templates.
Apply this patch before doing the testing of "intranet templates".

Sponsored-By: Halland County Library

Signed-off-by: Owen Leonard <oleonard@myacpl.org>
Comment 66 Owen Leonard 2018-10-05 14:24:21 UTC
Created attachment 80109 [details] [review]
Bug 8630: Adlibris covers (OPAC templates)

Changes to OPAC templates.
Depends on new CSS clases defined in separate patch.

Test plan:

To test this particular patch (intranet templates) you need:
* The syspref patch applied
* The intranet CSS patch applied

To test:
* Apply this patch

* Enable covers (if not done already)
  * Go to staff interface, log in as a priviliged user.
  * Select "More" -> "Administration" ->
	"Global system preferences" -> "Enhanced content".
  * Set ""AdlibrisCoversEnabled" to "Show" under "Adlibris".
  * Save changes

* Add a book with a known cover/ISBN (if none exists)
  * Set MARC field 020 a,
	"INTERNATIONAL STANDARD BOOK NUMBER" to: 9780451524935
  * Set MARC field 245 a, "Title" to: 1984
  * Save changes

* Test opac-results.tt
  * Search library catalog from OPAC for "1984".
  * You should be sent to:
    http://127.0.1.1/cgi-bin/koha/opac-search.pl?idx=&q=1984
  * Cover image should be shown to the right of each title
    with CSS class: "adlibris-cover"

* Test opac-detail.tt
  (continued from previous test's location)
  * Click on the title with cover (1984, ISBN: 9780451524935)
  * Cover should be displayed to the left in full size.
  * If clicked, should link to the full-size image.

Test opac-results-grouped.tt
  * This template is only used if an external "grouping" server is
    setup and the syspref "OPACGroupResults" is set to "Use".
  * Personally I did not test this, b/c: terminally lazy

* Test opac-showreviews.tt
  * Could not find any links to this location, manually enter it:
    http://127.0.1.1/cgi-bin/koha/opac-showreviews.pl
  * Image should be shown to the right in full size.
  * If clicked it should take you to the detail view with the
    comments tab opened.

* Test opac-showreviews-rss.tt
  * Click on the RSS icon from previous test's start location.
    URL should be:
    http://127.0.1.1/cgi-bin/koha/opac-showreviews.pl?format=rss
  * An image tag linking to the full-size image without any
    styling class should be present.

* Test opac-user.tt
  * Click on your username to open:
    http://127.0.1.1/cgi-bin/koha/opac-user.pl
  * Covers should be shown for checked out items with
    CSS class: adlibris-cover
  * When clicked the destination should be the same as
    clicking the title column entry: opac-details.pl

* Test opac-opensearch.tt
  * Click on "Advanced search" and enter "1984" then press "Search"
  * This search screen uses a different template.
  * Cover image should be shown to the right of each title
    with CSS class: "adlibris-cover"
  * If clicked, should link to the OPAC detail view.

* Test opac-readingrecord.tt
  * Click on your logged-in name to go to your personal page.
  * Click on "Your reading history" tab on the left.
    http://127.0.1.1/cgi-bin/koha/opac-readingrecord.pl
  * Covers should be shown in leftmost column with
    CSS class: adlibris-cover
  * If clicked, should link to the same as the 'Title' link.

Sponsored-By: Halland County Library

Signed-off-by: Owen Leonard <oleonard@myacpl.org>
Comment 67 Owen Leonard 2018-10-05 14:24:25 UTC
Created attachment 80110 [details] [review]
Bug 8630: Adlibris covers (OPAC SCSS changes)

This patch adds two new CSS classes specific to Adlibris covers.

Sponsored-By: Halland County Library

Signed-off-by: Owen Leonard <oleonard@myacpl.org>
Comment 68 Owen Leonard 2018-10-05 14:24:30 UTC
Created attachment 80111 [details] [review]
Bug 8630: (follow-up) Make Adlibris cover show on OPAC overdues tab

and fix alignment of cover on Staff detail page.
Comment 69 Owen Leonard 2018-10-05 14:35:49 UTC
Created attachment 80119 [details] [review]
Bug 8630: (follow-up) Template corrections

This patch makes two corrections to templates: One to correct the case
of a variable, an error which I introduced when adding html filters.

The other removes a redundant image tag from the recent comments
template.

To test, apply the patch and log in to the OPAC as a user with
checkouts. Cover images on the "your summar" page should appear
correctly.

View the "recent comments" page and confirm that images still appear
correctly.
Comment 70 Aleisha Amohia 2018-10-09 00:23:53 UTC
Created attachment 80245 [details] [review]
[SIGNED-OFF] Bug 8630: (follow-up) Make Adlibris cover show on OPAC overdues tab

and fix alignment of cover on Staff detail page.

Signed-off-by: Aleisha Amohia <aleishaamohia@hotmail.com>
Comment 71 Aleisha Amohia 2018-10-09 00:24:57 UTC
Created attachment 80246 [details] [review]
[SIGNED-OFF] Bug 8630: (follow-up) Template corrections

This patch makes two corrections to templates: One to correct the case
of a variable, an error which I introduced when adding html filters.

The other removes a redundant image tag from the recent comments
template.

To test, apply the patch and log in to the OPAC as a user with
checkouts. Cover images on the "your summar" page should appear
correctly.

View the "recent comments" page and confirm that images still appear
correctly.

Signed-off-by: Aleisha Amohia <aleishaamohia@hotmail.com>
Comment 72 Katrin Fischer 2018-10-10 22:32:17 UTC
Started here, will continue soon!
Comment 73 Katrin Fischer 2018-10-11 05:56:26 UTC
Created attachment 80377 [details] [review]
Bug 8630: Adlibris covers (syspref files)

This patch adds a system preference for cover images from Swedish
book retailer Adlibris. Images are retrieved via http or https
from an external web server. This might leak OPAC and Staff
interface data to third parties and should thus be used with
caution.

Sponsored-By: Halland County Library

Test plan:

Test 1: Test upgrade procedure for clean installation.

  Start by removing existing sysprefs, if present:

  $ mysql -u kohaadmin -p -D koha
  > DELETE FROM `systempreferences` WHERE `variable` LIKE 'Adlibris%';

* Apply this patch which will add a pref file, update the 'syspref'
  structure and add an atomic upgrade file.

* Install the update:
  Koha$ perl installer/data/mysql/updatedatabase.pl

* Once upgraded and logged in, Select 'More', 'Administration',
  'Global Preferences' and finally 'Enhanced content'.
  There should be a new option called 'Adlibris'.

  The first option should default to "Don't show", if not the
  patch is broken.

  The second options should show the default URL:
  http://www.adlibris.com/se/organisationer/showimagesafe.aspx

  If not, the patch is broken.

Test 2: Changing sysprefs

* In the control panel, change the first value from "Don't show"
  to "Show" and save the changes. Use MySQL client to inspect changes:

  $ mysql -u kohaadmin -p -D koha
  > SELECT * FROM `systempreferences` WHERE `variable` LIKE 'Adlibris%';

  The column 'value' should now have the value '1', if not the patch
  is broken.

Test 3: Apply update to existing data

* Re-execute the installer now that the database has the data already:
  Koha$ perl installer/data/mysql/updatedatabase.pl

  If any errors occur the patch is broken.

  Examine the database contents:

  $ mysql -u kohaadmin -p -D koha
  > SELECT * FROM `systempreferences` WHERE `variable` LIKE 'Adlibris%';

  If the values were overwritten by the installer the patch is broken.

Signed-off-by: Owen Leonard <oleonard@myacpl.org>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 74 Katrin Fischer 2018-10-11 05:56:33 UTC
Created attachment 80378 [details] [review]
Bug 8630: Adlibris covers (intranet templates)

Changes to staff interface (intranet) templates.
Depends on new CSS clases defined in separate patch.

Test plan:

To test this particular patch (intranet templates) you need:
* The syspref patch applied
* The intranet CSS patch applied

To test:
* Apply this patch

* Enable covers (if not done already)
  * Go to staff interface, log in as a priviliged user.
  * Select "More" -> "Administration" ->
    "Global system preferences" -> "Enhanced content".
  * Set ""AdlibrisCoversEnabled" to "Show" under "Adlibris".
  * Save changes

* Add a book with a known cover/ISBN (if none exists)
  * Set MARC field 020 a,
    "INTERNATIONAL STANDARD BOOK NUMBER" to: 9780451524935
  * Set MARC field 245 a, "Title" to: 1984
  * Save changes

* Test results.tt
  * From the main intranet page, select "Search the catalog" and
    enter the title we added, "1984" and press "Search".
  * You should end up with the url:
    http://127.0.1.1:8080/cgi-bin/koha/catalogue/search.pl?q=1984
  * The cover image should be shown in the leftmost column.
  * If cover is clicked, the full cover image should be shown.

* Test detail.tt
  (continue from the search results used in prev. test)
  * Click on the title text, you should be sent to:
    http://127.0.1.1:8080/cgi-bin/koha/catalogue/detail.pl?biblionumber=2
  * The cover image should be shown on the right.
  * If clicked, the full cover should be shown.

Sponsored-By: Halland County Library

Signed-off-by: Owen Leonard <oleonard@myacpl.org>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 75 Katrin Fischer 2018-10-11 05:56:39 UTC
Created attachment 80379 [details] [review]
Bug 8630: Adlibris covers (intranet CSS)

This defined two new CSS classes for use by the intranet templates.
Apply this patch before doing the testing of "intranet templates".

Sponsored-By: Halland County Library

Signed-off-by: Owen Leonard <oleonard@myacpl.org>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 76 Katrin Fischer 2018-10-11 05:56:45 UTC
Created attachment 80380 [details] [review]
Bug 8630: Adlibris covers (OPAC templates)

Changes to OPAC templates.
Depends on new CSS clases defined in separate patch.

Test plan:

To test this particular patch (intranet templates) you need:
* The syspref patch applied
* The intranet CSS patch applied

To test:
* Apply this patch

* Enable covers (if not done already)
  * Go to staff interface, log in as a priviliged user.
  * Select "More" -> "Administration" ->
	"Global system preferences" -> "Enhanced content".
  * Set ""AdlibrisCoversEnabled" to "Show" under "Adlibris".
  * Save changes

* Add a book with a known cover/ISBN (if none exists)
  * Set MARC field 020 a,
	"INTERNATIONAL STANDARD BOOK NUMBER" to: 9780451524935
  * Set MARC field 245 a, "Title" to: 1984
  * Save changes

* Test opac-results.tt
  * Search library catalog from OPAC for "1984".
  * You should be sent to:
    http://127.0.1.1/cgi-bin/koha/opac-search.pl?idx=&q=1984
  * Cover image should be shown to the right of each title
    with CSS class: "adlibris-cover"

* Test opac-detail.tt
  (continued from previous test's location)
  * Click on the title with cover (1984, ISBN: 9780451524935)
  * Cover should be displayed to the left in full size.
  * If clicked, should link to the full-size image.

Test opac-results-grouped.tt
  * This template is only used if an external "grouping" server is
    setup and the syspref "OPACGroupResults" is set to "Use".
  * Personally I did not test this, b/c: terminally lazy

* Test opac-showreviews.tt
  * Could not find any links to this location, manually enter it:
    http://127.0.1.1/cgi-bin/koha/opac-showreviews.pl
  * Image should be shown to the right in full size.
  * If clicked it should take you to the detail view with the
    comments tab opened.

* Test opac-showreviews-rss.tt
  * Click on the RSS icon from previous test's start location.
    URL should be:
    http://127.0.1.1/cgi-bin/koha/opac-showreviews.pl?format=rss
  * An image tag linking to the full-size image without any
    styling class should be present.

* Test opac-user.tt
  * Click on your username to open:
    http://127.0.1.1/cgi-bin/koha/opac-user.pl
  * Covers should be shown for checked out items with
    CSS class: adlibris-cover
  * When clicked the destination should be the same as
    clicking the title column entry: opac-details.pl

* Test opac-opensearch.tt
  * Click on "Advanced search" and enter "1984" then press "Search"
  * This search screen uses a different template.
  * Cover image should be shown to the right of each title
    with CSS class: "adlibris-cover"
  * If clicked, should link to the OPAC detail view.

* Test opac-readingrecord.tt
  * Click on your logged-in name to go to your personal page.
  * Click on "Your reading history" tab on the left.
    http://127.0.1.1/cgi-bin/koha/opac-readingrecord.pl
  * Covers should be shown in leftmost column with
    CSS class: adlibris-cover
  * If clicked, should link to the same as the 'Title' link.

Sponsored-By: Halland County Library

Signed-off-by: Owen Leonard <oleonard@myacpl.org>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 77 Katrin Fischer 2018-10-11 05:56:52 UTC
Created attachment 80381 [details] [review]
Bug 8630: Adlibris covers (OPAC SCSS changes)

This patch adds two new CSS classes specific to Adlibris covers.

Sponsored-By: Halland County Library

Signed-off-by: Owen Leonard <oleonard@myacpl.org>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 78 Katrin Fischer 2018-10-11 05:56:59 UTC
Created attachment 80382 [details] [review]
Bug 8630: (follow-up) Make Adlibris cover show on OPAC overdues tab

and fix alignment of cover on Staff detail page.

Signed-off-by: Aleisha Amohia <aleishaamohia@hotmail.com>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 79 Katrin Fischer 2018-10-11 05:57:05 UTC
Created attachment 80383 [details] [review]
Bug 8630: (follow-up) Template corrections

This patch makes two corrections to templates: One to correct the case
of a variable, an error which I introduced when adding html filters.

The other removes a redundant image tag from the recent comments
template.

To test, apply the patch and log in to the OPAC as a user with
checkouts. Cover images on the "your summar" page should appear
correctly.

View the "recent comments" page and confirm that images still appear
correctly.

Signed-off-by: Aleisha Amohia <aleishaamohia@hotmail.com>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 80 Katrin Fischer 2018-10-11 05:58:20 UTC
A long journey - thx for your perseverance!
Comment 81 Jonathan Druart 2018-10-17 19:37:26 UTC
Maybe a silly question but, should not the css rules depend on the device (@media)? max-height in px is ok? (I did not test!)

Could we imagine a test to make sure the service is still working correctly?
Comment 82 Owen Leonard 2018-10-18 15:25:03 UTC
(In reply to Jonathan Druart from comment #81)
> Maybe a silly question but, should not the css rules depend on the device
> (@media)? max-height in px is ok? (I did not test!)

Looking at how things are displayed in both the OPAC and staff client, I think this patch works well.
Comment 83 Nick Clemens 2018-11-05 13:22:30 UTC
Created attachment 81934 [details] [review]
Bug 8630: (RM follow-up) Remove loop.odd reference and fix filters
Comment 84 Nick Clemens 2018-11-05 14:55:17 UTC
Awesome work all!

Pushed to master for 18.11
Comment 85 Martin Renvoize 2018-11-16 12:24:16 UTC
Enhancement, will not be backported to 18.05.x series.