Bug 8733 - Adding critic reviews to book pages
Summary: Adding critic reviews to book pages
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: OPAC (show other bugs)
Version: 3.12
Hardware: All All
: P5 - low new feature (vote)
Assignee: Jared Camins-Esakov
QA Contact: Jonathan Druart
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-09-06 02:36 UTC by idb
Modified: 2014-05-26 21:04 UTC (History)
5 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Large patch
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
PowerPoint Presentation of mockups (607.50 KB, application/vnd.ms-powerpoint)
2012-09-06 02:36 UTC, idb
Details
Slide one: New tab (82.58 KB, image/png)
2012-09-06 15:00 UTC, Owen Leonard
Details
Slide 2: Snippets of critics' reviews (110.84 KB, image/png)
2012-09-06 15:01 UTC, Owen Leonard
Details
Slide 3: Critics' rating (78.37 KB, image/png)
2012-09-06 15:02 UTC, Owen Leonard
Details
Slide 4: Readometer (83.24 KB, image/png)
2012-09-06 15:02 UTC, Owen Leonard
Details
Bug 8733: Add IDreamBooks.com enhanced content (15.74 KB, patch)
2012-09-24 23:36 UTC, Jared Camins-Esakov
Details | Diff | Splinter Review
Bug 8733: Add IDreamBooks.com enhanced content (16.96 KB, patch)
2012-09-25 11:57 UTC, Jared Camins-Esakov
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 8733: Add IDreamBooks.com enhanced content (17.13 KB, patch)
2012-09-28 13:27 UTC, Kyle M Hall
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 8733: Add IDreamBooks.com enhanced content (17.12 KB, patch)
2012-09-28 13:44 UTC, Nicole C. Engard
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 8733: Add IDreamBooks.com enhanced content (17.21 KB, patch)
2012-09-28 13:47 UTC, Kyle M Hall
Details | Diff | Splinter Review
Bug 8733: Add IDreamBooks.com enhanced content (17.07 KB, patch)
2013-01-01 00:35 UTC, Jared Camins-Esakov
Details | Diff | Splinter Review
Bug 8733 follow-up: restore isbn class in details page (1.73 KB, patch)
2013-01-31 15:44 UTC, Jared Camins-Esakov
Details | Diff | Splinter Review
Bug 8733: Follow-up The isbn sent to idream contains dash (1.46 KB, patch)
2013-02-01 12:42 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 8733 follow-up: restore isbn class in details page (1.79 KB, patch)
2013-02-01 15:41 UTC, Jared Camins-Esakov
Details | Diff | Splinter Review
Bug 8733: Follow-up The isbn sent to idream contains dash (1.52 KB, patch)
2013-02-01 15:42 UTC, Jared Camins-Esakov
Details | Diff | Splinter Review
Bug 8733: Add IDreamBooks.com enhanced content (17.13 KB, patch)
2013-02-04 09:00 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 8733 follow-up: restore isbn class in details page (1.86 KB, patch)
2013-02-04 09:00 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 8733: Follow-up The isbn sent to idream contains dash (1.58 KB, patch)
2013-02-04 09:00 UTC, Jonathan Druart
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description idb 2012-09-06 02:36:54 UTC
Created attachment 11996 [details]
PowerPoint Presentation of mockups

A proposal to enhance the detail page of a book by adding a section titled "Book reviews by critics" similar to the "Amazon reviews" section. This section would display 5 critic reviews from idreambooks.com as per the guidelines in iDreamBooks' API (idreambooks.com/api). 

For example, for the book MoonWalking with Einsten, the editorial review snippets from sources like The Guardian, NYTimes, WashingtonPost, etc. would be shown. See example of API output for the book here: http://idreambooks.com/newbooks/api.xml?q=moonwalking+with+einstein+foer&key=example_key

In addition to the review snippets, the overall rating of the book would get displayed on the detail page of a book to help users gauge the rating of the book in an instant. The rating on it's own or the entire "Readometer" or both can be displayed. For example, for the book MoonWalking with Einstein, it's rating of 80% would be displayed under the title of the book. Alternatively, the "Readometer" could also be displayed. 

Please see attached powerpoint presentation for images that give more detail.

We (iDreamBooks) are willing to provide development assistance to implement these enhancements.
Comment 1 Owen Leonard 2012-09-06 15:00:53 UTC
Created attachment 12015 [details]
Slide one: New tab
Comment 2 Owen Leonard 2012-09-06 15:01:45 UTC
Created attachment 12016 [details]
Slide 2: Snippets of critics' reviews
Comment 3 Owen Leonard 2012-09-06 15:02:15 UTC
Created attachment 12017 [details]
Slide 3: Critics' rating
Comment 4 Owen Leonard 2012-09-06 15:02:39 UTC
Created attachment 12018 [details]
Slide 4: Readometer
Comment 5 idb 2012-09-10 23:02:09 UTC
We have added a way to retrieve the "Readometer" based on ISBN number. See http://www.idreambooks.com/remotereadometer/9780143120537.html for example.

Also, we would need help from the community for implementation as we are a bit thin on resources.
Comment 6 Jared Camins-Esakov 2012-09-24 23:36:03 UTC Comment hidden (obsolete)
Comment 7 Jared Camins-Esakov 2012-09-25 11:57:04 UTC Comment hidden (obsolete)
Comment 8 Kyle M Hall 2012-09-28 13:27:24 UTC Comment hidden (obsolete)
Comment 9 Kyle M Hall 2012-09-28 13:27:56 UTC
Followed the test plan, everything looks good!
Comment 10 Nicole C. Engard 2012-09-28 13:44:02 UTC Comment hidden (obsolete)
Comment 11 Kyle M Hall 2012-09-28 13:47:02 UTC Comment hidden (obsolete)
Comment 12 Mason James 2012-10-07 00:00:21 UTC
tagging this for inclusion in 3.12 release...
Comment 13 idb 2012-10-07 01:16:40 UTC
(In reply to comment #12)
> tagging this for inclusion in 3.12 release...

Is there anyway we can get this into the next release of 3.10? Like 3.10.1 (assuming the first one is 3.10.0)? The development has been completed...and looks like tests are passing...?
Comment 14 Chris Cormack 2012-10-07 02:56:00 UTC
Here's how Koha releases work

http://koha-community.org/about/release-schedule/

New features only go into a .0 release, and this feature has missed the feature freeze for 3.10.0, so the next feature release is 3.12.0.

It can obviously get pushed up into git, but it won't be in an official release before then. (Speaking as the release maintainer (unless someone else volunteers that is) for 3.10.x)
Comment 15 Jonathan Druart 2012-11-13 14:01:38 UTC
QA Comment:

I cannot test this feature.
Where is the class 'isbn' used to set the js variable isbn ?
    var isbn = $(".isbn:last").text().split(" ")[1];
I don't find any occurrence of this class in the opac detail page.

Question: What is the key (key=8bf66516232d1b72f3e47df939653e1e) used in the url to idreambooks.com ? Is it a good idea to hard code it in the template ?

These patchs have to be rebased, I switch the status to "does not apply".
Comment 16 Jared Camins-Esakov 2013-01-01 00:35:11 UTC Comment hidden (obsolete)
Comment 17 Jonathan Druart 2013-01-30 14:33:05 UTC
(In reply to comment #15)

No answer ?

> I cannot test this feature.
> Where is the class 'isbn' used to set the js variable isbn ?
>     var isbn = $(".isbn:last").text().split(" ")[1];
> I don't find any occurrence of this class in the opac detail page.

Finally I understand, the class is added by the webservice.

> Question: What is the key (key=8bf66516232d1b72f3e47df939653e1e) used in the
> url to idreambooks.com ? Is it a good idea to hard code it in the template ?

But I would like to have an answer for these questions before to pass qa this patch.
Comment 18 Jared Camins-Esakov 2013-01-30 15:18:18 UTC
(In reply to comment #17)
> (In reply to comment #15)
> 
> No answer ?
> 
> > I cannot test this feature.
> > Where is the class 'isbn' used to set the js variable isbn ?
> >     var isbn = $(".isbn:last").text().split(" ")[1];
> > I don't find any occurrence of this class in the opac detail page.
> 
> Finally I understand, the class is added by the webservice.
> 
> > Question: What is the key (key=8bf66516232d1b72f3e47df939653e1e) used in the
> > url to idreambooks.com ? Is it a good idea to hard code it in the template ?
> 
> But I would like to have an answer for these questions before to pass qa
> this patch.

Sorry, I didn't see the question. The key was assigned by idreambooks.com for Koha.
Comment 19 Jonathan Druart 2013-01-31 11:32:51 UTC
I got the same problem as last time.

The detail page does not displayed the readometer, the critic rating and the reviews.

The isbn variable is always undefined in the following test:
[% IF ( IDreamBooksReviews || IDreamBooksReadometer ) %]
        var isbn = $(".isbn:last").text().split(" ")[1];
        // I pass here
        if (isbn) {
        // I never pass here

There is no isbn class in my generated html!
What I missed?
Comment 20 Jared Camins-Esakov 2013-01-31 15:44:12 UTC Comment hidden (obsolete)
Comment 21 Jared Camins-Esakov 2013-01-31 15:48:45 UTC
The isbn class was already in the XSLT view, but I rebased out the added class from the normal view. I did a follow-up to re-add the line.
Comment 22 Jonathan Druart 2013-02-01 12:40:54 UTC
I tried with an isbn-13 (978-*) and the ws does not return any result. But if I delete the dash, the ws returns the good one.
Comment 23 Jonathan Druart 2013-02-01 12:42:54 UTC Comment hidden (obsolete)
Comment 24 Jonathan Druart 2013-02-01 12:43:31 UTC
Jared, do you think this patch is relevant?
Comment 25 Jared Camins-Esakov 2013-02-01 15:41:53 UTC Comment hidden (obsolete)
Comment 26 Jared Camins-Esakov 2013-02-01 15:42:01 UTC Comment hidden (obsolete)
Comment 27 Jared Camins-Esakov 2013-02-01 16:44:15 UTC
(In reply to comment #24)
> Jared, do you think this patch is relevant?

Yes, I think it was a very good idea. I signed off on your follow-up.
Comment 28 Jonathan Druart 2013-02-04 08:59:48 UTC
QA comments:

Everything works to me now.
The critic rating area is displayed on the bottom of the details contrary to what the snapshot points out (not blocker).

I didn't find any regression or any problem with the proposed code.
So I mark as passed QA these patchs.
Comment 29 Jonathan Druart 2013-02-04 09:00:05 UTC
Created attachment 15024 [details] [review]
Bug 8733: Add IDreamBooks.com enhanced content

Adds the following enhanced content to the OPAC, all controlled by
separate sysprefs:
1) A "Readometer" which summarizes reviews on the OPAC detail page
2) A tab with snippets of critical reviews on the OPAC detail page
3) A computed rating on the results page

To test:
Find a book that is listed on IDreamBooks.com (you may have to make
sure that you have the first edition), and one that is not. Try
each of IDreamBooksReadometer, IDreamBooksReviews, and
IDreamBooksResults sysprefs, taking note of the content appearing (or
not) as appropriate.

Updated to add missing CSS to new theme.

Signed-off-by: Nicole C. Engard <nengard@bywatersolutions.com>
all tests pass.

Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>
Signed-off-by: Jared Camins-Esakov <jcamins@cpbibliography.com>
Rebased to latest master 2012-12-31

Signed-off-by: Jonathan Druart <jonathan.druart@biblibre.com>
Comment 30 Jonathan Druart 2013-02-04 09:00:12 UTC
Created attachment 15025 [details] [review]
Bug 8733 follow-up: restore isbn class in details page

For some reason the isbn CSS class was missing from the details
page, presumably due to a bad merge. This one-line commit re-adds
it so that the critics reviews will show up.

Signed-off-by: Jared Camins-Esakov <jcamins@cpbibliography.com>

Signed-off-by: Jonathan Druart <jonathan.druart@biblibre.com>
Comment 31 Jonathan Druart 2013-02-04 09:00:18 UTC
Created attachment 15026 [details] [review]
Bug 8733: Follow-up The isbn sent to idream contains dash

Signed-off-by: Jared Camins-Esakov <jcamins@cpbibliography.com>

Signed-off-by: Jonathan Druart <jonathan.druart@biblibre.com>
Comment 32 Jared Camins-Esakov 2013-02-04 13:03:41 UTC
This patch has been pushed to master.
Comment 33 Nicole C. Engard 2013-02-08 15:54:06 UTC
I was going to document this, I have the preferences, but don't see the content when i turn them on ... is there maybe an updatedatabase problem here?
Comment 34 Nicole C. Engard 2013-02-09 14:07:56 UTC
The problem is in the limited content.  I have added a warning to the manual - the  feature itself does in fact work though :)