Bug 8853 - clicking basketgroup name in closed basketgroups reopens it
Summary: clicking basketgroup name in closed basketgroups reopens it
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Acquisitions (show other bugs)
Version: master
Hardware: All All
: P5 - low major (vote)
Assignee: mathieu saby
QA Contact:
URL: cgi-bin/koha/acqui/basketgroup.pl?boo...
Keywords:
Depends on:
Blocks:
 
Reported: 2012-10-01 14:09 UTC by Nicole C. Engard
Modified: 2014-05-26 21:04 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
[PATCH] Bug 8853: Suppress links in basketgroups list (2.49 KB, patch)
2013-03-09 15:23 UTC, mathieu saby
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 8853: Suppress links in basketgroups list (2.59 KB, patch)
2013-03-11 15:57 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 8853: Suppress links in basketgroups list (2.60 KB, patch)
2013-03-11 16:28 UTC, Jonathan Druart
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Nicole C. Engard 2012-10-01 14:09:58 UTC
When I'm looking at my closed basket groups if I click the name of the basket I think it's supposed to open a summary (like it does on the open tab) but instead clicking a basket name reopens that basket ... if this is the intended behavior we need to make that clear, if not we need to fix it.

Nicole
Comment 1 mathieu saby 2013-02-06 16:07:48 UTC
Hello Nicole
In your title you speak of "closed baskets", but I think you mean "closed basket groups"?
If you mean basket groups, we have seen the same behavior, and it is clearly a UX problem. Clicking on closed basketgroups should show some summary, or it should be impossible, but it should NOT reopen basketgroup!

For the moment I can make a very small patch : deleting the link.
And if somebody wants to create a summary page, it will be an ENH

Do you agree with that?

M. Saby
Rennes 2 University
Comment 2 Nicole C. Engard 2013-02-08 14:23:18 UTC
Yes you are right.
Comment 3 mathieu saby 2013-03-08 20:52:34 UTC
OK Nicole, I changed the name of the bug, and I will make a patch.
M. Saby
Comment 4 mathieu saby 2013-03-08 21:09:32 UTC
I will take profit of the occasion to add more information on basketgroup list page, so it won't be necessary to click on each basketgroup to know some basical details (billingplace, deliveryplace, number of baskets in each basketgroup, number of orders, number of received orders...)

In basketgroups, actions are triggered by buttons. In other pages (as booksellers), they are triggered by links. It sound strange for me. Is there a rule for that in Koha?

M. Saby
Comment 5 mathieu saby 2013-03-09 15:23:06 UTC Comment hidden (obsolete)
Comment 6 mathieu saby 2013-03-09 15:24:20 UTC
Here is a small patch, just to suppress links around basketgroup name.
I am working on an other patch for improving basketgroup management.

M. Saby
Comment 7 Owen Leonard 2013-03-11 15:57:45 UTC Comment hidden (obsolete)
Comment 8 Jonathan Druart 2013-03-11 16:28:19 UTC
QA comment:

This patch fixes an ergonomic issue (action edit or reopen on clicking a basketgroup name link).
qa tools complains on tabulation characters but the file contains too much tab.

Marked as Passed QA.
Comment 9 Jonathan Druart 2013-03-11 16:28:41 UTC
Created attachment 16040 [details] [review]
Bug 8853: Suppress links in basketgroups list

In the table listing all closed basketgroups, clicking the name of a
basketgroup reopen it. To edit an open basketgroup or reopen a closed
basketgroup, there are specific buttons in "Action" column. So the link
around basketgroup name is an UX problem. This patch suppress the link
around basketgroup name, in both "closed" and "open" tab.

To test :
1. create some closed and open basketgroups
2. check links are not showing anymore

Signed-off-by: Owen Leonard <oleonard@myacpl.org>
Signed-off-by: Jonathan Druart <jonathan.druart@biblibre.com>
Comment 10 Jared Camins-Esakov 2013-03-13 12:02:57 UTC
This patch has been pushed to master.
Comment 11 Chris Cormack 2013-03-16 21:11:44 UTC
Pushed to 3.10.x will be in 3.10.4