Bug 8858 - C4::Circulation::GetBranchItemRule is poorly written
Summary: C4::Circulation::GetBranchItemRule is poorly written
Status: RESOLVED DUPLICATE of bug 18936
Alias: None
Product: Koha
Classification: Unclassified
Component: Circulation (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Kyle M Hall
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-10-02 11:47 UTC by Kyle M Hall
Modified: 2019-04-28 21:09 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kyle M Hall 2012-10-02 11:47:08 UTC
The function C4::Circulation::GetBranchItemRule is mean to return back the 'hold allowed' policy and whether to return an item to the home or holding branch. A visual inspection of this subroutine shows that it could be re-factored for efficiency. It always runs all four searches even if it is unnecessary.
Comment 1 Katrin Fischer 2019-04-28 11:39:34 UTC
Should we still keep this open in light of the work on issuing rules?
Comment 2 Jonathan Druart 2019-04-28 21:09:54 UTC
Indeed, the problem reported by Kyle originally will be fixed by bug 18936.

*** This bug has been marked as a duplicate of bug 18936 ***