Bug 9033 - Wide character error in runreport.pl
Summary: Wide character error in runreport.pl
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Reports (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Target Milestone: ---
Assignee: Kyle M Hall
QA Contact: Paul Poulain
URL:
Whiteboard:
Keywords:
: 10031 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-11-08 15:35 UTC by Kyle M Hall
Modified: 2014-05-26 21:04 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 9033 - Wide character error in runreport.pl (1.03 KB, patch)
2012-11-08 15:39 UTC, Kyle M Hall
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 9033 - Wide character error in runreport.pl (1.05 KB, patch)
2012-11-22 16:22 UTC, Julian Maurice
Details | Diff | Splinter Review
[Follow-up] Bug 9033: Wide character error in runreport.pl (1.03 KB, patch)
2012-11-22 16:22 UTC, Julian Maurice
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 9033: Wide character error in runreport.pl (1.08 KB, patch)
2012-12-03 17:22 UTC, Kyle M Hall
Details | Diff | Splinter Review
Bug 9033 - Wide character error in runreport.pl (1.05 KB, patch)
2012-12-11 19:46 UTC, Paul Poulain
Details | Diff | Splinter Review
Bug 9033: Wide character error in runreport.pl (1.13 KB, patch)
2012-12-11 19:46 UTC, Paul Poulain
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Kyle M Hall 2012-11-08 15:35:08 UTC
runreport.pl is not encoding email correctly. 

Wide character in subroutine entry at /usr/share/perl5/Mail/Sendmail.pm line 308.
Comment 1 Kyle M Hall 2012-11-08 15:39:41 UTC Comment hidden (obsolete)
Comment 2 Owen Leonard 2012-11-08 17:37:05 UTC
This needs a test plan.
Comment 3 Kyle M Hall 2012-11-19 13:26:53 UTC
Test Plan:
1) Verify you have a least one record with non-ascii unicode characters ( i.e. a record that would cause the wide character error ).
2) Create a report that would contain these characters as part of its result.
3) Run this report via runreport.pl with the email option
4) This should cause the wide character error
5) Apply this patch
6) Re-run step 3.
7) This time, you should not get any wide character error.
Comment 4 Julian Maurice 2012-11-22 16:22:34 UTC Comment hidden (obsolete)
Comment 5 Julian Maurice 2012-11-22 16:22:40 UTC Comment hidden (obsolete)
Comment 6 Julian Maurice 2012-11-22 16:25:05 UTC
I followed the test plan, got the wide character error on master and got no errors with the patch. On master the mail is not sent. With the patch the mail is sent and with correct encoding.

I just added a tiny follow-up because runreport.pl wasn't working without it.
Comment 7 Kyle M Hall 2012-12-03 17:22:55 UTC Comment hidden (obsolete)
Comment 8 Paul Poulain 2012-12-11 19:45:44 UTC
QA comment: small patch, passes koha-qa.pl, nothing to add

passed QA
Comment 9 Paul Poulain 2012-12-11 19:46:14 UTC
Created attachment 14011 [details] [review]
Bug 9033 - Wide character error in runreport.pl

Signed-off-by: Julian Maurice <julian.maurice@biblibre.com>
Comment 10 Paul Poulain 2012-12-11 19:46:18 UTC
Created attachment 14012 [details] [review]
Bug 9033: Wide character error in runreport.pl

This patch fix a typo that prevented report to be run

Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>
Signed-off-by: Paul Poulain <paul.poulain@biblibre.com>
Comment 11 Jared Camins-Esakov 2012-12-12 12:29:46 UTC
This patch has been pushed to master.

Note that wide characters will still not display in the e-mail. All these patches do is ensure that the e-mail is sent.
Comment 12 Chris Cormack 2012-12-12 20:11:05 UTC
Pushed to 3.10.x, will be in 3.10.1
Comment 13 Chris Cormack 2013-04-29 21:30:30 UTC
*** Bug 10031 has been marked as a duplicate of this bug. ***