Bug 9063 - When ordering from staged file '# Bibs' is empty
Summary: When ordering from staged file '# Bibs' is empty
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Acquisitions (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Bugs List
QA Contact:
URL:
Keywords:
Depends on: 7180
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-12 21:33 UTC by Katrin Fischer
Modified: 2014-12-07 20:07 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
screenshot (26.32 KB, image/png)
2012-11-12 21:33 UTC, Katrin Fischer
Details
Bug 9063: When ordering from staged file '# Bibs' is empty (3.85 KB, patch)
2014-04-15 14:51 UTC, Jonathan Druart
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 9063: When ordering from staged file '# Bibs' is empty (3.94 KB, patch)
2014-04-17 16:26 UTC, Owen Leonard
Details | Diff | Splinter Review
[PASSED QA] Bug 9063: When ordering from staged file '# Bibs' is empty (4.02 KB, patch)
2014-04-20 15:42 UTC, Katrin Fischer
Details | Diff | Splinter Review
Bug 9063: When ordering from staged file '# Bibs' is empty (3.83 KB, patch)
2014-05-06 07:40 UTC, Jonathan Druart
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Katrin Fischer 2012-11-12 21:33:22 UTC
Created attachment 13409 [details]
screenshot

When ordering from a staged file in acquisitions, the column '# Bibs' in the table is empty for my staged file with 17 records.
Comment 1 Katrin Fischer 2013-09-11 20:40:07 UTC
This is still an issue on current master.
Comment 2 Katrin Fischer 2013-09-11 21:06:58 UTC
I think this problem is caused by renaming the database column from num_biblios to num_records when authority importing/matching was introduced.
Comment 3 Jonathan Druart 2014-04-15 14:51:52 UTC Comment hidden (obsolete)
Comment 4 Jonathan Druart 2014-04-15 14:57:50 UTC
Patch created on top of bug 7180. Feel free to provide a patch based on master.
Comment 5 Owen Leonard 2014-04-17 16:26:16 UTC Comment hidden (obsolete)
Comment 6 Katrin Fischer 2014-04-20 15:42:23 UTC
Created attachment 27326 [details] [review]
[PASSED QA] Bug 9063: When ordering from staged file '# Bibs' is empty

Bug 2060 renames columns num_biblios with num_records in the
import_batches table.

The addorderiso2709 files had not been fixed.

Test plan:
Add an order from a staged file to a basket and verify the "# Bibs"
columns is correctly filled. Before the patch, the column was empty.

Signed-off-by: Owen Leonard <oleonard@myacpl.org>
Signed-off-by: Katrin Fischer <Katrin.Fischer.83@web.de>
Works as described, passes all tests and QA script.
Comment 7 Galen Charlton 2014-04-20 17:22:00 UTC
This patch does not apply.  Since the dependency on 7180 is only textual, if Jonathan wants to rebase this one and put it back to passed QA after doing so, that's fine with me.
Comment 8 Galen Charlton 2014-05-04 22:14:18 UTC
I happened to fix this bug already via one of my follow-ups for bug 7180.  Sorry for forgetting about this one.
Comment 9 Jonathan Druart 2014-05-06 07:40:24 UTC
Created attachment 27957 [details] [review]
Bug 9063: When ordering from staged file '# Bibs' is empty

Bug 2060 renames columns num_biblios with num_records in the
import_batches table.

The addorderiso2709 files had not been fixed.

Test plan:
Add an order from a staged file to a basket and verify the "# Bibs"
columns is correctly filled. Before the patch, the column was empty.

Signed-off-by: Owen Leonard <oleonard@myacpl.org>
Signed-off-by: Katrin Fischer <Katrin.Fischer.83@web.de>
Works as described, passes all tests and QA script.
Comment 10 Jonathan Druart 2014-05-06 07:40:58 UTC
(In reply to Galen Charlton from comment #8)
> I happened to fix this bug already via one of my follow-ups for bug 7180. 
> Sorry for forgetting about this one.

Maybe this patch is still useful since it changes the variable name in the tt file too.
Comment 11 Galen Charlton 2014-05-06 14:38:42 UTC
Pushed to master.  Thanks, Jonathan!