Bug 922 - koha.upgrade produces password error when upgrading MARC tables
Summary: koha.upgrade produces password error when upgrading MARC tables
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Installation and upgrade (command-line installer) (show other bugs)
Version: 2.2.0
Hardware: All All
: P2 normal (vote)
Assignee: Galen Charlton
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-02-04 05:46 UTC by Chris Cormack
Modified: 2012-10-25 00:08 UTC (History)
0 users

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Cormack 2010-05-20 23:36:48 UTC


---- Reported by a.c.li@ieee.org 2005-02-04 17:46:18 ----

When koha.upgrade is run, it tries to upgrade the MARC tables, but gives a
password error because the mysql command does not have a -p parameter passed to it.



---- Additional Comments From mjr@ttllp.co.uk 2005-02-05 07:21:47 ----

This bug is actually because Install::updatedatabase() didn't set the mysql
password it was using (or indeed do anything about mysql passwords).

I have just committed the fix to CVS on the rel_2_2 branch. Thanks for the report.



--- Bug imported by chris@bigballofwax.co.nz 2010-05-20 23:36 UTC  ---

This bug was previously known as _bug_ 922 at http://bugs.koha.org/cgi-bin/bugzilla3/show_bug.cgi?id=922

Actual time not defined. Setting to 0.0
The original reporter of this bug does not have
   an account here. Reassigning to the person who moved
   it here: chris@bigballofwax.co.nz.
   Previous reporter was a.c.li@ieee.org.
The original assignee of this bug does not have
   an account here. Reassigning to the default assignee
   for the component, gmcharlt@gmail.com.
   Previous assignee was mjr@ttllp.co.uk.