Bug 9324 - Reserves cannot be deleted with DEBUG on under Plack
Summary: Reserves cannot be deleted with DEBUG on under Plack
Status: CLOSED WORKSFORME
Alias: None
Product: Koha
Classification: Unclassified
Component: Circulation (show other bugs)
Version: master
Hardware: All All
: P5 - low blocker (vote)
Assignee: Bugs List
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-27 14:37 UTC by Jared Camins-Esakov
Modified: 2019-06-27 09:24 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jared Camins-Esakov 2012-12-27 14:37:45 UTC
When I try to delete a reserve I get the following error:
DBD::mysql::st execute failed: Duplicate entry '10' for key 'PRIMARY' at /home/jcamins/kohaclone/C4/Reserves.pm line 1081.DBD::mysql::st execute failed: Duplicate entry '10' for key 'PRIMARY' at /home/jcamins/kohaclone/C4/Reserves.pm line 1081. at /home/jcamins/kohaclone/reserve/modrequest.pl line 91
Comment 1 Jonathan Druart 2013-04-16 08:32:25 UTC
Hi Jared,
Is it still valid? I cannot reproduce.
I think the error occurs when the reservenumber already exists in old_reserves (so it should occur without Plack too).