Bug 9392 - confirmation does not appear for negative notforloan items issues
Summary: confirmation does not appear for negative notforloan items issues
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Cataloging (show other bugs)
Version: master
Hardware: All All
: P5 - low major (vote)
Target Milestone: ---
Assignee: Fridolin SOMERS
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-01-15 08:22 UTC by Fridolin SOMERS
Modified: 2014-05-26 21:04 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Proposed patch (1.74 KB, patch)
2013-01-15 08:29 UTC, Fridolin SOMERS
Details | Diff | Splinter Review
Bug 9392: confirmation does not appear for negative notforloan items issues (1.81 KB, patch)
2013-01-16 03:11 UTC, Galen Charlton
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 9392: confirmation does not appear for negative notforloan items issues (1.96 KB, patch)
2013-02-08 18:06 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Fridolin SOMERS 2013-01-15 08:22:21 UTC
When checking-out an item marked "not for loan" with a positive value, you get a message to forbid or confirm issue (depending on AllowNotForLoanOverride syspref).
For an item with a negative value (usually during acquisition process), the issue is made without forbid or confirm message.
Comment 1 Fridolin SOMERS 2013-01-15 08:29:45 UTC Comment hidden (obsolete)
Comment 2 Galen Charlton 2013-01-16 03:11:59 UTC Comment hidden (obsolete)
Comment 3 Katrin Fischer 2013-02-08 18:06:22 UTC
Created attachment 15189 [details] [review]
[SIGNED-OFF] Bug 9392: confirmation does not appear for negative notforloan items issues

When checking-out an item marked "not for loan" with a positive value,
you get a message to forbid or confirm issue (depending on
AllowNotForLoanOverride syspref).  For an item with a negative value
(usually during acquisition process), the issue is made without forbid
or confirm message.

This patch simply changes the test notforloan > 0 into notforloan != 0.

Test plan :
- Checkout an item with items.notforloan = 0
=> The item is issued without message
- Checkout an item with items.notforloan > 0
=> A message forbids or asks confirmation to override
- Checkout an item with items.notforloan < 0 (e.g., on order)
=> A message forbids or asks confirmation to override

Signed-off-by: Galen Charlton <gmc@esilibrary.com>
Signed-off-by: Katrin Fischer <Katrin.Fischer.83@web.de>
Checked with AllowNotForLoanOverride on and off.
All tests and QA script pass.
Comment 4 Jared Camins-Esakov 2013-02-09 02:39:27 UTC
This patch has been pushed to master.
Comment 5 Chris Cormack 2013-04-24 08:38:11 UTC
Pushed to 3.10.x will be in 3.10.6