Bug 9591 - Set Library changes after viewing Holds Queue >> reserves item
Summary: Set Library changes after viewing Holds Queue >> reserves item
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Staff Client (show other bugs)
Version: master
Hardware: All All
: P3 blocker (vote)
Assignee: Chris Cormack
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-11 22:17 UTC by Jesse Maseto
Modified: 2019-06-27 09:24 UTC (History)
5 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 9591 : Set Library changes after viewing Holds Queue >> reserves item (2.58 KB, patch)
2013-04-08 09:23 UTC, Chris Cormack
Details | Diff | Splinter Review
Bug 9591 : Set Library changes after viewing Holds Queue >> reserves item (2.64 KB, patch)
2013-04-08 11:03 UTC, Mirko Tietgen
Details | Diff | Splinter Review
[PASSED QA] Bug 9591 : Set Library changes after viewing Holds Queue >> reserves item (2.75 KB, patch)
2013-04-09 21:08 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Maseto 2013-02-11 22:17:40 UTC
Serious bug encountered.

SET LIBRARY automatically changes after viewing Holds Queue report for another library and then clicking on a reserved item on patron record. See attached video.


Video Link: http://media.bywatersolutions.com/Video/set_library_change_bug.mp4


Best Regards,
-Jesse
Comment 1 Owen Leonard 2013-02-12 15:07:16 UTC
Steps to reproduce:

1. Log in to the staff client. Note your logged in library.
2. Navigate to Circulation -> Holds queue.
3. Select a holds queue report for a library other than your own.
4. From the holds queue report page, click the "Check out" tab and
   enter the card number of a patron who has holds.
5. On the circulation page for that patron, click the "Holds" tab.
6. Click one of the titles in the list of holds.

Your logged in branch will now match the library you chose for the holds queue report.

Alternate sequence:

4. From the holds queue report page, click the "Check out" tab and 
   do a non-exact search (search which will return more than one result)
   for a patron who has holds.
5. Choose the correct patron from the list of results.

Your logged in branch will now match the library you chose for the holds queue report.
Comment 2 Liz Rea 2013-03-24 01:46:48 UTC
I verify this as a problem, and it's a big one.
Comment 3 Chris Cormack 2013-04-08 08:58:59 UTC
Working on a fix for this
Comment 4 Chris Cormack 2013-04-08 09:21:02 UTC
Ah ha

 <input autocomplete="off" id="findborrower" name="findborrower" size="40" class="focus" type="text" /> <input id="autocsubmit" type="submit" class="submit" value="Submit" />
                <input name="branch" value="AS" type="hidden" />


And we set
        branch     => $branchlimit,

Which is what we chose to limit on. However in
koha-tmpl/intranet-tmpl/prog/en/includes/patron-search-box.inc

we set
 <input name="branch" value="[% branch %]" type="hidden" />
Comment 5 Chris Cormack 2013-04-08 09:23:23 UTC Comment hidden (obsolete)
Comment 6 Mirko Tietgen 2013-04-08 11:03:19 UTC Comment hidden (obsolete)
Comment 7 Katrin Fischer 2013-04-09 21:08:34 UTC
Created attachment 17322 [details] [review]
[PASSED QA] Bug 9591 : Set Library changes after viewing Holds Queue >> reserves item

To test
1. Log in to the staff client. Note your logged in library.
2. Navigate to Circulation -> Holds queue.
3. Select a holds queue report for a library other than your own.
4. From the holds queue report page, click the "Check out" tab and
   enter the card number of a patron who has holds.
5. On the circulation page for that patron, click the "Holds" tab.
6. Click one of the titles in the list of holds.

Your logged in branch will now match the library you chose for the
holds queue report.

Alternate sequence:

4. From the holds queue report page, click the "Check out" tab and
   do a non-exact search (search which will return more than one result)
   for a patron who has holds.
5. Choose the correct patron from the list of results.

Your logged in branch will now match the library you chose for
the holds queue report.

Apply the patch and repeat, this time it should not change your logged
in branch

Signed-off-by: Mirko Tietgen <mirko@abunchofthings.net>
Weird bug, the patch works for me.

Signed-off-by: Katrin Fischer <Katrin.Fischer.83@web.de>
Good catch. All tests and QA script pass.
Comment 8 Jared Camins-Esakov 2013-04-15 12:39:01 UTC
This patch has been pushed to master and 3.12.x.
Comment 9 Chris Cormack 2013-04-25 06:48:56 UTC
Pushed to 3.10.x and 3.8.x will be in 3.10.6 and 3.8.13