Bug 9804 - Fix name for NORMARC biblio-koha-indexdefs.xml
Summary: Fix name for NORMARC biblio-koha-indexdefs.xml
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: MARC Bibliographic data support (show other bugs)
Version: master
Hardware: All All
: P5 - low trivial (vote)
Target Milestone: ---
Assignee: Magnus Enger
QA Contact: Jonathan Druart
URL:
Whiteboard:
Keywords:
Depends on: 8805
Blocks:
  Show dependency treegraph
 
Reported: 2013-03-13 12:08 UTC by Magnus Enger
Modified: 2014-05-26 21:04 UTC (History)
2 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 9804 - Fix name for NORMARC biblio-koha-indexdefs.xml (1.21 KB, patch)
2013-04-15 18:28 UTC, Magnus Enger
Details | Diff | Splinter Review
Bug 9804 - Fix name for NORMARC biblio-koha-indexdefs.xml (1.29 KB, patch)
2013-04-24 08:09 UTC, Chris Cormack
Details | Diff | Splinter Review
Bug 9804 - Fix name for NORMARC biblio-koha-indexdefs.xml (1.35 KB, patch)
2013-04-24 09:04 UTC, Jonathan Druart
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Magnus Enger 2013-03-13 12:08:21 UTC
Looks like I managed to get a filename wrong in the patch for Bug 8805:

$ cd etc/zebradb/marc_defs
$ ls marc21/biblios/
biblio-koha-indexdefs.xml  biblio-zebra-indexdefs.xsl  record.abs
$ ls normarc/biblios/
biblio-zebra-indexdefs.xml  biblio-zebra-indexdefs.xsl  record.abs

biblio-zebra-indexdefs.xml should be biblio-koha-indexdefs.xml. 

Thanks to Mirko for spotting this!
Comment 1 Magnus Enger 2013-04-15 18:28:14 UTC Comment hidden (obsolete)
Comment 2 Chris Cormack 2013-04-24 08:09:47 UTC Comment hidden (obsolete)
Comment 3 Jonathan Druart 2013-04-24 09:04:34 UTC
QA comment:
After applying the patch, the normarc directory is like 2 others:

ls etc/zebradb/marc_defs/*/biblios
etc/zebradb/marc_defs/marc21/biblios/:
biblio-koha-indexdefs.xml  biblio-zebra-indexdefs.xsl  record.abs

etc/zebradb/marc_defs/normarc/biblios/:
biblio-koha-indexdefs.xml  biblio-zebra-indexdefs.xsl  record.abs

etc/zebradb/marc_defs/unimarc/biblios/:
biblio-koha-indexdefs.xml  biblio-zebra-indexdefs.xsl  record.abs


Marked as Passed QA.
Comment 4 Jonathan Druart 2013-04-24 09:04:48 UTC
Created attachment 17644 [details] [review]
Bug 9804 - Fix name for NORMARC biblio-koha-indexdefs.xml

When i did bug 8805, I gave the biblio-koha-indexdefs.xml file the
wrong name, and called it biblio-zebra-indexdefs.xml. This patch
fixes that.

To reproduce:
- Check that etc/zebradb/marc_defs/normarc/biblios/biblio-zebra-
  indexdefs.xml exists

To test:
- Apply the patch and check that etc/zebradb/marc_defs/normarc/
  biblios/biblio-zebra-indexdefs.xml no longer exists, but that
  etc/zebradb/marc_defs/normarc/biblios/biblio-koha-indexdefs.xml
  does exist.

Signed-off-by: Chris Cormack <chrisc@catalyst.net.nz>
Signed-off-by: Jonathan Druart <jonathan.druart@biblibre.com>
Comment 5 Jared Camins-Esakov 2013-04-24 13:16:39 UTC
This patch has been pushed to master and 3.12.x.
Comment 6 Chris Cormack 2013-04-27 21:36:44 UTC
Pushed to 3.10.x and 3.8.x will be in 3.10.6 and 3.8.13