Bug 9843 - OpenILS/QueryParser.pm not (always) installed when installing from tarball
Summary: OpenILS/QueryParser.pm not (always) installed when installing from tarball
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Installation and upgrade (command-line installer) (show other bugs)
Version: master
Hardware: All All
: P5 - low blocker (vote)
Assignee: Jared Camins-Esakov
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-03-19 12:09 UTC by Jared Camins-Esakov
Modified: 2019-06-27 09:24 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 9843: Include OpenILS directory in Perl lib directory (1.26 KB, patch)
2013-03-19 12:17 UTC, Jared Camins-Esakov
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 9843: Include OpenILS directory in Perl lib directory (1.44 KB, patch)
2013-03-19 15:38 UTC, Tomás Cohen Arazi
Details | Diff | Splinter Review
[PASSED QA] Bug 9843: Include OpenILS directory in Perl lib directory (1.53 KB, patch)
2013-03-19 15:50 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Jared Camins-Esakov 2013-03-19 12:09:19 UTC
When installing from the tarball, the OpenILS/QueryParser.pm file seems to be missed because it is not included in Makefile.PL... sometimes.
Comment 1 Jared Camins-Esakov 2013-03-19 12:17:48 UTC Comment hidden (obsolete)
Comment 2 Magnus Enger 2013-03-19 15:00:31 UTC
We just saw the "Base class package "OpenILS::QueryParser" is empty." error on a package installation too, so this is not just a problem for tarball installations.
Comment 3 Tomás Cohen Arazi 2013-03-19 15:38:45 UTC Comment hidden (obsolete)
Comment 4 Katrin Fischer 2013-03-19 15:50:51 UTC
Created attachment 16416 [details] [review]
[PASSED QA] Bug 9843: Include OpenILS directory in Perl lib directory

When installing from the tarball, the OpenILS/QueryParser.pm file seems
to be missed because it is not included in Makefile.PL... sometimes.

To test:
1) Run Makefile.PL and make.
2) Look in blib/PERL_MODULE_DIR/ and check if the OpenILS directory is
   there.
3) Apply patch.
4) Rerun Makefile.PL and make.
5) Confirm that OpenILS directory is now in blib/PERL_MODULE_DIR/
   regardless of whether or not it was there during step (2).
6) Sign off.

Note: Confirmed that OpenILS directory is correctly installed in the lib dir,
in 'standard' install mode, and also 'single'.

Signed-off-by: Tomas Cohen Arazi <tomascohen@gmail.com>
Signed-off-by: Katrin Fischer <Katrin.Fischer.83@web.de>
Simple fix for a big problem.
Comment 5 Jared Camins-Esakov 2013-03-19 23:31:07 UTC
This patch has been pushed to master.