Bug 9950 - Some holds not showing up in holds queue - even though they are supposed to
Summary: Some holds not showing up in holds queue - even though they are supposed to
Status: RESOLVED DUPLICATE of bug 10311
Alias: None
Product: Koha
Classification: Unclassified
Component: Hold requests (show other bugs)
Version: master
Hardware: All All
: P3 critical (vote)
Assignee: Liz Rea
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-03-29 08:11 UTC by Katrin Fischer
Modified: 2013-07-19 02:55 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Katrin Fischer 2013-03-29 08:11:52 UTC
While testing bug 9922 I saw some strange behaviour that looks to me like another bug.

Testing scenario:
I am at library A.
My record has 1 item, holding library is B, home library is A.
The status of the item is available.

1) Place an item level hold on the item - pickup library is A.
2) Run build_holds_queue.pl
3) Check holds queue in staff for both library A and B
Problem: Hold doesn't show up on either for me, but I think it should show up on the one for library B, so it can be picked up and send to A to fill the hold.

Different settings for AutomaticItemReturn made no difference. 
Same for testing on a branch with bug 9922 applied.
Comment 1 Katrin Fischer 2013-03-29 08:12:40 UTC
Assigning Liz for now for testing :)
Comment 2 Jared Camins-Esakov 2013-03-30 02:28:52 UTC
I think I am seeing this problem with bib-level holds, too. It's weird.
Comment 3 Liz Rea 2013-03-30 09:18:48 UTC
I was able to replicate this with Katrin's plan - with the added complication of patron's home branch was different than the logged in branch.

so, item from A, with holdingbranch B, on hold for a patron from B, logged in as A.

The item shows as having a hold on it, but it does not show on any hold queue. 

Very odd.
Comment 4 Katrin Fischer 2013-03-30 09:23:24 UTC
Maybe there is even more to this, as my patron was from the same branch as I was logged in. Difficult.
Comment 5 Liz Rea 2013-07-19 02:55:02 UTC

*** This bug has been marked as a duplicate of bug 10311 ***