Bug 13122

Summary: Patron holds table no longer display date item went in transit
Product: Koha Reporter: Kyle M Hall <kyle>
Component: Hold requestsAssignee: Kyle M Hall <kyle>
Status: CLOSED FIXED QA Contact: Testopia <testopia>
Severity: normal    
Priority: P5 - low CC: gmcharlt, katrin.fischer, mtj, oleonard, tomascohen
Version: master   
Hardware: All   
OS: All   
Change sponsored?: --- Patch complexity: Trivial patch
Documentation contact: Documentation submission:
Text to go in the release notes:
Version(s) released in:
Bug Depends on: 11703    
Bug Blocks:    
Attachments: Bug 13122 - Patron holds table no longer display date item went in transit
[SIGNED-OFF] Bug 13122 - Patron holds table no longer display date item went in transit
[PASSED QA] Bug 13122 - Patron holds table no longer display date item went in transit

Description Kyle M Hall 2014-10-21 17:25:42 UTC
In Koha 3.14 and earlier, an item on hold and in transit would display the date the item was transferred. This is missing from the new ajax holds table.
Comment 1 Kyle M Hall 2014-10-21 17:29:02 UTC Comment hidden (obsolete)
Comment 2 Owen Leonard 2014-10-22 16:09:00 UTC Comment hidden (obsolete)
Comment 3 Katrin Fischer 2014-10-25 19:04:02 UTC
Created attachment 32740 [details] [review]
[PASSED QA] Bug 13122 - Patron holds table no longer display date item went in transit

In Koha 3.14 and earlier, an item on hold and in transit would display
the date the item was transferred. This is missing from the new ajax
holds table.

Test Plan:
1) Place an item on hold for delivery at a different library
2) Check the item in, confirm the hold and transfer
3) View the patron's holds tab on circulation.pl and/or moremember.pl
4) Note the item is show as in transit, but does not give the "since"
   date
5) Apply this patch
6) Note the in transit status now has a "since <date>"

Signed-off-by: Owen Leonard <oleonard@myacpl.org>
Signed-off-by: Katrin Fischer <Katrin.Fischer.83@web.de>
Small change, works as described.
Comment 4 HB-NEKLS 2014-11-04 18:56:13 UTC
*** Bug 13198 has been marked as a duplicate of this bug. ***
Comment 5 Tomás Cohen Arazi 2014-11-17 00:12:07 UTC
Patch pushed to master.

Thanks Kyle!
Comment 6 Mason James 2015-01-19 14:42:08 UTC
Pushed to 3.16.x, will be in 3.16.7