Bug 21870

Summary: Convert browser alerts to modals: OPAC user summary
Product: Koha Reporter: Owen Leonard <oleonard>
Component: TemplatesAssignee: Owen Leonard <oleonard>
Status: RESOLVED FIXED QA Contact: Testopia <testopia>
Severity: enhancement    
Priority: P5 - low CC: hughr, jose-mario.monteiro-santos, katrin.fischer, martin.renvoize, nick, testopia
Version: master   
Hardware: All   
OS: All   
See Also: https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=25280
Change sponsored?: --- Patch complexity: Small patch
Who signed the patch off: Text to go in the release notes:
Version(s) released in:
Bug Depends on:    
Bug Blocks: 18117, 24341    
Attachments: Bug 21870: Convert browser alerts to modals: OPAC user summary
Bug 21870: Convert browser alerts to modals: OPAC user summary
Bug 21870: Convert browser alerts to modals: OPAC user summary

Description Owen Leonard 2018-11-20 19:35:07 UTC
I propose to update the user summary page in the OPAC so that JavaScript alerts are replaced by modal confirmation dialogs.
Comment 1 Owen Leonard 2018-11-20 20:00:31 UTC Comment hidden (obsolete)
Comment 2 José-Mario Monteiro-Santos 2019-02-15 21:16:16 UTC Comment hidden (obsolete)
Comment 3 Katrin Fischer 2019-02-17 10:50:35 UTC
Just a note for now:

The space in front of strings seems to get lost in translations. Example:

<i class="fa fa-play"></i> Resume all suspended holds</button>
http://translate.koha-community.org/sv/translate/#search=Resume%20all%20suspended%20holds&sfields=source,target&soptions=exact,case&unit=8394611&offset=0

Strings here are the same before and after, so not a reason to fail, but something we might want to keep in mind.
Comment 4 Katrin Fischer 2019-02-17 10:55:20 UTC
Created attachment 85218 [details] [review]
Bug 21870: Convert browser alerts to modals: OPAC user summary

This patch updates the user summary page in the OPAC so that JavaScript
alerts are replaced with Bootstrap modals. This provides us the ability
to more carefully control the content of confirmation dialogs and their
control buttons.

A global function for defining a modal confirmation boxes has been
added, to which one can pass:

 - The modal title
 - Body
 - Text for submit and cancel buttons
 - A callback function to trigger on submit

To test, apply the patch and clear your browser cache if necessary.

 - Log in to the OPAC as a user who has holds and article requests.
 - Test the following interactions, both the confirmation and cancel
   options for each:
     - Cancel a hold
     - Suspend all holds
     - Resume all holds
     - Cancel an article request

Signed-off-by: Jose-Mario Monteiro-Santos <jose-mario.monteiro-santos@inLibro.com>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 5 Nick Clemens 2019-02-26 14:40:36 UTC
Awesome work all!

Pushed to master for 19.05
Comment 6 Martin Renvoize 2019-03-01 11:17:19 UTC
Enhancement will not be backported to 18.11.x series.
Comment 7 Owen Leonard 2020-01-10 12:39:24 UTC
*** Bug 20278 has been marked as a duplicate of this bug. ***