Bug 20278 - Cancel Hold alert in OPAC provides confusing options
Summary: Cancel Hold alert in OPAC provides confusing options
Status: RESOLVED DUPLICATE of bug 21870
Alias: None
Product: Koha
Classification: Unclassified
Component: OPAC (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Owen Leonard
QA Contact: Testopia
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-02-22 23:01 UTC by Hugh Rundle
Modified: 2020-01-10 12:39 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Hugh Rundle 2018-02-22 23:01:44 UTC
When a patron cancels a hold, an alert pops up asking "Are you sure you want to cancel this reservation?" The two options available are "OK" or "Cancel".

OK -> cancels hold
Cancel -> does not cancel hold (cancels the operation)

This is confusing, because clicking 'Cancel' stops the cancellation of the hold!

It would be clearer if the options were "Yes" and "No":

>Are you sure you want to cancel this hold?
>Yes | No

or perhaps:

>Are you sure you want to cancel this hold?
>Yes I'm sure| Undo
Comment 1 Katrin Fischer 2018-02-22 23:04:12 UTC
It should also not say reservation, but hold (if someone goes to fix this).
I think yes / no would work.
Comment 2 Hugh Rundle 2018-02-22 23:14:53 UTC
Sorry Katrin, that's probably the en-NZ language pack changing it from Hold to Reservation in our instance.
Comment 3 Katrin Fischer 2018-02-22 23:26:07 UTC
Makes sense, thx Hugh!
Comment 4 Liz Rea 2018-02-23 00:45:21 UTC
There ought to be an omnibus for "eliminating ambiguous ok/cancel buttons," this happens across Koha and it needs to be fixed for UX reasons.
Comment 5 Hugh Rundle 2018-02-23 01:33:14 UTC
I'd be very happy to work on that omnibus project Liz, it sounds reasonably straightforward. Maybe we can talk in our other channel about how to get set up and understand the process to be able to push patches.
Comment 6 Liz Rea 2018-02-23 01:47:12 UTC
👍
Comment 7 Owen Leonard 2018-11-21 18:54:06 UTC
I think this may be fixed by Bug 21870.
Comment 8 Owen Leonard 2020-01-10 12:39:24 UTC
I'm marking this as a duplicate of Bug 21870. If anyone objects please re-open and provide more details.

*** This bug has been marked as a duplicate of bug 21870 ***