Bug 25619

Summary: Updating an expiration date for a waiting hold won't save
Product: Koha Reporter: Donna <bwsdonna>
Component: CirculationAssignee: Kyle M Hall <kyle>
Status: RESOLVED FIXED QA Contact: Testopia <testopia>
Severity: minor    
Priority: P5 - low CC: aholt, andrew, barbara.johnson, eveal, fridolin.somers, george, gmcharlt, jgaine, katrin.fischer, kyle.m.hall, kyle, lisetteslatah, lucas, nohora, rcoert, rmcompton, sbcornell, tech, techservspec, victor
Version: master   
Hardware: All   
OS: All   
See Also: https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=25631
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=26429
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=26656
Change sponsored?: --- Patch complexity: Small patch
Text to go in the release notes:
Version(s) released in:
21.11.00,21.05.04,20.11.10
Attachments: Bug 25619: Add ability to adjust expiration date for waiting holds
Bug 25619: Add ability to adjust expiration date for waiting holds
Bug 25619: Unit Tests
Bug 25619: Add ability to adjust expiration date for waiting holds
Bug 25619: Unit Tests
Bug 25619: (QA follow-up) Fix subtest description
Bug 25619: Add ability to adjust expiration date for waiting holds
Bug 25619: Unit Tests
Bug 25619: (QA follow-up) Fix subtest description
Bug 25619: Adjust POD
Bug 25619: Add ability to adjust expiration date for waiting holds
Bug 25619: Unit Tests
Bug 25619: (QA follow-up) Fix subtest description
Bug 25619: Adjust POD
Bug 25619: Adjust POD and move date check before logging

Description Donna 2020-05-28 15:51:35 UTC
There are times when an item that is waiting for pickup needs to have the expiration date extended. This would give staff the ability to modify one by one, as needed, the reserves.expirationdate for a given item awaiting pickup.

If possible, this should be a separate permission.
Comment 1 George Williams (NEKLS) 2020-05-29 14:39:12 UTC
Great idea.
Comment 2 Andrew Fuerste-Henry 2020-08-07 13:47:47 UTC
I also support this idea.
If it is some reason decided that we should not allow this, then we should update request.pl to make it clear that date can't be changed. As it is now, it lets one pick a new expiration date on a waiting hold but when you click Update it doesn't save.
Comment 3 Rebecca Coert 2020-08-07 20:25:51 UTC
I support this idea as well.  It's been a main request from our front-line staff that are assisting our patrons with contact-less hold pickup service during COVID.  The ability to add a few days would aid in providing excellent customer service and patron goodwill.
Comment 4 Jeff Gaines 2020-08-07 20:37:41 UTC
I agree with above, and it would nice to add some reporting on this. If we find we are adjusting the expiration dates too much, we can change our default settings.
Comment 5 Rhiana 2020-09-01 16:01:09 UTC
This is a great idea and would greatly benefit our patrons - especially now given the pandemic but I also see plenty of need after the fact. It could be used to support a number of programs and/or services.
Comment 6 Katrin Fischer 2020-10-11 11:15:49 UTC
The expiration date appears as editable on master now - but changes don't save. I have filed bug 26656 for this mentioning this bug.
Comment 7 Ed Veal 2021-02-04 22:57:50 UTC
This is an issue for us as well, we allow extra time for patron's to pick up ILLs so we would like to be able to edit the field as appropriate. 

Ed
Comment 8 Sarah Cornell 2021-02-10 14:29:16 UTC
This is a fantastic idea.  Like Ed, we allow patrons to pick up ILLs for as long as their ILL item is in the building, which is 30+ days. In non-pandemic times, regular holds are hold available for 4 days. Individual adjustment of time on holdshelf would save us a lot of fiddling.
Comment 9 Nell 2021-03-25 11:42:51 UTC
I support this idea also. As above, it's been a main request from our front-line staff that are assisting our patrons with contact-less hold pickup service during COVID.  The ability to add a few days would aid in providing excellent customer service and patron goodwill.

It would also be useful to have this ability once we return to 'normal' hold processes.
Comment 10 Eric Swenson 2021-04-13 15:57:06 UTC
I also would like to add my support to this request. All the complications with holds pickup in the time of COVID have made this something that would be very helpful!
Comment 11 Barbara Johnson 2021-04-13 17:37:05 UTC
Great suggestion.  We really need this functionality at our library.  As it is now, staff has to use a clunky workaround which is not efficient.
Comment 12 Kyle M Hall 2021-07-16 17:54:05 UTC
Created attachment 122922 [details] [review]
Bug 25619: Add ability to adjust expiration date for waiting holds

There are times when an item that is waiting for pickup needs to have the expiration date extended. This would give staff the ability to modify one by one, as needed, the reserves.expirationdate for a given item awaiting pickup.

Test Plan:
1) Place a hold, trap an item for it such that is is waiting
2) Attempt to update the expiration date
3) Note the new date is not saved
4) Apply this patch, restart all the things!
5) Attempt to update the expiration date
6) The new date should be saved!
Comment 13 Kyle M Hall 2021-07-16 18:26:58 UTC
Created attachment 122923 [details] [review]
Bug 25619: Add ability to adjust expiration date for waiting holds

There are times when an item that is waiting for pickup needs to have the expiration date extended. This would give staff the ability to modify one by one, as needed, the reserves.expirationdate for a given item awaiting pickup.

Test Plan:
1) Place a hold, trap an item for it such that is is waiting
2) Attempt to update the expiration date
3) Note the new date is not saved
4) Apply this patch, restart all the things!
5) Attempt to update the expiration date
6) The new date should be saved!
Comment 14 Kyle M Hall 2021-07-16 18:27:10 UTC
Created attachment 122924 [details] [review]
Bug 25619: Unit Tests
Comment 15 sandboxes@biblibre.com 2021-07-16 21:34:01 UTC
Created attachment 122929 [details] [review]
Bug 25619: Add ability to adjust expiration date for waiting holds

There are times when an item that is waiting for pickup needs to have the expiration date extended. This would give staff the ability to modify one by one, as needed, the reserves.expirationdate for a given item awaiting pickup.

Test Plan:
1) Place a hold, trap an item for it such that is is waiting
2) Attempt to update the expiration date
3) Note the new date is not saved
4) Apply this patch, restart all the things!
5) Attempt to update the expiration date
6) The new date should be saved!

Signed-off-by: Abbey Holt <aholt@dubuque.lib.ia.us>
Comment 16 sandboxes@biblibre.com 2021-07-16 21:34:06 UTC
Created attachment 122930 [details] [review]
Bug 25619: Unit Tests

Signed-off-by: Abbey Holt <aholt@dubuque.lib.ia.us>
Comment 17 Kyle M Hall 2021-07-22 10:24:31 UTC
Created attachment 123043 [details] [review]
Bug 25619: (QA follow-up) Fix subtest description
Comment 18 Katrin Fischer 2021-08-10 13:52:19 UTC
*** Bug 26656 has been marked as a duplicate of this bug. ***
Comment 19 Katrin Fischer 2021-08-10 13:59:55 UTC
Created attachment 123693 [details] [review]
Bug 25619: Add ability to adjust expiration date for waiting holds

There are times when an item that is waiting for pickup needs to have the expiration date extended. This would give staff the ability to modify one by one, as needed, the reserves.expirationdate for a given item awaiting pickup.

Test Plan:
1) Place a hold, trap an item for it such that is is waiting
2) Attempt to update the expiration date
3) Note the new date is not saved
4) Apply this patch, restart all the things!
5) Attempt to update the expiration date
6) The new date should be saved!

Signed-off-by: Abbey Holt <aholt@dubuque.lib.ia.us>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 20 Katrin Fischer 2021-08-10 14:00:01 UTC
Created attachment 123694 [details] [review]
Bug 25619: Unit Tests

Signed-off-by: Abbey Holt <aholt@dubuque.lib.ia.us>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 21 Katrin Fischer 2021-08-10 14:00:07 UTC
Created attachment 123695 [details] [review]
Bug 25619: (QA follow-up) Fix subtest description

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 22 Jonathan Druart 2021-08-11 11:18:25 UTC
Created attachment 123779 [details] [review]
Bug 25619: Adjust POD
Comment 23 Nick Clemens 2021-08-26 19:09:31 UTC
Created attachment 124120 [details] [review]
Bug 25619: Add ability to adjust expiration date for waiting holds

There are times when an item that is waiting for pickup needs to have the expiration date extended. This would give staff the ability to modify one by one, as needed, the reserves.expirationdate for a given item awaiting pickup.

Test Plan:
1) Place a hold, trap an item for it such that is is waiting
2) Attempt to update the expiration date
3) Note the new date is not saved
4) Apply this patch, restart all the things!
5) Attempt to update the expiration date
6) The new date should be saved!

Signed-off-by: Abbey Holt <aholt@dubuque.lib.ia.us>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>

Signed-off-by: Nick Clemens <nick@bywatersolutions.com>
Comment 24 Nick Clemens 2021-08-26 19:09:36 UTC
Created attachment 124121 [details] [review]
Bug 25619: Unit Tests

Signed-off-by: Abbey Holt <aholt@dubuque.lib.ia.us>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>

Signed-off-by: Nick Clemens <nick@bywatersolutions.com>
Comment 25 Nick Clemens 2021-08-26 19:09:40 UTC
Created attachment 124122 [details] [review]
Bug 25619: (QA follow-up) Fix subtest description

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>

Signed-off-by: Nick Clemens <nick@bywatersolutions.com>
Comment 26 Nick Clemens 2021-08-26 19:09:45 UTC
Created attachment 124123 [details] [review]
Bug 25619: Adjust POD

Signed-off-by: Nick Clemens <nick@bywatersolutions.com>
Comment 27 Nick Clemens 2021-08-26 19:09:51 UTC
Created attachment 124124 [details] [review]
Bug 25619: Adjust POD and move date check before logging

Potentially we could have logged a change when no date was passed.

This patch moves the test before logging and updates POD

Signed-off-by: Nick Clemens <nick@bywatersolutions.com>
Comment 28 Jonathan Druart 2021-08-27 13:36:52 UTC
Pushed to master for 21.11, thanks to everybody involved!
Comment 29 Kyle M Hall 2021-09-03 14:01:58 UTC
Pushed to 21.05.x for 21.05.04
Comment 30 Fridolin Somers 2021-09-08 20:27:01 UTC
Unit test shows a warning :

t/db_dependent/Holds.t .. 71/73 Use of uninitialized value $_ in concatenation (.) or string at t/db_dependent/Holds.t line 1432.

Strange $_ var out of nowhere ?
Comment 31 Fridolin Somers 2021-09-08 20:27:28 UTC
Pushed to 20.11.x for 20.11.10
Comment 32 Victor Grousset/tuxayo 2021-09-20 11:34:15 UTC
Not backported to oldoldstable (20.05.x). Feel free to ask if it's needed.