Bug 8411

Summary: merging allows for creation of duplicate fields where not allowed
Product: Koha Reporter: Nicole C. Engard <nengard>
Component: CatalogingAssignee: Galen Charlton <gmcharlt>
Status: CLOSED FIXED QA Contact:
Severity: major    
Priority: P5 - low CC: jonathan.druart+koha, katrin.fischer, m.de.rooy
Version: master   
Hardware: All   
OS: All   
See Also: http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=8064
Change sponsored?: --- Patch complexity: ---
Documentation contact: Documentation submission:
Text to go in the release notes:
Version(s) released in:

Description Nicole C. Engard 2012-07-10 19:37:34 UTC
See here : http://manual.koha-community.org/3.8/en/stafflists.html#mergebibrecs the merging bib records tool used to stop you from adding fields if they were not repeatable, but I was just able to add the two 001 fields to my destination record but the framework says it's not repeatable.  

For the 999 it didn't add it but didn't give me an error either.
Comment 1 Jonathan Druart 2015-07-13 13:52:54 UTC
I did not test, but I think bug 8064 fixes this issue.
Comment 2 Katrin Fischer 2019-04-28 13:54:10 UTC
I believe this is fixed. When checking the checkbox to get the second 001 or 245$a:

The field is non-repeatable and already exists in the destination record. Therefore, you cannot add it.
Comment 3 Katrin Fischer 2019-04-28 18:24:10 UTC
*** Bug 10551 has been marked as a duplicate of this bug. ***