Bug 11573

Summary: Fine descriptions related to Rentals are untranslatable
Product: Koha Reporter: Marjorie Barry-Vila <marjorie.barry-vila>
Component: Fines and feesAssignee: Martin Renvoize <martin.renvoize>
Status: RESOLVED FIXED QA Contact: Testopia <testopia>
Severity: normal    
Priority: P5 - low CC: arthur.bousquet, chris, fridolin.somers, gmcharlt, hayleymapley, jonathan.druart, katrin.fischer, kyle.m.hall, martin.renvoize, matted-34813, mtompset, nick, patrick.robitaille, veron, wizzyrea
Version: master   
Hardware: All   
OS: All   
See Also: https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=21678
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=12166
Change sponsored?: --- Patch complexity: Small patch
Who signed the patch off: Text to go in the release notes:
Version(s) released in:
19.11.00
Bug Depends on: 19919    
Bug Blocks: 6759    
Attachments: item_description_charges
Bug 11573 - Make fine display more consistent for rentals
Bug 11573 - removing title double ups on boraccount.tt
Followup Bug-11573-display-derived-account-fines-tab-description
[SIGNED OFF] Bug 11573 - Make fine display more consistent for rentals
[SIGNED OFF] Bug 11573 - removing title double ups on boraccount.tt
Bug 11573: Follow-up: Include changes in OPAC templates
Bug 11573 - Make fine display more consistent for rentals
Bug 11573 - removing title double ups on boraccount.tt
Bug 11573: Follow-up: Include changes in OPAC templates
Bug 11573 - Make fine display more consistent for rentals
Bug 11573 - removing title double ups on boraccount.tt
Bug 11573: Follow-up: Include changes in OPAC templates
Bug 11573: Follow-up: Include changes in OPAC templates
[SIGNED-OFF] Bug 11573 - Make fine display more consistent for rentals
[SIGNED-OFF] Bug 11573 - Make fine display more consistent for rentals
[SIGNED-OFF] Bug 11573 - removing title double ups on boraccount.tt
[SIGNED-OFF] Bug 11573: Follow-up: Include changes in OPAC templates
Bug 11573: Make rental accountlines translatable
Bug 11573: Make rental accountlines translatable
Bug 11573: Update existing accountlines for 'Rent'
Bug 11573: Update of unit tests
Bug 11573: Make rental accountlines translatable
Bug 11573: Update existing accountlines for 'Rent'
Bug 11573: Update of unit tests
Bug 11573: (follow-up) Correction to accountype search on opac-user.pl
Bug 11573: Make rental accountlines translatable
Bug 11573: Update existing accountlines for 'Rent'
Bug 11573: Update of unit tests
Bug 11573: (follow-up) Correction to accountype search on opac-user.pl
Bug 11573: Make rental accountlines translatable
Bug 11573: Update existing accountlines for 'Rent'
Bug 11573: Update of unit tests
Bug 11573: (follow-up) Correction to accountype search on opac-user.pl
Update release notes for the 19.05.00 release
Update release notes for the 19.05.00 release
Bug 11573: Make rental accountlines translatable
Bug 11573: Update existing accountlines for 'Rent'
Bug 11573: Update of unit tests
Bug 11573: (follow-up) Correction to accountype search on opac-user.pl
Bug 11573: Make rental accountlines translatable
Bug 11573: Update existing accountlines for 'Rent'
Bug 11573: Update of unit tests
Bug 11573: (follow-up) Correction to accountype search on opac-user.pl
Bug 11573: (follow-up) Handle daily rental in db update
Bug 11573: Make rental accountlines translatable
Bug 11573: Update existing accountlines for 'Rent'
Bug 11573: Update of unit tests
Bug 11573: (follow-up) Correction to accountype search on opac-user.pl
Bug 11573: (follow-up) Handle daily rental in db update
Bug 11573: (QA follow-up) Correct spelling typo

Description Marjorie Barry-Vila 2014-01-16 21:30:18 UTC
Created attachment 24473 [details]
item_description_charges

Hi,

In description of charges on an account, a title of a item is written twice (see capture).
Why?

It would be nice if each instance can set the information on Description of charges. For example, if we want to see call number, barcode, etc.

Thanks,

Marjorie
Comment 1 Liz Rea 2014-01-17 08:04:58 UTC
Hi Marjorie,

Thanks for your report. As a general note, when taking a screenshot it's useful for us to see the whole page, including the URL, so we know exactly what page you are looking at.

Cheers,
Liz
Comment 2 Liz Rea 2014-01-17 09:37:38 UTC Comment hidden (obsolete)
Comment 3 Liz Rea 2014-01-17 09:37:51 UTC Comment hidden (obsolete)
Comment 4 Chris Cormack 2014-02-16 04:48:05 UTC
I can't sign off on this, can someone outside of catalyst take a look please
Comment 5 wajasu 2014-02-26 22:56:25 UTC
I generated a rental, and renewal of rental item:
26/02/2014 	Rent, Renewal of Rental Item A heart for God / 1111  View item A heart for God / 		5.00 	5.00 	Print
26/02/2014 	Rent, Rental  View item A heart for God / 		5.00 	5.00 	Print

then applied patches
26/02/2014 	Rent, Renewal of Rental Item A heart for God / 1111  View item  		5.00 	5.00 	Print
26/02/2014 	Rent, A heart for God / 1111  View item  		5.00 	5.00 	Print


Overall this patch seems to make the  Patron Fines Account tab more succinct not showing the duplicate title info. It also appends the barcode number for Rentals and renewal entries.

---But

The Pay Fines tab now has title duplicated in parenthesis, which might need to be taken off, now that its part of the accountlines description from this patch.

  koha-tmpl/intranet-tmpl/prog/en/modules/members/pay.tt
could have line 129 removed,
       [% IF line.title %]([% line.title |html_entity %])[% END %] 
but we need to preserve historical context for the historically generated accountline that may not have a title.

We could:
a) test to see if the title is already in the description and if not, append it.
(but what if the title changes in the item record? does that matter)
b) perform a one time database update, appending the title to the accountline description if its not already in there - gotta think about this. -- BIG UPDATE for some follks.
Comment 6 wajasu 2014-02-28 02:22:13 UTC Comment hidden (obsolete)
Comment 7 wajasu 2014-02-28 02:25:17 UTC
Account tab lines look like:
Rental Renewal ( A heart for God /  1111 )  View item  		

Pay Fine tab lines look like:
Rental Renewal ( A heart for God /  1111 )

With the followup patch.  See patch for accounttype transformations
Comment 8 wajasu 2014-02-28 07:27:38 UTC
I think my followup partially fixed bug 11301 (barcode display, but not assession number).
It also should have fixed bug 2696, since I show the (Title / barcode) when an item exists for a payment/accountline.

If folks want to keep adding fields, we could add a View Item link to the Pay fines tab, just like the Account tab has.
Comment 9 Katrin Fischer 2014-04-30 05:58:40 UTC
'new feature' is not right for the attached patches - looks more like something between a bug fix and an enh. hm.
Comment 10 Katrin Fischer 2014-04-30 19:38:59 UTC
The third patch on this patch set does not apply, and also has some problems. - capitalization, not including OPAC templates. I'd suggest we split this up into some smaller steps. Starting with fixing the rentals.
Comment 11 Katrin Fischer 2014-04-30 20:43:18 UTC
Comment on attachment 25715 [details] [review]
Followup Bug-11573-display-derived-account-fines-tab-description

Obsoleting here - moving it to another bug later.
Comment 12 Katrin Fischer 2014-04-30 22:28:33 UTC Comment hidden (obsolete)
Comment 13 Katrin Fischer 2014-04-30 22:28:36 UTC Comment hidden (obsolete)
Comment 14 Katrin Fischer 2014-04-30 22:28:39 UTC Comment hidden (obsolete)
Comment 15 Katrin Fischer 2014-04-30 22:49:35 UTC
Wajasu, I am not sure about your patch, as there are some problems with, would you mind going step by step? We could also check then that the other codes are still in use and have test plans for each. I haven't moved your patch to another bug yet, but happy to do so if you want me to.
Comment 16 Owen Leonard 2014-10-23 16:25:09 UTC
What is the status of this bug? It is just waiting for a signoff on attachment 27824 [details] [review]?
Comment 17 wajasu 2014-10-24 19:01:57 UTC
I had originally went to sign off after reading comment4.  Then I took a shot at the fix.  Comment6 was my attempt to fix it.  I also saw afterward that accountlines was being worked on.  The fix I did was an attempt to consistently display the descriptions that I could find through the system codebase at that time without resorting to trying to change user data.  At least the obsolete patch documented my attempt to centralize a mapping of descriptions for the set of codes I researched.   It was to lay a groundwork for future accountlines rewrite or such to know what would need to be handled in schema design.  I can barely remember if a messy part was the storage of a code in the description field, which required a string scan. Well it looks like a newer effort is pending signoff.
Comment 18 Nick Clemens 2015-02-06 03:58:22 UTC
Needs a rebase, and I am unclear on whether to apply just the last three patches, or all 5?  I hit conflicts in both scenarios
Comment 19 M. Tompsett 2016-01-25 02:50:57 UTC Comment hidden (obsolete)
Comment 20 M. Tompsett 2016-01-25 02:51:06 UTC Comment hidden (obsolete)
Comment 21 M. Tompsett 2016-01-25 02:51:30 UTC Comment hidden (obsolete)
Comment 22 M. Tompsett 2016-01-25 04:32:04 UTC Comment hidden (obsolete)
Comment 23 M. Tompsett 2016-01-25 04:32:11 UTC Comment hidden (obsolete)
Comment 24 M. Tompsett 2016-01-25 04:32:20 UTC Comment hidden (obsolete)
Comment 25 M. Tompsett 2016-01-25 04:42:23 UTC Comment hidden (obsolete)
Comment 26 M. Tompsett 2016-01-25 04:45:51 UTC
It now applies, and should be identical to before.
Admittedly, the commit messages probably should be tweaked to reflect minor changes, but that would make comparing patches more difficult. :)
Comment 27 Aleisha Amohia 2016-01-26 01:20:34 UTC Comment hidden (obsolete)
Comment 28 Aleisha Amohia 2016-01-26 01:21:05 UTC
Created attachment 47289 [details] [review]
[SIGNED-OFF] Bug 11573 - Make fine display more consistent for rentals

To test:

1. Set up an item type with a rental charge
2. issue an item from that item type
3. Check fines - the rental charge does not show the title of the issued item
4. Renew that item, the renewal charge does show the title of the issued item
5. Apply the patch
6. Repeat steps 1-4, both should show the title of the issued item in the description.

This change is proposed in order to get rid of some double ups in the title on the boraccount template.

Signed-off-by: Katrin Fischer <Katrin.Fischer.83@web.de>

Tested with rental lines created before and after applying the patch.
After applying the patch it's better, but old lines will still look ok.

There is still a double up on the title on the 'pay' tab, as we get the
title from the itemnumber and also display the description. I think
getting all the information from the itemnumber for display would be
a bit nicer in the future. Butthis is an improvement.

Passes tests and QA script.
Comment 29 Aleisha Amohia 2016-01-26 01:21:16 UTC
Created attachment 47290 [details] [review]
[SIGNED-OFF] Bug 11573 - removing title double ups on boraccount.tt

To test:
1. Create a bunch of fines (or view your existing fines data) - it should have lost entries, rentals, rental renewals, and regular fines and fine updates.
2. View the fines tab for your borrower with fines
3. without the patch, it will look like the submitted screenshot
4. with the patch, there will be few, if any, doubleups of title

This patch may be incomplete - there may be cases that still need work. I'm happy to do followups.
Rental fees and rental renewals will not look wholly consistent without the other attached patch, but this one does not require it.

Signed-off-by: Katrin Fischer <Katrin.Fischer.83@web.de>
Comment 30 Aleisha Amohia 2016-01-26 01:21:30 UTC
Created attachment 47291 [details] [review]
[SIGNED-OFF] Bug 11573: Follow-up: Include changes in OPAC templates

Patch adds changes from earlier patches to OPAC prog and
bootstrap templates.

Patch radds a description for FU - Accrued fine.

Removes a stray space before the comma, using some TT magic.

To test:
- Test like the other patch, display in OPAC prog, OPAC bootstrap,
  Staff Pay fines tab and Staff Accounts tab should be the same.
- No ' , ' should be seen.
- FU fines should now display a description.

Signed-off-by: Aleisha <aleishaamohia@hotmail.com>
Comment 31 Jonathan Druart 2016-01-27 12:10:45 UTC
Comment on attachment 47289 [details] [review]
[SIGNED-OFF] Bug 11573 - Make fine display more consistent for rentals

Review of attachment 47289 [details] [review]:
-----------------------------------------------------------------

I am not sure I have understood what is expected.
I get:
 	
Without the patch:
	Rental, Rental (my_title_99) 		Rent 	0 	0 	1.00 	1.00
	
	Rental, Renewal of Rental Item my_title_99 my_barcode_992 (my_title_99) 		Rent 	0 	0 	1.00 	1.00
With the patch:
	Rental, my_title_99 my_barcode_992 (my_title_99) 		Rent 	0 	0 	1.00 	1.00
	
	Rental, Renewal of Rental Item my_title_99 my_barcode_992 (my_title_99)

I still get the title displayed twice.

::: C4/Circulation.pm
@@ +3189,4 @@
>      my $dbh = C4::Context->dbh;
>      my $nextaccntno = getnextacctno( $borrowernumber );
>      my $manager_id = 0;
> +    my $item = GetBiblioFromItemNumber($itemnumber);

GetBiblioFromItemNumber returns a biblio, not an item.
Comment 32 Martin Renvoize 2019-04-09 09:26:38 UTC

*** This bug has been marked as a duplicate of bug 21953 ***
Comment 33 Martin Renvoize 2019-04-09 09:27:23 UTC
This one hasn't received any love for a while and there are new reports (and patches) in it's place.. I'm going to look at the more recent efforts and see fi those resolve it.

Marking as duplicate.
Comment 34 Katrin Fischer 2019-04-09 22:19:45 UTC
Not sure if this is a duplicate to bug 21953 - Rental vs. Lost. 

It looks like Rental might still have issues:

C4/Circulation.pm

if ( $charge > 0 ) {
my $description = "Rental";
AddIssuingCharge( $issue, $charge, $description );
}

if ( $accumulate_charge > 0 ) {
my $type_desc = "Renewal of Daily Rental Item " . $biblio->title . " $item_unblessed->{'barcode'}";
AddIssuingCharge( $issue, $accumulate_charge, $type_desc )
}

And same without Daily.
Comment 35 Martin Renvoize 2019-04-23 17:10:53 UTC
Created attachment 88549 [details] [review]
Bug 11573: Make rental accountlines translatable

To test:

1. Set up an item type with a rental charge
2. Issue an item with that item type
3. Check fines - the rental charge does not show the title of the issued
item
4. Renew that item, the renewal charge does show the title of the issued
item
5. Apply the patch
6. Repeat steps 1-4, both should show the title of the issued item in
the description.
7. Repeat steps 1-6 for an item type with a daily rental charge

Signed-off-by: Martin Renvoize <martin.renvoize@ptfs-europe.com>
Comment 36 Martin Renvoize 2019-04-23 17:13:02 UTC
OK, I've re-written this from scratch as a fair bit has changed under the hood since the last time it was submitted.

Still to do:
1) DB update to update old accountlines to reflect the new accounttypes
2) Update any tests to reflect the description output

Submitting just this patch to get some initial feedback
Comment 37 Martin Renvoize 2019-04-24 09:38:55 UTC
Created attachment 88600 [details] [review]
Bug 11573: Make rental accountlines translatable

To test:

1. Set up an item type with a rental charge
2. Issue an item with that item type
3. Check fines - the rental charge does not show the title of the issued
item
4. Renew that item, the renewal charge does show the title of the issued
item
5. Apply the patch
6. Repeat steps 1-4, both should show the title of the issued item in
the description.
7. Repeat steps 1-6 for an item type with a daily rental charge

Signed-off-by: Martin Renvoize <martin.renvoize@ptfs-europe.com>
Comment 38 Martin Renvoize 2019-04-24 09:38:59 UTC
Created attachment 88601 [details] [review]
Bug 11573: Update existing accountlines for 'Rent'

Signed-off-by: Martin Renvoize <martin.renvoize@ptfs-europe.com>
Comment 39 Martin Renvoize 2019-04-24 09:39:03 UTC
Created attachment 88602 [details] [review]
Bug 11573: Update of unit tests

This patch updates the unit tests to reflect the changes to the core
routines.  The relevant changes are the removal of a hard coded
'description' and the splitting up of the 'Rent' accounttype into
'RENT', 'RENT_RENEW', 'RENT_DAILY' and 'RENT_DAILY_RENEW'.

Signed-off-by: Martin Renvoize <martin.renvoize@ptfs-europe.com>
Comment 40 Martin Renvoize 2019-04-24 09:39:49 UTC
All ready to go now :)
Comment 41 Martin Renvoize 2019-04-24 09:46:22 UTC
Created attachment 88603 [details] [review]
Bug 11573: Make rental accountlines translatable

To test:

1. Set up an item type with a rental charge
2. Issue an item with that item type
3. Check fines, a charge of type 'Rent' will be visible with a
description of 'Rental'.
4. Renew the item
5. Check fines, a charge of type 'Rent' will be visible with a
description of 'Renewal of Rental Item TITLE BARCODE' where TITLE and
BARCODE are the items title and barcode.
5. Apply the patch
6. Repeat steps 1-4, charge descriptions should now be empty and charge
types should display 'Rental fee' and 'Renewal of rental item'.
7. Repeat steps 1-6 for an item type with a daily rental charge and note
the charge types are now 'Daily rental fee' and 'Renewal of daily rental
item'

Signed-off-by: Martin Renvoize <martin.renvoize@ptfs-europe.com>
Comment 42 Martin Renvoize 2019-04-24 09:46:26 UTC
Created attachment 88604 [details] [review]
Bug 11573: Update existing accountlines for 'Rent'

Signed-off-by: Martin Renvoize <martin.renvoize@ptfs-europe.com>
Comment 43 Martin Renvoize 2019-04-24 09:46:29 UTC
Created attachment 88605 [details] [review]
Bug 11573: Update of unit tests

This patch updates the unit tests to reflect the changes to the core
routines.  The relevant changes are the removal of a hard coded
'description' and the splitting up of the 'Rent' accounttype into
'RENT', 'RENT_RENEW', 'RENT_DAILY' and 'RENT_DAILY_RENEW'.

Signed-off-by: Martin Renvoize <martin.renvoize@ptfs-europe.com>
Comment 44 Martin Renvoize 2019-04-24 09:52:54 UTC
Created attachment 88606 [details] [review]
Bug 11573: (follow-up) Correction to accountype search on opac-user.pl

With the update of accountype from 'Rent' to four distinct accountypes
we need to update the search here to catch all four types of charge.

Signed-off-by: Martin Renvoize <martin.renvoize@ptfs-europe.com>
Comment 45 Martin Renvoize 2019-04-25 09:15:18 UTC
Created attachment 88726 [details] [review]
Bug 11573: Make rental accountlines translatable

To test:

1. Set up an item type with a rental charge
2. Issue an item with that item type
3. Check fines, a charge of type 'Rent' will be visible with a
description of 'Rental'.
4. Renew the item
5. Check fines, a charge of type 'Rent' will be visible with a
description of 'Renewal of Rental Item TITLE BARCODE' where TITLE and
BARCODE are the items title and barcode.
5. Apply the patch
6. Repeat steps 1-4, charge descriptions should now be empty and charge
types should display 'Rental fee' and 'Renewal of rental item'.
7. Repeat steps 1-6 for an item type with a daily rental charge and note
the charge types are now 'Daily rental fee' and 'Renewal of daily rental
item'

Signed-off-by: Martin Renvoize <martin.renvoize@ptfs-europe.com>
Comment 46 Martin Renvoize 2019-04-25 09:15:22 UTC
Created attachment 88727 [details] [review]
Bug 11573: Update existing accountlines for 'Rent'

Signed-off-by: Martin Renvoize <martin.renvoize@ptfs-europe.com>
Comment 47 Martin Renvoize 2019-04-25 09:15:26 UTC
Created attachment 88728 [details] [review]
Bug 11573: Update of unit tests

This patch updates the unit tests to reflect the changes to the core
routines.  The relevant changes are the removal of a hard coded
'description' and the splitting up of the 'Rent' accounttype into
'RENT', 'RENT_RENEW', 'RENT_DAILY' and 'RENT_DAILY_RENEW'.

Signed-off-by: Martin Renvoize <martin.renvoize@ptfs-europe.com>
Comment 48 Martin Renvoize 2019-04-25 09:15:30 UTC
Created attachment 88729 [details] [review]
Bug 11573: (follow-up) Correction to accountype search on opac-user.pl

With the update of accountype from 'Rent' to four distinct accountypes
we need to update the search here to catch all four types of charge.

Signed-off-by: Martin Renvoize <martin.renvoize@ptfs-europe.com>
Comment 49 Hayley Mapley 2019-05-13 03:48:37 UTC
Hi Martin,

I was testing these patches and followed the test plan. Everything went as expected, except for step 6.

6. Repeat steps 1-4, charge descriptions should now be empty and charge
types should display 'Rental fee' and 'Renewal of rental item'.

The Description column in the table is not empty, but instead contains the title in brackets: (TITLE). Is this the expected behaviour? If so, I will sign it off
Comment 50 Kyle M Hall 2019-05-31 11:22:52 UTC
Created attachment 90231 [details] [review]
Bug 11573: Make rental accountlines translatable

To test:

1. Set up an item type with a rental charge
2. Issue an item with that item type
3. Check fines, a charge of type 'Rent' will be visible with a
description of 'Rental'.
4. Renew the item
5. Check fines, a charge of type 'Rent' will be visible with a
description of 'Renewal of Rental Item TITLE BARCODE' where TITLE and
BARCODE are the items title and barcode.
5. Apply the patch
6. Repeat steps 1-4, charge descriptions should now be empty and charge
types should display 'Rental fee' and 'Renewal of rental item'.
7. Repeat steps 1-6 for an item type with a daily rental charge and note
the charge types are now 'Daily rental fee' and 'Renewal of daily rental
item'

Signed-off-by: Martin Renvoize <martin.renvoize@ptfs-europe.com>

Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>
Comment 51 Kyle M Hall 2019-05-31 11:23:02 UTC
Created attachment 90232 [details] [review]
Bug 11573: Update existing accountlines for 'Rent'

Signed-off-by: Martin Renvoize <martin.renvoize@ptfs-europe.com>

Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>
Comment 52 Kyle M Hall 2019-05-31 11:23:06 UTC
Created attachment 90233 [details] [review]
Bug 11573: Update of unit tests

This patch updates the unit tests to reflect the changes to the core
routines.  The relevant changes are the removal of a hard coded
'description' and the splitting up of the 'Rent' accounttype into
'RENT', 'RENT_RENEW', 'RENT_DAILY' and 'RENT_DAILY_RENEW'.

Signed-off-by: Martin Renvoize <martin.renvoize@ptfs-europe.com>

Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>
Comment 53 Kyle M Hall 2019-05-31 11:23:10 UTC
Created attachment 90234 [details] [review]
Bug 11573: (follow-up) Correction to accountype search on opac-user.pl

With the update of accountype from 'Rent' to four distinct accountypes
we need to update the search here to catch all four types of charge.

Signed-off-by: Martin Renvoize <martin.renvoize@ptfs-europe.com>

Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>
Comment 54 Arthur Bousquet 2019-05-31 18:55:41 UTC
Created attachment 90246 [details] [review]
Update release notes for the 19.05.00 release

Signed-off-by: Nick Clemens <nick@bywatersolutions.com>
Comment 55 Katrin Fischer 2019-05-31 19:04:35 UTC
Hi Arthur, I think something went wrong here - the last file should not be attached here. Let me know if I can help
Comment 56 Arthur Bousquet 2019-05-31 19:38:27 UTC
Created attachment 90256 [details] [review]
Update release notes for the 19.05.00 release

Signed-off-by: Nick Clemens <nick@bywatersolutions.com>
Comment 57 Martin Renvoize 2019-06-04 10:37:53 UTC
Created attachment 90313 [details] [review]
Bug 11573: Make rental accountlines translatable

To test:

1. Set up an item type with a rental charge
2. Issue an item with that item type
3. Check fines, a charge of type 'Rent' will be visible with a
description of 'Rental'.
4. Renew the item
5. Check fines, a charge of type 'Rent' will be visible with a
description of 'Renewal of Rental Item TITLE BARCODE' where TITLE and
BARCODE are the items title and barcode.
5. Apply the patch
6. Repeat steps 1-4, charge descriptions should now be empty and charge
types should display 'Rental fee' and 'Renewal of rental item'.
7. Repeat steps 1-6 for an item type with a daily rental charge and note
the charge types are now 'Daily rental fee' and 'Renewal of daily rental
item'

Signed-off-by: Martin Renvoize <martin.renvoize@ptfs-europe.com>
Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>
Comment 58 Martin Renvoize 2019-06-04 10:37:57 UTC
Created attachment 90314 [details] [review]
Bug 11573: Update existing accountlines for 'Rent'

Signed-off-by: Martin Renvoize <martin.renvoize@ptfs-europe.com>
Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>
Comment 59 Martin Renvoize 2019-06-04 10:38:01 UTC
Created attachment 90315 [details] [review]
Bug 11573: Update of unit tests

This patch updates the unit tests to reflect the changes to the core
routines.  The relevant changes are the removal of a hard coded
'description' and the splitting up of the 'Rent' accounttype into
'RENT', 'RENT_RENEW', 'RENT_DAILY' and 'RENT_DAILY_RENEW'.

Signed-off-by: Martin Renvoize <martin.renvoize@ptfs-europe.com>
Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>
Comment 60 Martin Renvoize 2019-06-04 10:38:06 UTC
Created attachment 90316 [details] [review]
Bug 11573: (follow-up) Correction to accountype search on opac-user.pl

With the update of accountype from 'Rent' to four distinct accountypes
we need to update the search here to catch all four types of charge.

Signed-off-by: Martin Renvoize <martin.renvoize@ptfs-europe.com>
Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>
Comment 61 Martin Renvoize 2019-07-15 14:15:31 UTC
Created attachment 91529 [details] [review]
Bug 11573: Make rental accountlines translatable

To test:

1. Set up an item type with a rental charge
2. Issue an item with that item type
3. Check fines, a charge of type 'Rent' will be visible with a
description of 'Rental'.
4. Renew the item
5. Check fines, a charge of type 'Rent' will be visible with a
description of 'Renewal of Rental Item TITLE BARCODE' where TITLE and
BARCODE are the items title and barcode.
5. Apply the patch
6. Repeat steps 1-4, charge descriptions should now be empty and charge
types should display 'Rental fee' and 'Renewal of rental item'.
7. Repeat steps 1-6 for an item type with a daily rental charge and note
the charge types are now 'Daily rental fee' and 'Renewal of daily rental
item'

Signed-off-by: Martin Renvoize <martin.renvoize@ptfs-europe.com>
Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>
Comment 62 Martin Renvoize 2019-07-15 14:15:35 UTC
Created attachment 91530 [details] [review]
Bug 11573: Update existing accountlines for 'Rent'

Signed-off-by: Martin Renvoize <martin.renvoize@ptfs-europe.com>
Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>
Comment 63 Martin Renvoize 2019-07-15 14:15:39 UTC
Created attachment 91531 [details] [review]
Bug 11573: Update of unit tests

This patch updates the unit tests to reflect the changes to the core
routines.  The relevant changes are the removal of a hard coded
'description' and the splitting up of the 'Rent' accounttype into
'RENT', 'RENT_RENEW', 'RENT_DAILY' and 'RENT_DAILY_RENEW'.

Signed-off-by: Martin Renvoize <martin.renvoize@ptfs-europe.com>
Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>
Comment 64 Martin Renvoize 2019-07-15 14:15:43 UTC
Created attachment 91532 [details] [review]
Bug 11573: (follow-up) Correction to accountype search on opac-user.pl

With the update of accountype from 'Rent' to four distinct accountypes
we need to update the search here to catch all four types of charge.

Signed-off-by: Martin Renvoize <martin.renvoize@ptfs-europe.com>
Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>
Comment 65 Martin Renvoize 2019-07-15 14:16:01 UTC
Freshly rebased and ready for QA
Comment 66 Martin Renvoize 2019-07-26 11:53:39 UTC
Created attachment 91800 [details] [review]
Bug 11573: (follow-up) Handle daily rental in db update
Comment 67 Nick Clemens 2019-07-26 12:33:43 UTC
Created attachment 91801 [details] [review]
Bug 11573: Make rental accountlines translatable

To test:

1. Set up an item type with a rental charge
2. Issue an item with that item type
3. Check fines, a charge of type 'Rent' will be visible with a
description of 'Rental'.
4. Renew the item
5. Check fines, a charge of type 'Rent' will be visible with a
description of 'Renewal of Rental Item TITLE BARCODE' where TITLE and
BARCODE are the items title and barcode.
5. Apply the patch
6. Repeat steps 1-4, charge descriptions should now be empty and charge
types should display 'Rental fee' and 'Renewal of rental item'.
7. Repeat steps 1-6 for an item type with a daily rental charge and note
the charge types are now 'Daily rental fee' and 'Renewal of daily rental
item'

Signed-off-by: Martin Renvoize <martin.renvoize@ptfs-europe.com>
Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>

Signed-off-by: Nick Clemens <nick@bywatersolutions.com>
Comment 68 Nick Clemens 2019-07-26 12:33:47 UTC
Created attachment 91802 [details] [review]
Bug 11573: Update existing accountlines for 'Rent'

Signed-off-by: Martin Renvoize <martin.renvoize@ptfs-europe.com>
Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>

Signed-off-by: Nick Clemens <nick@bywatersolutions.com>
Comment 69 Nick Clemens 2019-07-26 12:33:51 UTC
Created attachment 91803 [details] [review]
Bug 11573: Update of unit tests

This patch updates the unit tests to reflect the changes to the core
routines.  The relevant changes are the removal of a hard coded
'description' and the splitting up of the 'Rent' accounttype into
'RENT', 'RENT_RENEW', 'RENT_DAILY' and 'RENT_DAILY_RENEW'.

Signed-off-by: Martin Renvoize <martin.renvoize@ptfs-europe.com>
Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>

Signed-off-by: Nick Clemens <nick@bywatersolutions.com>
Comment 70 Nick Clemens 2019-07-26 12:33:55 UTC
Created attachment 91804 [details] [review]
Bug 11573: (follow-up) Correction to accountype search on opac-user.pl

With the update of accountype from 'Rent' to four distinct accountypes
we need to update the search here to catch all four types of charge.

Signed-off-by: Martin Renvoize <martin.renvoize@ptfs-europe.com>
Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>

Signed-off-by: Nick Clemens <nick@bywatersolutions.com>
Comment 71 Nick Clemens 2019-07-26 12:34:00 UTC
Created attachment 91805 [details] [review]
Bug 11573: (follow-up) Handle daily rental in db update

Signed-off-by: Nick Clemens <nick@bywatersolutions.com>
Comment 72 Nick Clemens 2019-07-26 12:34:04 UTC
Created attachment 91806 [details] [review]
Bug 11573: (QA follow-up) Correct spelling typo

Signed-off-by: Nick Clemens <nick@bywatersolutions.com>
Comment 73 Martin Renvoize 2019-07-26 15:19:04 UTC
Nice work!

Pushed to master for 19.11.00
Comment 74 Fridolin SOMERS 2019-08-09 12:44:19 UTC
Depends on Bug 19919 not in 19.05.x