Bug 15273

Summary: Fines Payment receipt should include all account lines selected for this pay
Product: Koha Reporter: Claudio <costalc>
Component: CirculationAssignee: Bugs List <koha-bugs>
Status: CLOSED FIXED QA Contact: Testopia <testopia>
Severity: enhancement    
Priority: P5 - low CC: black23, gmcharlt, josef.moravec, katrin.fischer, kyle.m.hall, marjorie.barry-vila, nengard, sally.healey, savitra.sirohi
Version: master   
Hardware: All   
OS: All   
See Also: http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=14825
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=2696
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19191
Change sponsored?: --- Patch complexity: ---
Documentation contact: Documentation submission:
Text to go in the release notes:
Version(s) released in:
Bug Depends on: 14826    
Bug Blocks:    
Attachments: Pay receipt

Description Claudio 2015-12-01 21:26:10 UTC
The fines payment process needs that the generated payment receipt contains all account lines selected for this payment. At now, it informs a laconic "Thanks". So all accounts lines selected and payed must be included in the payment receipt. Thus, librarians could print in only one receipt (the PAY one) all the accounts lines payed.
Comment 1 Katrin Fischer 2015-12-02 23:20:58 UTC
I am not sure if this is possible with the way we currently store the data.
Comment 2 Claudio 2015-12-02 23:51:48 UTC
So there's no way to generate a single receipt of all accounts paid when the payment is triggered... what a pity...
Comment 3 Claudio 2015-12-02 23:52:34 UTC
Created attachment 45344 [details]
Pay receipt
Comment 4 Claudio 2015-12-02 23:54:20 UTC
it is realy anti intuitive...
Comment 5 Josef Moravec 2015-12-03 07:58:10 UTC
I think it depends on bud 14826 - this should introduce table to link payments to fines.
Comment 6 Claudio 2015-12-03 12:56:13 UTC
I understand. #14826 is a structural change to prepare tables for future enhancements (i.e. payment receipt with detail information). I will mark as duplicate #15273.
Comment 7 Katrin Fischer 2015-12-03 12:57:41 UTC
Hi bondiurbano,

I think it's worth having this bug open, as it shows what we need to do after we got the linked bugs resolved.
Comment 8 Claudio 2015-12-03 13:05:48 UTC
Thanks Katrin.
Comment 9 Katrin Fischer 2017-01-05 09:55:14 UTC
*** Bug 7565 has been marked as a duplicate of this bug. ***
Comment 10 Katrin Fischer 2018-04-21 09:57:34 UTC
With the reinstated account_offsets table this will be finally in reach. 
See also bug 2696 and bug 19191.
Comment 11 Claudio 2018-05-31 00:28:36 UTC
Now that the account_offsets table is ready, is there a chance to go on with this ticket?
Comment 12 Katrin Fischer 2018-05-31 22:16:03 UTC
The base is there, but it will need someone to sponsor or work on the development.
Comment 13 Claudio 2018-08-21 18:13:21 UTC
No volunteers for this ticket?
Comment 14 Katrin Fischer 2019-02-10 02:04:53 UTC
*** Bug 5655 has been marked as a duplicate of this bug. ***
Comment 15 Katrin Fischer 2020-01-08 21:48:07 UTC
I think this is supposed to work with ACCOUNT_DEBIT and ACCOUNT_CREDIT now, but I have some trouble testing, see bug 24381