Bug 15920

Summary: Clean up and fix errors in batch checkout template
Product: Koha Reporter: Owen Leonard <oleonard>
Component: TemplatesAssignee: Owen Leonard <oleonard>
Status: CLOSED FIXED QA Contact: Testopia <testopia>
Severity: minor    
Priority: P5 - low CC: brendan, gwilliams, hector.hecaxmmx, julian.maurice
Version: master   
Hardware: All   
OS: All   
See Also: https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15718
Change sponsored?: --- Patch complexity: Small patch
Who signed the patch off: Text to go in the release notes:
Version(s) released in:
Bug Depends on:    
Bug Blocks: 15718, 15937, 15918    
Attachments: Bug 15920 - Clean up and fix errors in batch checkout template
Buggy checkout batch
Checked-out table result
[SIGNED-OFF]Bug 15920: Clean up and fix errors in batch checkout template
Bug 15920: Clean up and fix errors in batch checkout template

Description Owen Leonard 2016-02-25 18:58:34 UTC
The batch checkout template has some JavaScript and markup errors which should be corrected.
Comment 1 Owen Leonard 2016-02-25 19:11:58 UTC Comment hidden (obsolete)
Comment 2 Héctor Eduardo Castro Avalos 2016-02-26 17:15:42 UTC
Created attachment 48411 [details]
Buggy checkout batch

Hi Owen

For damaged items the warning message is not displayed, and Koha let to checkout the item as shown in the image.

I notice about a buggy behavor in this functionallity, for example the program let to checkout the first item available without confirm the checkout message, for example, Maxwell's handbook was borrowed/renewed to this patron every time in which I repeat the process.
Comment 3 Héctor Eduardo Castro Avalos 2016-02-26 17:32:37 UTC
Created attachment 48412 [details]
Checked-out table result

When the process end, you will presented with this table (see image attached), one items was checked-out and the others wasn't, but the message is not clear whether those items was checked out or not.

Another thing that I could observe is that in my circ policies I don't have set a fine amount and the program is charging $5.00 to all my check-outs, but I think this is a bug in the circulation and fine policies.
Comment 4 Owen Leonard 2016-02-26 17:59:40 UTC
Thanks for testing Héctor. Just to be clear: Are these problems caused by my patch? See also Bug 15718.
Comment 5 Héctor Eduardo Castro Avalos 2016-02-26 19:51:45 UTC
> Thanks for testing Héctor. Just to be clear: Are these problems caused by my
> patch? See also Bug 15718.

Ahhh, Ok I understand. You're right, the problem persist without your patch. I did the same without your patch and gave me the some results.

The make up you did it is much better in addition to the problems you fixed it up.
Comment 6 Héctor Eduardo Castro Avalos 2016-02-26 19:54:23 UTC Comment hidden (obsolete)
Comment 7 Jonathan Druart 2016-02-29 12:02:48 UTC
Created attachment 48446 [details] [review]
Bug 15920: Clean up and fix errors in batch checkout template

The batch checkout template has some markup and JavaScript problems
which need to be resolved, including:

- Mismatched <h3></h1>
- JavaScript includes which are not used
- Incorrect DataTables configuration
- Incorrect class on warning dialogs
- Incorrect terminology: Use "checkout" instead of "issue"

This patch also changes the markup and styling of batch checkout errors,
using Font Awesome icons to retain highlighting of warnings and errors
while (I hope) improving readability.

To test, apply the patch and go to batch checkout for a patron for whom
batch checkouts are enabled.

- Check out a batch of barcodes. Include items which will trigger errors
  or warnings. For example: Invalid barcodes, lost items, items which
  are already checked out, items which are on hold for another patron,
  items which are damaged.

- When the table of items is displayed so that you can confirm the
  checkout, make sure the table is sortable.

- Think about whether the style changes on warnings and errors are an
  improvement.

- Try to initiate a batch checkout to a patron who is restricted. You
  should see an "alert" style dialog instead of a "message" style one.

- Validate the HTML and confirm that there are no errors raised by this
  template's markup.

Signed-off-by: Hector Castro <hector.hecaxmmx@gmail.com>
Works as described

Signed-off-by: Jonathan Druart <jonathan.druart@bugs.koha-community.org>
Comment 8 Brendan Gallagher 2016-03-02 01:07:01 UTC
Pushed to Master - should be in the May 2016 Release.  Thanks!
Comment 9 Julian Maurice 2016-03-07 12:55:41 UTC
Patch pushed to 3.22.x, will be in 3.22.5