Bug 19073

Summary: Can't change library with patron batch modification tool
Product: Koha Reporter: Katrin Fischer <katrin.fischer>
Component: ToolsAssignee: Alex Sassmannshausen <alex>
Status: CLOSED FIXED QA Contact: Testopia <testopia>
Severity: major    
Priority: P5 - low CC: bob, fridolin.somers, jonathan.druart, jzairo, mtj
Version: master   
Hardware: All   
OS: All   
Change sponsored?: --- Patch complexity: Trivial patch
Who signed the patch off: Text to go in the release notes:
Version(s) released in:
Bug Depends on: 15758    
Bug Blocks:    
Attachments: Bug 19074: bugfix: Dereference correct value from Koha::Object.
Bug 19073: bugfix: Dereference correct value from Koha::Object.
[SIGNED OFF] Bug 19073: bugfix: Dereference correct value from Koha::Object.
Bug 19073: (bug 15758 follow-up) Dereference correct value from Koha::Object.

Description Katrin Fischer 2017-08-10 09:59:24 UTC
It appears that the option to change a users homebranch with the patron batch modification tool is broken.

To test:
- Install Koha sample patrons
- Search all patrons (empty search) and add them to a patron list
- Go to the patron batch modification tool
- Select your list
- Change branch to Centerville
- Save
- Verify Koha shows the result list, but that the branch hasn't been changed.
Comment 1 Alex Sassmannshausen 2017-08-10 11:09:53 UTC
Created attachment 65799 [details] [review]
Bug 19074: bugfix: Dereference correct value from Koha::Object.

* tools/modborrowers.pl: Dereference 'branchcode' rather than
  'value'.

Test Plan:
- Carry out "Batch patron modification" with any number of patrons.
  + Change the library.
  + Hit Save.
- The library will not have been updated.
- Apply patch.
- Run same modification.
- The library will have been updated
Comment 2 Alex Sassmannshausen 2017-08-10 11:38:26 UTC
Created attachment 65801 [details] [review]
Bug 19073: bugfix: Dereference correct value from Koha::Object.

* tools/modborrowers.pl: Dereference 'branchcode' rather than
  'value'.

Test Plan:
- Carry out "Batch patron modification" with any number of patrons.
  + Change the library.
  + Hit Save.
- The library will not have been updated.
- Apply patch.
- Run same modification.
- The library will have been updated
Comment 3 Katrin Fischer 2017-08-10 11:55:19 UTC
Created attachment 65805 [details] [review]
[SIGNED OFF] Bug 19073: bugfix: Dereference correct value from Koha::Object.

* tools/modborrowers.pl: Dereference 'branchcode' rather than
  'value'.

Test Plan:
- Carry out "Batch patron modification" with any number of patrons.
  + Change the library.
  + Hit Save.
- The library will not have been updated.
- Apply patch.
- Run same modification.
- The library will have been updated

https://bugs.koha-community.org/show_bug.cgi?id=19073

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 4 Jonathan Druart 2017-08-10 18:25:01 UTC
Caused by:
  commit 9b9803b69c8bde879768ccfa3cc4688ef46b7799
    Bug 15758: Koha::Libraries - Remove GetBranchesLoop
Comment 5 Jonathan Druart 2017-08-10 18:28:05 UTC
Created attachment 65841 [details] [review]
Bug 19073: (bug 15758 follow-up) Dereference correct value from Koha::Object.

* tools/modborrowers.pl: Dereference 'branchcode' rather than
  'value'.

Test Plan:
- Carry out "Batch patron modification" with any number of patrons.
  + Change the library.
  + Hit Save.
- The library will not have been updated.
- Apply patch.
- Run same modification.
- The library will have been updated

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>

Signed-off-by: Jonathan Druart <jonathan.druart@bugs.koha-community.org>
Comment 6 Jonathan Druart 2017-08-10 18:29:31 UTC
This is a bad one, it affects 16.11.x and 17.05.x
Comment 7 Jonathan Druart 2017-08-10 19:32:36 UTC
Pushed to master for 17.11, thanks to everybody involved!
Comment 8 Fridolin SOMERS 2017-09-12 14:42:28 UTC
Pushed to 17.05.x, will be in 17.05.04.
Comment 9 Katrin Fischer 2017-09-16 06:52:28 UTC
This patch has been pushed to 16.11.x and will be in 16.11.12.
Comment 10 Mason James 2017-11-23 21:28:46 UTC
Pushed to 16.05.x, for 16.05.17 release
Comment 11 Katrin Fischer 2020-04-19 12:28:56 UTC
*** Bug 18792 has been marked as a duplicate of this bug. ***