Bug 6347

Summary: Bug in opac-reserve.pl stopping item level holds
Product: Koha Reporter: Chris Cormack <chris>
Component: OPACAssignee: Owen Leonard <oleonard>
Status: CLOSED FIXED QA Contact: Bugs List <koha-bugs>
Severity: enhancement    
Priority: PATCH-Sent (DO NOT USE) CC: katrin.fischer, lculber, magnus
Version: 3.4   
Hardware: All   
OS: All   
Change sponsored?: --- Patch complexity: ---
Who signed the patch off: Text to go in the release notes:
Version(s) released in:
Bug Depends on:    
Bug Blocks: 5917, 6353    
Attachments: Proposed Patch
Screenshot of broken table
Screenshot of error message 'no item was selected'
Revised fix
Signed-off patch

Description Chris Cormack 2011-05-16 21:25:53 UTC

    
Comment 1 Chris Cormack 2011-05-16 21:32:38 UTC Comment hidden (obsolete)
Comment 2 Katrin Fischer 2011-05-19 20:42:04 UTC
Created attachment 4197 [details]
Screenshot of broken table

Patch applies, but there are some problems:

1) Table width and cells are broken once you click on specific hold.

2) When I tried to place my hold I always got 'No item was selected'.
Comment 3 Katrin Fischer 2011-05-19 20:43:32 UTC
Created attachment 4198 [details]
Screenshot of error message 'no item was selected'
Comment 4 Owen Leonard 2011-05-20 13:43:02 UTC Comment hidden (obsolete)
Comment 5 Katrin Fischer 2011-05-20 20:58:52 UTC
Created attachment 4210 [details] [review]
Signed-off patch
Comment 6 Chris Cormack 2011-05-29 03:48:24 UTC
Simple template::toolkit issue, pushed please test
Comment 7 lculber 2011-06-10 16:34:46 UTC
We tested this in 3.4.1  and it worked beautifully for us.
Comment 8 Magnus Enger 2011-07-16 09:39:02 UTC
Table looks good, no error when placing hold.