Bug 6347 - Bug in opac-reserve.pl stopping item level holds
Summary: Bug in opac-reserve.pl stopping item level holds
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: OPAC (show other bugs)
Version: 3.4
Hardware: All All
: PATCH-Sent (DO NOT USE) enhancement (vote)
Assignee: Owen Leonard
QA Contact: Bugs List
URL:
Keywords:
Depends on:
Blocks: 5917 6353
  Show dependency treegraph
 
Reported: 2011-05-16 21:25 UTC by Chris Cormack
Modified: 2012-10-25 23:09 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Proposed Patch (5.06 KB, patch)
2011-05-16 21:32 UTC, Chris Cormack
Details | Diff | Splinter Review
Screenshot of broken table (35.09 KB, image/png)
2011-05-19 20:42 UTC, Katrin Fischer
Details
Screenshot of error message 'no item was selected' (62.51 KB, image/png)
2011-05-19 20:43 UTC, Katrin Fischer
Details
Revised fix (5.59 KB, patch)
2011-05-20 13:43 UTC, Owen Leonard
Details | Diff | Splinter Review
Signed-off patch (5.72 KB, patch)
2011-05-20 20:58 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Cormack 2011-05-16 21:25:53 UTC

    
Comment 1 Chris Cormack 2011-05-16 21:32:38 UTC Comment hidden (obsolete)
Comment 2 Katrin Fischer 2011-05-19 20:42:04 UTC
Created attachment 4197 [details]
Screenshot of broken table

Patch applies, but there are some problems:

1) Table width and cells are broken once you click on specific hold.

2) When I tried to place my hold I always got 'No item was selected'.
Comment 3 Katrin Fischer 2011-05-19 20:43:32 UTC
Created attachment 4198 [details]
Screenshot of error message 'no item was selected'
Comment 4 Owen Leonard 2011-05-20 13:43:02 UTC Comment hidden (obsolete)
Comment 5 Katrin Fischer 2011-05-20 20:58:52 UTC
Created attachment 4210 [details] [review]
Signed-off patch
Comment 6 Chris Cormack 2011-05-29 03:48:24 UTC
Simple template::toolkit issue, pushed please test
Comment 7 lculber 2011-06-10 16:34:46 UTC
We tested this in 3.4.1  and it worked beautifully for us.
Comment 8 Magnus Enger 2011-07-16 09:39:02 UTC
Table looks good, no error when placing hold.