Bug 7300

Summary: display suggestions from librarian library only by default
Product: Koha Reporter: claire.hernandez <claire.hernandez>
Component: AcquisitionsAssignee: Matthias Meusburger <matthias.meusburger>
Status: CLOSED FIXED QA Contact: Ian Walls <koha.sekjal>
Severity: enhancement    
Priority: P5 - low CC: alexandre.lengereau, cbrannon, chris, danielle.cristofol, katrin.fischer, kyle, matthias.meusburger, nengard, paul.poulain, robin, veron
Version: 3.8   
Hardware: All   
OS: All   
Change sponsored?: Sponsored Patch complexity: ---
Text to go in the release notes:
Version(s) released in:
Bug Depends on:    
Bug Blocks: 7163, 8274, 9840    
Attachments: proposed patch
proposed patch

Description claire.hernandez@biblibre.com 2011-12-02 09:49:46 UTC
Suggestions  : by default, let the librarian see only suggestions made by patrons of his library. The patron can choose to see other's as well, it's just the default	(BibLibre MT 6842)
Comment 1 Matthias Meusburger 2012-03-02 13:43:40 UTC Comment hidden (obsolete)
Comment 2 Alexandre Lengereau 2012-03-19 15:59:43 UTC
The sandbox you've requested is now ready. The patches attached to bugzilla 7300 have been applied, and the result is
<h1>Something went wrong !</h1>Applying: BZ7300 : Show working branch suggestions by default<br/>
Using index info to reconstruct a base tree...<br/>
Falling back to patching base and 3-way merge...<br/>
Auto-merging suggestion/suggestion.pl<br/>
CONFLICT (content): Merge conflict in suggestion/suggestion.pl<br/>
Failed to merge in the changes.<br/>
Patch failed at 0001 BZ7300 : Show working branch suggestions by default<br/>
When you have resolved this problem run git am --resolved.<br/>
If you would prefer to skip this patch, instead run git am --skip.<br/>
To restore the original branch and stop patching run git am --abort.<br/>
Bug 7300 - display suggestions from librarian library only by default<br/>
<br/>
proposed patch<br/>
Apply? [yn] <br/>
Patch left in /tmp/proposed-patch-LU4JkC.patch<br/>
<br/>=== translation installation ===<br/>Install templates
  Install templates 'opac
    From: /home/koha/src/koha-tmpl/opac-tmpl/prog/en/
    To  : /home/koha/src/koha-tmpl/opac-tmpl/prog/fr-FR
    With: /home/koha/src/misc/translator/po/fr-FR-i-opac-t-prog-v-3006000.po
The install seems to be successful.
  Install templates 'intranet
    From: /home/koha/src/koha-tmpl/intranet-tmpl/prog/en/
    To  : /home/koha/src/koha-tmpl/intranet-tmpl/prog/fr-FR
    With: /home/koha/src/misc/translator/po/fr-FR-i-staff-t-prog-v-3006000.po
The install seems to be successful.

If you use this system for the 1st time, you may find usefull to reach the wiki page http://wiki.koha-community.org/wiki/Sandboxes to have some information about those results, to check if everything went well & if you can test the patch properly
Comment 3 Matthias Meusburger 2012-03-20 13:15:33 UTC
Created attachment 8352 [details] [review]
proposed patch

conflicts fixed
Comment 4 danielle.cristofol 2012-03-20 14:09:35 UTC
Test OK
Create suggestion by patron from another branch
Suggestion not seen in suggestion modul
Comment 5 Paul Poulain 2012-03-22 05:02:00 UTC
QA comment:
* most of this patch is related to some code cleaning, reindenting,...
* works as announced
* change the default behaviour, should be in 3.8 only, and clearly stated in release notes

passed QA
Comment 6 Nicole C. Engard 2012-03-27 19:16:02 UTC
I see no indication on the suggestions page that I'm only seeing suggestions made at my branch. I think that the librarians should know that they're not seeing all suggestions by default and that they need to do a suggestions search to see more - or am I missing something?

Nicole
Comment 7 Robin Sheat 2012-08-30 12:40:18 UTC
Yeah, I've just had someone confused by this too. There's no indication that it's restricted to the current branch, or what you should do to show all the other suggestions (for reference, if you change "organise by" to branch, then you can see everything.)

This is an unfortunate hiding of information. At the least some on-screen doc should explain what's happening, or have something that lets you toggle between showing only one branch and showing all of them.
Comment 8 Katrin Fischer 2012-08-30 12:56:48 UTC
I am a bit worried about this too - I even think it should be a pref, because workflows in libraries are different and there might well be a situation where someone in a central place takes care of managing suggestions. 
I think we need at least a follow-up.
Comment 9 Nicole C. Engard 2012-08-30 13:24:19 UTC
I agree with Katrin - a preference is needed.  Almost every library we support has contacted me to ask what's going on.  Also, after you approve or reject a comment it goes back to showing only the current branch even if you filtered on all branches before - a very difficult workflow.

I kind of feel like this is a regression.
Comment 10 Marc VĂ©ron 2012-09-24 06:45:24 UTC
I agree with Katrin and Nicole that there should be a syspref.
Comment 11 Kyle M Hall 2012-09-24 13:22:52 UTC
(In reply to comment #8)
> I am a bit worried about this too - I even think it should be a pref,
> because workflows in libraries are different and there might well be a
> situation where someone in a central place takes care of managing
> suggestions. 
> I think we need at least a follow-up.

Yes, definitely make this a system-preference controlled behavior.
Comment 12 Christopher Brannon 2012-09-28 18:24:52 UTC
I agree that this should be a preference.  I also think this preference should make the counter reflect an accurate number.  If you are switched to branch moderation, you should only see a count for your branch, rather than the count for all requests.

Christopher Brannon
Coeur d'Alene Public Library
Comment 13 Chris Cormack 2013-03-18 23:08:30 UTC
This enhancement is causing real problems for a few of our libraries, I will report a bug for fixing it to be controlled by a system preference

A lot of libraries want to be able to see all suggestions and with this patch having been pushed they can no longer do that.

And as is the rule once a feature is pushed, bug fixes to it must be on their own bug